aboutsummaryrefslogtreecommitdiff
path: root/emulators/gxemul/Makefile
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2016-01-31 21:46:24 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2016-01-31 21:46:24 +0000
commitb2c43980fbc2211b2abc8ae78c5c1c92d3b9394f (patch)
treed41e6288f30544fe0b1745abdd33d04565eceeab /emulators/gxemul/Makefile
parentc53fb64def63031276e963992db9934361cb9d92 (diff)
downloadports-b2c43980fbc2211b2abc8ae78c5c1c92d3b9394f.tar.gz
ports-b2c43980fbc2211b2abc8ae78c5c1c92d3b9394f.zip
- Switch to options helpers
- Regenerate patches with `make makepatch`
Notes
Notes: svn path=/head/; revision=407669
Diffstat (limited to 'emulators/gxemul/Makefile')
-rw-r--r--emulators/gxemul/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/emulators/gxemul/Makefile b/emulators/gxemul/Makefile
index 7f9d4f446d36..336d343553c1 100644
--- a/emulators/gxemul/Makefile
+++ b/emulators/gxemul/Makefile
@@ -40,10 +40,12 @@ post-patch:
/CXXFLAGS=/s|-f[a-zA-Z-]+||g' ${WRKSRC}/configure
do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} gxemul \
- ${STAGEDIR}${PREFIX}/bin)
- (cd ${WRKSRC}/man && ${INSTALL_MAN} gxemul.1 \
- ${STAGEDIR}${MAN1PREFIX}/man/man1)
+ ${INSTALL_PROGRAM} ${WRKSRC}/gxemul \
+ ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/man/gxemul.1 \
+ ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
@(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . \
${STAGEDIR}${DOCSDIR})