aboutsummaryrefslogtreecommitdiff
path: root/emulators/gxemul/Makefile
diff options
context:
space:
mode:
authorWarner Losh <imp@FreeBSD.org>2005-12-31 04:57:23 +0000
committerWarner Losh <imp@FreeBSD.org>2005-12-31 04:57:23 +0000
commitde810f3771404a4839a42a9ca305c0e908a1c91e (patch)
tree7d34234d93264d4e55dfef9d7a04e01e0f47cf2b /emulators/gxemul/Makefile
parentb587769d8713a87c9372f5258da0898265845ddb (diff)
downloadports-de810f3771404a4839a42a9ca305c0e908a1c91e.tar.gz
ports-de810f3771404a4839a42a9ca305c0e908a1c91e.zip
Update to 0.3.7 from 0.3.2. See
http://gavare.se/gxemul/gxemul-stable/HISTORY.html for a long changelog between these releases. Summary: vastly improved arm, mips and ppc support. Lots of new CPUs and a better dynamic code generator for the instructions emulated. Vastly improved hardware device emulation. Can boot many free and obscure guest operating systems.
Notes
Notes: svn path=/head/; revision=152470
Diffstat (limited to 'emulators/gxemul/Makefile')
-rw-r--r--emulators/gxemul/Makefile67
1 files changed, 60 insertions, 7 deletions
diff --git a/emulators/gxemul/Makefile b/emulators/gxemul/Makefile
index 18994711ca30..1a864b2db659 100644
--- a/emulators/gxemul/Makefile
+++ b/emulators/gxemul/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gxemul
-PORTVERSION= 0.3.2
+PORTVERSION= 0.3.7
CATEGORIES= emulators
MASTER_SITES= http://gavare.se/gxemul/src/
@@ -28,14 +28,21 @@ OPTIONS= ALWAYS32 "ALWAYS_SIGNEXTEND_32" off \
BINTRANS "bintrans" on \
CACHES "cache emulation (experimental)" off \
DELAYS "instruction latency/delay emulation" off \
+ TRACENULL "tracenull support" off \
X "X11 support" on \
ALPHA "Alpha CPU emulation" off \
+ ARM "ARM CPU emulation" on \
+ AVR "AVR CPU emulation" off \
HPPA "HPPA CPU emulation" off \
+ I960 "i960 CPU emulation" off \
+ IA64 "ia64 CPU emulation" off \
+ M86K "m68k CPU emulation" off \
MIPS "MIPS CPU emulation" on \
PPC "PPC CPU emulation" on \
+ SH "SH CPU emulation" off \
SPARC "SPARC CPU emulation" off \
- URISC "URISC CPU emulation" on \
X86 "x86 CPU emulation" off \
+ NEWMIPS "NEWMIPS CPU emulation (experimental)" off \
MIPS16 "MIPS16 instruction support (experimental)" off
.include <bsd.port.pre.mk>
@@ -52,6 +59,9 @@ CONFIGURE_ARGS+=--enable-caches
.if defined(WITH_DELAYS)
CONFIGURE_ARGS+=--enable-delays
.endif
+.if defined(WITH_TRACENULL)
+CONFIGURE_ARGS+=--tracenull
+.endif
.if defined(WITH_X)
USE_XLIB= yes
.else
@@ -59,24 +69,67 @@ CONFIGURE_ARGS+=--disable-x
.endif
.if defined(WITH_ALPHA)
CONFIGURE_ARGS+=--enable-alpha
+.else
+CONFIGURE_ARGS+=--disable-alpha
+.endif
+.if defined(WITH_ARM)
+CONFIGURE_ARGS+=--enable-arm
+.else
+CONFIGURE_ARGS+=--disable-arm
+.endif
+.if defined(WITH_AVR)
+CONFIGURE_ARGS+=--enable-avr
+.else
+CONFIGURE_ARGS+=--disable-avr
.endif
.if defined(WITH_HPPA)
CONFIGURE_ARGS+=--enable-hppa
+.else
+CONFIGURE_ARGS+=--disable-hppa
+.endif
+.if defined(WITH_I960)
+CONFIGURE_ARGS+=--enable-i960
+.else
+CONFIGURE_ARGS+=--disable-i960
+.endif
+.if defined(WITH_IA64)
+CONFIGURE_ARGS+=--enable-ia64
+.else
+CONFIGURE_ARGS+=--disable-ia64
.endif
-.if !defined(WITH_MIPS)
+.if defined(WITH_M68K)
+CONFIGURE_ARGS+=--enable-m68k
+.else
+CONFIGURE_ARGS+=--disable-m68k
+.endif
+.if defined(WITH_MIPS)
+CONFIGURE_ARGS+=--enable-mips
+.else
CONFIGURE_ARGS+=--disable-mips
.endif
-.if !defined(WITH_PPC)
+.if defined(WITH_PPC)
+CONFIGURE_ARGS+=--enable-ppc
+.else
CONFIGURE_ARGS+=--disable-ppc
.endif
+.if defined(WITH_SH)
+CONFIGURE_ARGS+=--enable-sh
+.else
+CONFIGURE_ARGS+=--disable-sh
+.endif
.if defined(WITH_SPARC)
CONFIGURE_ARGS+=--enable-sparc
-.endif
-.if !defined(WITH_URISC)
-CONFIGURE_ARGS+=--disable-urisc
+.else
+CONFIGURE_ARGS+=--disable-sparc
.endif
.if defined(WITH_X86)
CONFIGURE_ARGS+=--enable-x86
+.else
+CONFIGURE_ARGS+=--disable-x86
+.endif
+
+.if defined(WITH_NEWMIPS)
+CONFIGURE_ARGS+=--enable-newmips
.endif
.if defined(WITH_MIPS16)
CONFIGURE_ARGS+=--enable-mips16