aboutsummaryrefslogtreecommitdiff
path: root/emulators/joytran/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2013-05-02 14:46:08 +0000
committerPawel Pekala <pawel@FreeBSD.org>2013-05-02 14:46:08 +0000
commit56d2b3484201a7a9cf486b02b9e548d8f56b1876 (patch)
treea321774fd7800b3d82ab04d17b9ec0fc9705c9e9 /emulators/joytran/Makefile
parent06613f44814ccfb65a102dc8e1907be054c81a5e (diff)
downloadports-56d2b3484201a7a9cf486b02b9e548d8f56b1876.tar.gz
ports-56d2b3484201a7a9cf486b02b9e548d8f56b1876.zip
Update to version 0.9.5
PR: ports/178294 Submitted by: Timothy Beyer <beyert@cs.ucr.edu> (maintainer)
Notes
Notes: svn path=/head/; revision=317125
Diffstat (limited to 'emulators/joytran/Makefile')
-rw-r--r--emulators/joytran/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/emulators/joytran/Makefile b/emulators/joytran/Makefile
index de9b46f11ea8..1d56f48160ba 100644
--- a/emulators/joytran/Makefile
+++ b/emulators/joytran/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: joytran
-# Date created: 30 Jul 2011
-# Whom: Timothy Beyer <beyert@cs.ucr.edu>
-#
+# Created by: Timothy Beyer <beyert@cs.ucr.edu>
# $FreeBSD$
-#
PORTNAME= joytran
-PORTVERSION= 0.8.7
+PORTVERSION= 0.9.5
CATEGORIES= emulators
MASTER_SITES= BERLIOS GOOGLE_CODE
MASTER_SITE_SUBDIR= joytran
@@ -17,19 +13,21 @@ COMMENT= Joystick to keyboard/mouse events translator written in C
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYRIGHT
+LIB_DEPENDS= SDL2:${PORTSDIR}/devel/sdl20
+
# This is needed to fetch from BerliOS
FETCH_ARGS= "-Fpr"
USE_BZIP2= yes
-USES= cmake
+USES= cmake pkgconfig
CMAKE_ARGS= -DLOCALBASE="${LOCALBASE}" -DPREFIX="${PREFIX}"
+USE_XORG= x11 xtst
+
+.include <bsd.port.options.mk>
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
CMAKE_ARGS+= -DINSTALL_DOCUMENTATION:BOOL=ON
.else
CMAKE_ARGS+= -DINSTALL_DOCUMENTATION:BOOL=OFF
.endif
-USE_SDL= sdl
-USE_XORG= x11 xtst
-
.include <bsd.port.mk>