aboutsummaryrefslogtreecommitdiff
path: root/emulators/joytran/files
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2012-03-30 17:48:02 +0000
committerAlex Kozlov <ak@FreeBSD.org>2012-03-30 17:48:02 +0000
commitf9dfea7ca6b1f3056d6954beadbc3812b52b1524 (patch)
treed08c7a2df6a0d661bd5fb5e83ed8ff7d6b1f358b /emulators/joytran/files
parent04d1af513e20f4363403782925d65eb7475de5b5 (diff)
downloadports-f9dfea7ca6b1f3056d6954beadbc3812b52b1524.tar.gz
ports-f9dfea7ca6b1f3056d6954beadbc3812b52b1524.zip
- Update to 0.8.7
Appropriate credits given to hosts in documentation - Install Profiles system-wide (defaults to local profiles if available) - Install Optional Documentation system-wide (depends on NOPORTDOCS) - Fix fetch with BerliOS PR: ports/166487 Submitted by: Timothy Beyer <beyert@cs.ucr.edu> (maintainer) Approved by: eadler (mentor) Feature safe: yes
Notes
Notes: svn path=/head/; revision=294000
Diffstat (limited to 'emulators/joytran/files')
-rw-r--r--emulators/joytran/files/patch-CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/emulators/joytran/files/patch-CMakeLists.txt b/emulators/joytran/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..173615a1a295
--- /dev/null
+++ b/emulators/joytran/files/patch-CMakeLists.txt
@@ -0,0 +1,22 @@
+--- CMakeLists.txt.orig 2012-03-29 01:34:41.000000000 -0700
++++ CMakeLists.txt 2012-03-29 13:24:33.000000000 -0700
+@@ -2,7 +2,6 @@
+ CMAKE_MINIMUM_REQUIRED(VERSION 2.8)
+
+ ## On means use clang, off means use gcc
+-OPTION(USE_CLANG "build with clang" ON) # On is the default
+ OPTION(INSTALL_DOCUMENTATION "install documentation" ON) # On is the default
+
+ ## Files that will be included in the build-release target
+@@ -151,11 +150,6 @@
+ MESSAGE(WARNING "If you want to build the X11 plugin, please install X11.")
+ ENDIF(X11_X11_INCLUDE_PATH)
+
+-IF(USE_CLANG)
+- MESSAGE(STATUS "Using clang as a compiler")
+- SET(CMAKE_C_COMPILER "clang")
+-ENDIF(USE_CLANG)
+-
+ ## add include directories build project in src
+ INCLUDE_DIRECTORIES(${CMAKE_INCLUDE_PATH} src)
+ ADD_SUBDIRECTORY(src)