aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux-peops-softgpu/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-01-29 20:54:06 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-01-29 20:54:06 +0000
commit2a69c71ed980eb43a6b6887dfcf12f87d92667a1 (patch)
tree3045a65d06618093c38cda3b32379e865814a8fc /emulators/linux-peops-softgpu/Makefile
parenta37d6a3f380c119c91d4f090fee74ca8e908877c (diff)
downloadports-2a69c71ed980eb43a6b6887dfcf12f87d92667a1.tar.gz
ports-2a69c71ed980eb43a6b6887dfcf12f87d92667a1.zip
- Update to 1.16
PR: ports/76597 Submitted by: Jean-Yves Lefort <jylefort@brutele.be> (maintainer)
Notes
Notes: svn path=/head/; revision=127658
Diffstat (limited to 'emulators/linux-peops-softgpu/Makefile')
-rw-r--r--emulators/linux-peops-softgpu/Makefile17
1 files changed, 10 insertions, 7 deletions
diff --git a/emulators/linux-peops-softgpu/Makefile b/emulators/linux-peops-softgpu/Makefile
index 21b6c0a64da4..9e5d85ee8cae 100644
--- a/emulators/linux-peops-softgpu/Makefile
+++ b/emulators/linux-peops-softgpu/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= peops-softgpu
-PORTVERSION= 1.15
-PORTREVISION= 1
+PORTVERSION= 1.16
CATEGORIES= emulators linux
-MASTER_SITES= http://home.t-online.de/home/PeteBernert/
+MASTER_SITES= http://www.pbernert.com/
PKGNAMEPREFIX= linux-
-DISTNAME= gpupeopssoftx115
+DISTNAME= gpupeopssoftx${MAJOR}${MINOR}
MAINTAINER= jylefort@brutele.be
COMMENT= A PSEmu Pro GPU plugin using a software X11 renderer (Linux version)
@@ -28,6 +27,10 @@ ONLY_FOR_ARCHS= i386
# because as a side effect it brands the binary as FreeBSD.
STRIP=
+MAJOR= ${PORTVERSION:R}
+MINOR= ${PORTVERSION:E}
+PLIST_SUB+= MAJOR=${MAJOR} MINOR=${MINOR}
+
.include <bsd.port.pre.mk>
PSEMUPRO_PLUGINS_DIR= ${LOCALBASE}/lib/psemupro/plugins
@@ -36,7 +39,7 @@ PSEMUPRO_CFGFILES_DIR= ${LOCALBASE}/share/psemupro/cfg
do-install:
${MKDIR} ${PSEMUPRO_PLUGINS_DIR}
- ${INSTALL_PROGRAM} ${WRKSRC}/libgpuPeopsSoftX.so.1.0.15 ${PSEMUPRO_PLUGINS_DIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/libgpuPeopsSoftX.so.${MAJOR}.0.${MINOR} ${PSEMUPRO_PLUGINS_DIR}
${MKDIR} ${PSEMUPRO_CFGBINS_DIR}
${INSTALL_PROGRAM} ${WRKSRC}/cfgPeopsSoft ${PSEMUPRO_CFGBINS_DIR}
@@ -47,8 +50,8 @@ do-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} \
- ${WRKSRC}/peops_soft_readme_1_15.txt \
- ${WRKSRC}/peops_soft_version_1_15.txt \
+ ${WRKSRC}/peops_soft_readme_${MAJOR}_${MINOR}.txt \
+ ${WRKSRC}/peops_soft_version_${MAJOR}_${MINOR}.txt \
${DOCSDIR}
.endif