aboutsummaryrefslogtreecommitdiff
path: root/emulators/linux-vmware-toolbox5
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-21 07:23:49 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-21 07:23:49 +0000
commit70dd3b7be8acaccdf0669259546e8c500574ddeb (patch)
treee530f62fc4305d99b65ffa57d5f5ed46bcce7b30 /emulators/linux-vmware-toolbox5
parentc26e98a06144b1e6137d11f2cd619cf05f233c23 (diff)
downloadports-70dd3b7be8acaccdf0669259546e8c500574ddeb.tar.gz
ports-70dd3b7be8acaccdf0669259546e8c500574ddeb.zip
Add linux-vmware-toolbox, VMware toolbox for FreeBSD Guest OS
(full-featured Linux version). PR: ports/20612 Submitted by: Makoto MATSUSHITA <matusita@jp.FreeBSD.org> Modified by: knu
Notes
Notes: svn path=/head/; revision=31808
Diffstat (limited to 'emulators/linux-vmware-toolbox5')
-rw-r--r--emulators/linux-vmware-toolbox5/Makefile76
-rw-r--r--emulators/linux-vmware-toolbox5/distinfo1
-rw-r--r--emulators/linux-vmware-toolbox5/pkg-comment1
-rw-r--r--emulators/linux-vmware-toolbox5/pkg-descr15
-rw-r--r--emulators/linux-vmware-toolbox5/pkg-plist1
5 files changed, 94 insertions, 0 deletions
diff --git a/emulators/linux-vmware-toolbox5/Makefile b/emulators/linux-vmware-toolbox5/Makefile
new file mode 100644
index 000000000000..957f5be3b001
--- /dev/null
+++ b/emulators/linux-vmware-toolbox5/Makefile
@@ -0,0 +1,76 @@
+# New ports collection makefile for: VMware toolbox for Linux
+# Date created: 10 Aug 2000
+# Whom: matusita@jp.FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= vmware-toolbox
+PORTVERSION= ${VMWARE_VER}.${BUILD_VER}
+CATEGORIES= emulators linux
+MASTER_SITES= # none
+PKGNAMEPREFIX= linux-
+DISTNAME= vmware-linux-tools
+
+MAINTAINER= matusita@jp.FreeBSD.org
+
+RUN_DEPENDS= ${LINUX_DIR}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base
+
+ONLY_FOR_ARCHS= i386
+USE_X_PREFIX= yes
+NO_BUILD= yes
+
+RESTRICTED= "Not sure if we can redistribute this."
+
+LINUX_FLP?= ${DISTDIR}/linux.flp
+LINUX_DIR?= /compat/linux
+MOUNT_PT?= ${WRKDIR}/mnt
+.if exists(${LINUX_FLP})
+MOUNT_DEV?= vn0
+.else
+MOUNT_DEV?= fd0
+.endif
+VMWARE_VER= 2.0.2
+BUILD_VER= 621
+
+MOUNT= /sbin/mount
+UMOUNT= /sbin/umount
+VNCONFIG= /usr/sbin/vnconfig
+
+.include <bsd.port.pre.mk>
+
+pre-fetch:
+ @${ECHO} "========================================================================"
+ @${ECHO} ""
+ @${ECHO} "To install this port, please do one of these:"
+ @${ECHO} ""
+ @${ECHO} " 1. Select the menu item \"Devices -> floppy0 -> Edit\" on VMware,"
+ @${ECHO} " and choose the file \"linux.flp\"."
+ @${ECHO} ""
+ @${ECHO} " 2. Manually put the file \"linux.flp\" in ${DISTDIR}."
+ @${ECHO} ""
+ @${ECHO} "========================================================================"
+
+do-fetch:
+.if exists("${DISTDIR}/${DISTFILES}")
+ @${ECHO} "Found ${DISTDIR}/${DISTFILES}."
+.else
+ ${MKDIR} ${MOUNT_PT}
+ -@${UMOUNT} ${MOUNT_PT} 2>&1 >/dev/null
+ -@${UMOUNT} /dev/${MOUNT_DEV} 2>&1 >/dev/null
+.if exists(${LINUX_FLP})
+ -@${VNCONFIG} -u /dev/r${MOUNT_DEV} 2>&1 >/dev/null
+ ${VNCONFIG} -c /dev/r${MOUNT_DEV} ${LINUX_FLP}
+.endif
+ ${MOUNT} -t msdos -r /dev/${MOUNT_DEV} ${MOUNT_PT}
+ ${CP} ${MOUNT_PT}/${DISTFILES} ${DISTDIR}
+ ${UMOUNT} /dev/${MOUNT_DEV}
+.if exists(${LINUX_FLP})
+ ${VNCONFIG} -u /dev/r${MOUNT_DEV}
+.endif
+.endif
+
+do-install:
+ ${CP} ${WRKSRC}/vmware-toolbox ${PREFIX}/bin/linux-vmware-toolbox
+
+.include <bsd.port.post.mk>
diff --git a/emulators/linux-vmware-toolbox5/distinfo b/emulators/linux-vmware-toolbox5/distinfo
new file mode 100644
index 000000000000..3c0b203551b2
--- /dev/null
+++ b/emulators/linux-vmware-toolbox5/distinfo
@@ -0,0 +1 @@
+MD5 (vmware-linux-tools.tar.gz) = 70f719cbcca112e5a5295ebfe40e28aa
diff --git a/emulators/linux-vmware-toolbox5/pkg-comment b/emulators/linux-vmware-toolbox5/pkg-comment
new file mode 100644
index 000000000000..96f35481cd83
--- /dev/null
+++ b/emulators/linux-vmware-toolbox5/pkg-comment
@@ -0,0 +1 @@
+VMware toolbox for FreeBSD Guest OS (full-featured Linux version)
diff --git a/emulators/linux-vmware-toolbox5/pkg-descr b/emulators/linux-vmware-toolbox5/pkg-descr
new file mode 100644
index 000000000000..00996c8f08da
--- /dev/null
+++ b/emulators/linux-vmware-toolbox5/pkg-descr
@@ -0,0 +1,15 @@
+This is the full-featured Linux version VMware toolbox for FreeBSD
+_Guest_ OS. Beware, this port is _not_ for FreeBSD _Host_ OS.
+
+As VMware toolbox included in VMware tools for FreeBSD is not as good
+as that for Linux, it lacks some useful features such as time
+synchronization between the virtual machine and the Host OS. That is
+why this port is provided.
+
+
+Before installing this port, make sure you have a `linux.flp' file
+that comes with VMware:
+
+ Windows NT/2000: C:\Program Files\VMware\Programs\linux.flp
+ Linux: /usr/lib/vmware/lib/floppies/linux.flp
+ FreeBSD (via ports): ${PREFIX}/lib/vmware/lib/floppies/linux.flp
diff --git a/emulators/linux-vmware-toolbox5/pkg-plist b/emulators/linux-vmware-toolbox5/pkg-plist
new file mode 100644
index 000000000000..0507bad56709
--- /dev/null
+++ b/emulators/linux-vmware-toolbox5/pkg-plist
@@ -0,0 +1 @@
+bin/linux-vmware-toolbox