aboutsummaryrefslogtreecommitdiff
path: root/emulators/mupen64plus-qt
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-11-08 18:57:00 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-11-08 18:57:00 +0000
commit2bf27373327c9fb50709f0c6c445f95cf0a2a65f (patch)
tree7b54f84e1011da7f5ce9fbc0d12231a107ad2355 /emulators/mupen64plus-qt
parentc80f3d4c0678c9cadfe180608d5bd096dd712b7d (diff)
downloadports-2bf27373327c9fb50709f0c6c445f95cf0a2a65f.tar.gz
ports-2bf27373327c9fb50709f0c6c445f95cf0a2a65f.zip
archivers/quazip: update to 1.1
- fix / modify find calls and include directories in dependent ports
Notes
Notes: svn path=/head/; revision=554642
Diffstat (limited to 'emulators/mupen64plus-qt')
-rw-r--r--emulators/mupen64plus-qt/Makefile5
-rw-r--r--emulators/mupen64plus-qt/files/patch-mupen64plus-qt.pro12
-rw-r--r--emulators/mupen64plus-qt/files/patch-src_common.cpp13
-rw-r--r--emulators/mupen64plus-qt/files/patch-src_emulation_emulatorhandler.cpp13
4 files changed, 41 insertions, 2 deletions
diff --git a/emulators/mupen64plus-qt/Makefile b/emulators/mupen64plus-qt/Makefile
index 3dfff8b13ad7..b8fc1627102b 100644
--- a/emulators/mupen64plus-qt/Makefile
+++ b/emulators/mupen64plus-qt/Makefile
@@ -2,6 +2,7 @@
PORTNAME= mupen64plus-qt
DISTVERSION= 1.14
+PORTREVISION= 1
CATEGORIES= emulators
MAINTAINER= maintainer@hasting.email
@@ -10,7 +11,7 @@ COMMENT= Basic launcher for Mupen64Plus
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
-LIB_DEPENDS= libquazip5.so:archivers/quazip
+LIB_DEPENDS= libquazip1-qt5.so:archivers/quazip
RUN_DEPENDS= ${LOCALBASE}/lib/libmupen64plus.so.2:emulators/mupen64plus-core \
${LOCALBASE}/lib/mupen64plus/mupen64plus-audio-sdl.so:emulators/mupen64plus-audio-sdl \
${LOCALBASE}/lib/mupen64plus/mupen64plus-input-sdl.so:emulators/mupen64plus-input-sdl \
@@ -18,7 +19,7 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libmupen64plus.so.2:emulators/mupen64plus-core \
${LOCALBASE}/lib/mupen64plus/mupen64plus-video-rice.so:emulators/mupen64plus-video-rice \
mupen64plus:emulators/mupen64plus-ui-console
-USES= gl qmake qt:5
+USES= gl pkgconfig qmake qt:5
USE_GL= gl
USE_QT= core gui network sql widgets xml \
buildtools_build \
diff --git a/emulators/mupen64plus-qt/files/patch-mupen64plus-qt.pro b/emulators/mupen64plus-qt/files/patch-mupen64plus-qt.pro
new file mode 100644
index 000000000000..9dae8b250deb
--- /dev/null
+++ b/emulators/mupen64plus-qt/files/patch-mupen64plus-qt.pro
@@ -0,0 +1,12 @@
+--- mupen64plus-qt.pro.orig 2020-11-08 17:31:05 UTC
++++ mupen64plus-qt.pro
+@@ -86,7 +86,8 @@ win32|macx|linux_quazip_static {
+ LIBS += -lquazip5
+ }
+ } else {
+- LIBS += -lquazip5
++ CONFIG += link_pkgconfig
++ PKGCONFIG += quazip1-qt5
+ }
+ }
+ }
diff --git a/emulators/mupen64plus-qt/files/patch-src_common.cpp b/emulators/mupen64plus-qt/files/patch-src_common.cpp
new file mode 100644
index 000000000000..39d8817b00d2
--- /dev/null
+++ b/emulators/mupen64plus-qt/files/patch-src_common.cpp
@@ -0,0 +1,13 @@
+--- src/common.cpp.orig 2020-11-08 17:32:57 UTC
++++ src/common.cpp
+@@ -40,8 +40,8 @@
+ #include <QLocale>
+ #include <QSize>
+
+-#include <quazip5/quazip.h>
+-#include <quazip5/quazipfile.h>
++#include <quazip/quazip.h>
++#include <quazip/quazipfile.h>
+
+ #ifdef Q_OS_WIN
+ #include <QCoreApplication>
diff --git a/emulators/mupen64plus-qt/files/patch-src_emulation_emulatorhandler.cpp b/emulators/mupen64plus-qt/files/patch-src_emulation_emulatorhandler.cpp
new file mode 100644
index 000000000000..a5be9a36500d
--- /dev/null
+++ b/emulators/mupen64plus-qt/files/patch-src_emulation_emulatorhandler.cpp
@@ -0,0 +1,13 @@
+--- src/emulation/emulatorhandler.cpp.orig 2020-11-08 17:32:57 UTC
++++ src/emulation/emulatorhandler.cpp
+@@ -38,8 +38,8 @@
+ #include <QFile>
+ #include <QMessageBox>
+
+-#include <quazip5/quazip.h>
+-#include <quazip5/quazipfile.h>
++#include <quazip/quazip.h>
++#include <quazip/quazipfile.h>
+
+
+ EmulatorHandler::EmulatorHandler(QWidget *parent) : QObject(parent)