aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu-devel
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-08-07 09:58:15 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2019-08-07 09:58:15 +0000
commit20eee12e655ba5a2169ea49b1eb786b825dfb5f0 (patch)
treecea6b53a4bc78d35f4c7cdd962b0e0c4897669f7 /emulators/qemu-devel
parent7b26e80f248c4be51c949e44f7df2eab493be52f (diff)
downloadports-20eee12e655ba5a2169ea49b1eb786b825dfb5f0.tar.gz
ports-20eee12e655ba5a2169ea49b1eb786b825dfb5f0.zip
emulators/qemu-devel: Update version 3.1.0=>4.0.0
- USES=gl is not always needed [1] PR: 238364 [1] Submitted by: pizzamig [1] Reported by: bz
Notes
Notes: svn path=/head/; revision=508308
Diffstat (limited to 'emulators/qemu-devel')
-rw-r--r--emulators/qemu-devel/Makefile27
-rw-r--r--emulators/qemu-devel/distinfo6
-rw-r--r--emulators/qemu-devel/files/patch-Makefile12
-rw-r--r--emulators/qemu-devel/files/patch-configure46
-rw-r--r--emulators/qemu-devel/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc4
-rw-r--r--emulators/qemu-devel/files/patch-include_net_net.h4
-rw-r--r--emulators/qemu-devel/files/patch-include_qemu_atomic.h10
-rw-r--r--emulators/qemu-devel/files/patch-net_tap-bsd.c4
-rw-r--r--emulators/qemu-devel/files/patch-qemu-doc.texi13
-rw-r--r--emulators/qemu-devel/pkg-plist18
10 files changed, 85 insertions, 59 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 301256eb6c28..b4ffaf8a4b99 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= qemu
-PORTVERSION= 3.1.0
-PORTREVISION= 2
+PORTVERSION= 4.0.0
CATEGORIES= emulators
MASTER_SITES= https://download.qemu.org/
PKGNAMESUFFIX= -devel
@@ -22,7 +21,7 @@ LIB_DEPENDS= libnettle.so:security/nettle \
libepoxy.so:graphics/libepoxy \
libpcre2-8.so:devel/pcre2
-USES= cpe gmake gnome pkgconfig bison perl5 python:2.7,build tar:xz
+USES= bison cpe gmake gnome iconv:wchar_t perl5 pkgconfig python:build tar:xz
USE_GNOME= cairo glib20 libxml2
USE_PERL5= build
USE_XORG= pixman
@@ -51,12 +50,12 @@ STATIC_LINK_DESC= Statically link the executables
VDE_DESC= vde dependency (for vde networking)
OPTIONS_DEFAULT=X11 GTK3 OPENGL GNUTLS SASL JPEG PNG CDROM_DMA CURL PCAP NCURSES VDE
OPTIONS_SUB= yes
-X11_USE= SDL=sdl XORG=x11,xext GNOME=gdkpixbuf2
+X11_USE= SDL=sdl2 XORG=x11,xext GNOME=gdkpixbuf2
X11_USES= sdl
X11_CONFIGURE_ENABLE= sdl
GTK3_LIB_DEPENDS= libxkbcommon.so:x11/libxkbcommon
GTK3_USE= GNOME=gdkpixbuf2,gtk30,vte3 XORG=x11,xext
-GTK3_USES= gettext
+GTK3_USES= gettext gl
GTK3_CONFIGURE_OFF= --disable-gtk --disable-vte
GNUTLS_LIB_DEPENDS= libgnutls.so:security/gnutls
GNUTLS_CONFIGURE_OFF= --disable-gnutls
@@ -69,6 +68,7 @@ PNG_CONFIGURE_OFF= --disable-vnc-png
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
CURL_CONFIGURE_OFF= --disable-curl
OPENGL_USE= GL=gl
+OPENGL_USES= gl
OPENGL_CONFIGURE_OFF= --disable-opengl
USBREDIR_BUILD_DEPENDS= usbredir>=0.6:net/usbredir
USBREDIR_RUN_DEPENDS= usbredir>=0.6:net/usbredir
@@ -84,11 +84,12 @@ STATIC_LINK_PREVENTS_MSG= X11 ui cannot be built static
NCURSES_USES= ncurses:base
SAMBA_USES= samba:run # smbd
SAMBA_CONFIGURE_ON= --smbd=${LOCALBASE}/sbin/smbd
-DOCS_BUILD_DEPENDS= texi2html:textproc/texi2html
+DOCS_BUILD_DEPENDS= texi2html:textproc/texi2html \
+ sphinx-build:textproc/py-sphinx
DOCS_USES= makeinfo
DOCS_MAKE_ARGS_OFF= NOPORTDOCS=1
-PORTDOCS= docs qemu-doc.html qemu-doc.txt qemu-ga-ref.html qemu-ga-ref.txt \
+PORTDOCS= docs interop/.buildinfo interop/* qemu-doc.html qemu-doc.txt qemu-ga-ref.html qemu-ga-ref.txt \
qemu-qmp-ref.html qemu-qmp-ref.txt
WITHOUT_CPU_CFLAGS=yes #to avoid problems with register allocation
@@ -99,6 +100,7 @@ CONFIGURE_ARGS= --localstatedir=/var --extra-ldflags=-L\"/usr/lib\" \
--disable-linux-user --disable-linux-aio --disable-xen \
--enable-debug-info --python=${PYTHON_CMD} \
--extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\"
+INSTALLS_ICONS= yes
.include <bsd.port.options.mk>
@@ -130,21 +132,10 @@ post-patch:
@${REINPLACE_CMD} -e '/LIBS/s|-lprocstat|-lprocstat -lelf|' \
-e '/libusb/s/ --atleast-version=1\.0\.[0-9]*//' \
${WRKSRC}/configure
- @${REINPLACE_CMD} -e '/libs_qga=/s|glib_libs|glib_libs -lintl|' ${WRKSRC}/configure
- @${REINPLACE_CMD} -E \
- -e "/^by Tibor .TS. S/s|Sch.*z.$$|Schuetz.|" \
- ${WRKSRC}/qemu-doc.texi
- @${REINPLACE_CMD} -E \
- -e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing|" \
- -e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \
- ${WRKSRC}/Makefile.target
@${REINPLACE_CMD} -E \
-e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing -I.|" \
-e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \
${WRKSRC}/Makefile
- @${REINPLACE_CMD} -E \
- -e "1s|^(#! )/usr/bin/perl|\1${PERL}|" \
- ${WRKSRC}/scripts/texi2pod.pl
post-patch-CDROM_DMA-off:
@${REINPLACE_CMD} -e '/USE_DMA_CDROM/d' ${WRKSRC}/include/hw/ide/internal.h
diff --git a/emulators/qemu-devel/distinfo b/emulators/qemu-devel/distinfo
index 14681107c2ac..6ad6264b1d46 100644
--- a/emulators/qemu-devel/distinfo
+++ b/emulators/qemu-devel/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1551235571
-SHA256 (qemu/3.1.0/qemu-3.1.0.tar.xz) = 6a0508df079a0a33c2487ca936a56c12122f105b8a96a44374704bef6c69abfc
-SIZE (qemu/3.1.0/qemu-3.1.0.tar.xz) = 36070104
+TIMESTAMP = 1556455551
+SHA256 (qemu/4.0.0/qemu-4.0.0.tar.xz) = 13a93dfe75b86734326f8d5b475fde82ec692d5b5a338b4262aeeb6b0fa4e469
+SIZE (qemu/4.0.0/qemu-4.0.0.tar.xz) = 55628624
diff --git a/emulators/qemu-devel/files/patch-Makefile b/emulators/qemu-devel/files/patch-Makefile
index 84fa77d3f2ac..095b684f8e80 100644
--- a/emulators/qemu-devel/files/patch-Makefile
+++ b/emulators/qemu-devel/files/patch-Makefile
@@ -1,6 +1,6 @@
---- Makefile.orig 2018-12-11 17:44:34 UTC
+--- Makefile.orig 2019-04-23 18:14:45 UTC
+++ Makefile
-@@ -353,9 +353,14 @@ LIBS+=-lz $(LIBS_TOOLS)
+@@ -311,9 +311,14 @@ LIBS+=-lz $(LIBS_TOOLS)
HELPERS-$(call land,$(CONFIG_SOFTMMU),$(CONFIG_LINUX)) = qemu-bridge-helper$(EXESUF)
ifdef BUILD_DOCS
@@ -15,10 +15,10 @@
DOCS+=docs/qemu-block-drivers.7
DOCS+=docs/qemu-cpu-models.7
ifdef CONFIG_VIRTFS
-@@ -823,11 +828,13 @@ BLOBS=
- endif
+@@ -742,11 +747,13 @@ install-sphinxdocs: sphinxdocs
+ $(call install-manual,interop)
- install-doc: $(DOCS)
+ install-doc: $(DOCS) install-sphinxdocs
+ifndef NOPORTDOCS
$(INSTALL_DIR) "$(DESTDIR)$(qemu_docdir)"
$(INSTALL_DATA) qemu-doc.html "$(DESTDIR)$(qemu_docdir)"
@@ -29,7 +29,7 @@
ifdef CONFIG_POSIX
$(INSTALL_DIR) "$(DESTDIR)$(mandir)/man1"
$(INSTALL_DATA) qemu.1 "$(DESTDIR)$(mandir)/man1"
-@@ -842,8 +849,10 @@ ifneq ($(TOOLS),)
+@@ -764,8 +771,10 @@ ifdef CONFIG_TRACE_SYSTEMTAP
endif
ifneq (,$(findstring qemu-ga,$(TOOLS)))
$(INSTALL_DATA) qemu-ga.8 "$(DESTDIR)$(mandir)/man8"
diff --git a/emulators/qemu-devel/files/patch-configure b/emulators/qemu-devel/files/patch-configure
index ea30d217e7b2..c41037e2774c 100644
--- a/emulators/qemu-devel/files/patch-configure
+++ b/emulators/qemu-devel/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2018-12-11 17:44:34 UTC
+--- configure.orig 2019-04-23 18:14:45 UTC
+++ configure
-@@ -393,7 +393,7 @@ DSOSUF=".so"
+@@ -396,7 +396,7 @@ DSOSUF=".so"
LDFLAGS_SHARED="-shared"
modules="no"
prefix="/usr/local"
@@ -9,7 +9,7 @@
datadir="\${prefix}/share"
firmwarepath="\${prefix}/share/qemu-firmware"
qemu_docdir="\${prefix}/share/doc/qemu"
-@@ -469,6 +469,9 @@ numa=""
+@@ -476,6 +476,9 @@ numa=""
tcmalloc="no"
jemalloc="no"
replication="yes"
@@ -19,7 +19,7 @@
vxhs=""
bochs="yes"
cloop="yes"
-@@ -1097,6 +1100,10 @@ for opt do
+@@ -1118,6 +1121,10 @@ for opt do
;;
--enable-vnc-png) vnc_png="yes"
;;
@@ -29,8 +29,8 @@
+ ;;
--disable-slirp) slirp="no"
;;
- --disable-vde) vde="no"
-@@ -2860,6 +2867,14 @@ if ! check_include "ifaddrs.h" ; then
+ --enable-slirp=system) slirp="system"
+@@ -2972,6 +2979,14 @@ if ! check_include "ifaddrs.h" ; then
fi
##########################################
@@ -45,19 +45,37 @@
# VTE probe
if test "$vte" != "no"; then
-@@ -4466,11 +4481,6 @@ fi
+@@ -3629,7 +3644,7 @@ for i in $glib_modules; do
+ glib_libs=$($pkg_config --libs $i)
+ QEMU_CFLAGS="$glib_cflags $QEMU_CFLAGS"
+ LIBS="$glib_libs $LIBS"
+- libs_qga="$glib_libs $libs_qga"
++ libs_qga="$glib_libs -lintl $libs_qga"
+ else
+ error_exit "glib-$glib_req_ver $i is required to compile QEMU"
+ fi
+@@ -4723,11 +4738,6 @@ has_sphinx_build() {
if test "$docs" != "no" ; then
- if has makeinfo && has pod2man; then
+ if has makeinfo && has pod2man && has_sphinx_build; then
docs=yes
- else
- if test "$docs" = "yes" ; then
-- feature_not_found "docs" "Install texinfo and Perl/perl-podlators"
+- feature_not_found "docs" "Install texinfo, Perl/perl-podlators and python-sphinx"
- fi
- docs=no
fi
fi
-@@ -4984,7 +4994,51 @@ if test "$debug_stack_usage" = "yes"; then
+@@ -4861,7 +4871,7 @@ fi
+
+ # check for libusb
+ if test "$libusb" != "no" ; then
+- if $pkg_config --atleast-version=1.0.13 libusb-1.0; then
++ if $pkg_config libusb-1.0; then
+ libusb="yes"
+ libusb_cflags=$($pkg_config --cflags libusb-1.0)
+ libusb_libs=$($pkg_config --libs libusb-1.0)
+@@ -5251,7 +5261,51 @@ if test "$debug_stack_usage" = "yes"; then
fi
fi
@@ -109,7 +127,7 @@
##########################################
# check if we have open_by_handle_at
-@@ -6005,6 +6059,7 @@ echo "Audio drivers $audio_drv_list"
+@@ -6332,6 +6386,7 @@ echo "Audio drivers $audio_drv_list"
echo "Block whitelist (rw) $block_drv_rw_whitelist"
echo "Block whitelist (ro) $block_drv_ro_whitelist"
echo "VirtFS support $virtfs"
@@ -117,7 +135,7 @@
echo "Multipath support $mpath"
echo "VNC support $vnc"
if test "$vnc" = "yes" ; then
-@@ -6240,6 +6295,15 @@ fi
+@@ -6565,6 +6620,15 @@ fi
if test "$profiler" = "yes" ; then
echo "CONFIG_PROFILER=y" >> $config_host_mak
fi
@@ -130,10 +148,10 @@
+ echo "CONFIG_BPF=y" >> $config_host_mak
+ fi
+fi
- if test "$slirp" = "yes" ; then
+ if test "$slirp" != "no"; then
echo "CONFIG_SLIRP=y" >> $config_host_mak
echo "CONFIG_SMBD_COMMAND=\"$smbd\"" >> $config_host_mak
-@@ -6470,6 +6534,9 @@ fi
+@@ -6812,6 +6876,9 @@ fi
# if this macro is set.
if test "$have_fsxattr" = "yes" ; then
echo "HAVE_FSXATTR=y" >> $config_host_mak
diff --git a/emulators/qemu-devel/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc b/emulators/qemu-devel/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc
index 4e88b6b4a362..546595845c62 100644
--- a/emulators/qemu-devel/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc
+++ b/emulators/qemu-devel/files/patch-disas_libvixl_vixl_a64_disasm-a64.cc
@@ -1,6 +1,6 @@
---- disas/libvixl/vixl/a64/disasm-a64.cc.orig 2016-04-14 20:19:53 UTC
+--- disas/libvixl/vixl/a64/disasm-a64.cc.orig 2019-04-23 18:14:45 UTC
+++ disas/libvixl/vixl/a64/disasm-a64.cc
-@@ -2693,7 +2693,7 @@ void Disassembler::AppendPCRelativeOffse
+@@ -2693,7 +2693,7 @@ void Disassembler::AppendPCRelativeOffsetToOutput(cons
if (offset < 0) {
abs_offset = -abs_offset;
}
diff --git a/emulators/qemu-devel/files/patch-include_net_net.h b/emulators/qemu-devel/files/patch-include_net_net.h
index 95d3b5e33654..92d57989a03f 100644
--- a/emulators/qemu-devel/files/patch-include_net_net.h
+++ b/emulators/qemu-devel/files/patch-include_net_net.h
@@ -1,6 +1,6 @@
---- include/net/net.h.orig 2015-11-03 20:01:34 UTC
+--- include/net/net.h.orig 2019-04-23 18:14:46 UTC
+++ include/net/net.h
-@@ -202,8 +202,8 @@ void qmp_netdev_add(QDict *qdict, QObjec
+@@ -209,8 +209,8 @@ void qmp_netdev_add(QDict *qdict, QObject **ret, Error
int net_hub_id_for_client(NetClientState *nc, int *id);
NetClientState *net_hub_port_find(int hub_id);
diff --git a/emulators/qemu-devel/files/patch-include_qemu_atomic.h b/emulators/qemu-devel/files/patch-include_qemu_atomic.h
index c1f3819a413a..623073e0b29a 100644
--- a/emulators/qemu-devel/files/patch-include_qemu_atomic.h
+++ b/emulators/qemu-devel/files/patch-include_qemu_atomic.h
@@ -1,6 +1,6 @@
---- include/qemu/atomic.h.orig 2017-04-20 14:57:00 UTC
+--- include/qemu/atomic.h.orig 2019-04-23 18:14:46 UTC
+++ include/qemu/atomic.h
-@@ -182,10 +182,12 @@
+@@ -201,10 +201,12 @@
/* Provide shorter names for GCC atomic builtins, return old value */
#define atomic_fetch_inc(ptr) __atomic_fetch_add(ptr, 1, __ATOMIC_SEQ_CST)
#define atomic_fetch_dec(ptr) __atomic_fetch_sub(ptr, 1, __ATOMIC_SEQ_CST)
@@ -13,7 +13,7 @@
#define atomic_fetch_xor(ptr, n) __atomic_fetch_xor(ptr, n, __ATOMIC_SEQ_CST)
#define atomic_inc_fetch(ptr) __atomic_add_fetch(ptr, 1, __ATOMIC_SEQ_CST)
-@@ -199,10 +201,12 @@
+@@ -218,10 +220,12 @@
/* And even shorter names that return void. */
#define atomic_inc(ptr) ((void) __atomic_fetch_add(ptr, 1, __ATOMIC_SEQ_CST))
#define atomic_dec(ptr) ((void) __atomic_fetch_sub(ptr, 1, __ATOMIC_SEQ_CST))
@@ -26,7 +26,7 @@
#define atomic_xor(ptr, n) ((void) __atomic_fetch_xor(ptr, n, __ATOMIC_SEQ_CST))
#else /* __ATOMIC_RELAXED */
-@@ -370,10 +374,12 @@
+@@ -389,10 +393,12 @@
#define atomic_inc_fetch(ptr) __sync_add_and_fetch(ptr, 1)
#define atomic_dec_fetch(ptr) __sync_add_and_fetch(ptr, -1)
@@ -39,7 +39,7 @@
#define atomic_xor_fetch(ptr, n) __sync_xor_and_fetch(ptr, n)
#define atomic_cmpxchg(ptr, old, new) __sync_val_compare_and_swap(ptr, old, new)
-@@ -382,10 +388,12 @@
+@@ -401,10 +407,12 @@
/* And even shorter names that return void. */
#define atomic_inc(ptr) ((void) __sync_fetch_and_add(ptr, 1))
#define atomic_dec(ptr) ((void) __sync_fetch_and_add(ptr, -1))
diff --git a/emulators/qemu-devel/files/patch-net_tap-bsd.c b/emulators/qemu-devel/files/patch-net_tap-bsd.c
index 8e027eda9e61..6d94c1bde1ca 100644
--- a/emulators/qemu-devel/files/patch-net_tap-bsd.c
+++ b/emulators/qemu-devel/files/patch-net_tap-bsd.c
@@ -1,6 +1,6 @@
---- net/tap-bsd.c.orig 2015-11-03 20:01:34 UTC
+--- net/tap-bsd.c.orig 2019-04-23 18:14:46 UTC
+++ net/tap-bsd.c
-@@ -29,6 +29,7 @@
+@@ -31,6 +31,7 @@
#if defined(__NetBSD__) || defined(__FreeBSD__)
#include <sys/ioctl.h>
diff --git a/emulators/qemu-devel/files/patch-qemu-doc.texi b/emulators/qemu-devel/files/patch-qemu-doc.texi
index 4bcda8581c01..aa79d423f792 100644
--- a/emulators/qemu-devel/files/patch-qemu-doc.texi
+++ b/emulators/qemu-devel/files/patch-qemu-doc.texi
@@ -1,6 +1,15 @@
---- qemu-doc.texi.orig 2015-11-03 20:01:35 UTC
+--- qemu-doc.texi.orig 2019-04-23 18:14:46 UTC
+++ qemu-doc.texi
-@@ -355,7 +355,8 @@ Send Ctrl-a
+@@ -200,7 +200,7 @@ VGA BIOS.
+ QEMU uses YM3812 emulation by Tatsuyuki Satoh.
+
+ QEMU uses GUS emulation (GUSEMU32 @url{http://www.deinmeister.de/gusemu/})
+-by Tibor "TS" Schütz.
++by Tibor "TS" Schuetz.
+
+ Note that, by default, GUS shares IRQ(7) with parallel ports and so
+ QEMU must be told to not have parallel ports to have working GUS.
+@@ -560,7 +560,8 @@ Send the escape character to the frontend
@c man begin SEEALSO
The HTML documentation of QEMU for more precise information and Linux
diff --git a/emulators/qemu-devel/pkg-plist b/emulators/qemu-devel/pkg-plist
index 98a08f1c0710..bf144fa1a856 100644
--- a/emulators/qemu-devel/pkg-plist
+++ b/emulators/qemu-devel/pkg-plist
@@ -1,3 +1,4 @@
+bin/elf2dmp
bin/qemu-edid
bin/qemu-ga
bin/qemu-i386
@@ -96,12 +97,9 @@ man/man8/qemu-nbd.8.gz
%%DATADIR%%/petalogix-s3adsp1800.dtb
%%DATADIR%%/bamboo.dtb
%%DATADIR%%/kvmvapic.bin
-%%DATADIR%%/qemu-icon.bmp
-%%DATADIR%%/qemu_logo_no_text.svg
%%DATADIR%%/u-boot.e500
%%DATADIR%%/keymaps/ar
%%DATADIR%%/keymaps/bepo
-%%DATADIR%%/keymaps/common
%%DATADIR%%/keymaps/cz
%%DATADIR%%/keymaps/da
%%DATADIR%%/keymaps/de
@@ -124,9 +122,7 @@ man/man8/qemu-nbd.8.gz
%%DATADIR%%/keymaps/lt
%%DATADIR%%/keymaps/lv
%%DATADIR%%/keymaps/mk
-%%DATADIR%%/keymaps/modifiers
%%DATADIR%%/keymaps/nl
-%%DATADIR%%/keymaps/nl-be
%%DATADIR%%/keymaps/no
%%DATADIR%%/keymaps/pl
%%DATADIR%%/keymaps/pt
@@ -136,8 +132,20 @@ man/man8/qemu-nbd.8.gz
%%DATADIR%%/keymaps/sv
%%DATADIR%%/keymaps/th
%%DATADIR%%/keymaps/tr
+%%DATADIR%%/pvh.bin
%%DATADIR%%/vgabios-bochs-display.bin
%%DATADIR%%/vgabios-ramfb.bin
+share/icons/hicolor/128x128/apps/qemu.png
+share/icons/hicolor/16x16/apps/qemu.png
+share/icons/hicolor/24x24/apps/qemu.png
+share/icons/hicolor/256x256/apps/qemu.png
+share/icons/hicolor/32x32/apps/qemu.bmp
+share/icons/hicolor/32x32/apps/qemu.png
+share/icons/hicolor/48x48/apps/qemu.png
+share/icons/hicolor/512x512/apps/qemu.png
+share/icons/hicolor/64x64/apps/qemu.png
+share/icons/hicolor/scalable/apps/qemu.svg
+share/applications/qemu.desktop
%%GTK3%%share/locale/bg/LC_MESSAGES/qemu.mo
%%GTK3%%share/locale/de_DE/LC_MESSAGES/qemu.mo
%%GTK3%%share/locale/fr_FR/LC_MESSAGES/qemu.mo