aboutsummaryrefslogtreecommitdiff
path: root/emulators/qemu
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2006-04-16 02:38:02 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2006-04-16 02:38:02 +0000
commit4ec773e477f188e26c238a78901f77b0d1d523c5 (patch)
treec15608641aa29337d70ea29da3db07be1b1f097f /emulators/qemu
parent38bfaf4774076463c2dab35d46311366d09fa345 (diff)
downloadports-4ec773e477f188e26c238a78901f77b0d1d523c5.tar.gz
ports-4ec773e477f188e26c238a78901f77b0d1d523c5.zip
Update to 2006-04-14 snapshot.
o no longer needs 3-wire configs when using the emulated serial port. o update patch-libmath to match this commit: [1] http://docs.freebsd.org/cgi/mid.cgi?200512021345.jB2Dj6D3057000 o Allow multiple graphics devices. o ARM Versatile Platform Baseboard emulation. o Thumb prefetch abort fix. o simulate a null modem cable. o 64 bit disassembly. o USB tablet support (Brad Campbell, Anthony Liguori). o mouse API changes. Suggested by: jkim [1] PR: ports/95826 Submitted by: Juergen Lock <nox@jelal.kn-bremen.de> (maintainer)
Notes
Notes: svn path=/head/; revision=159675
Diffstat (limited to 'emulators/qemu')
-rw-r--r--emulators/qemu/Makefile4
-rw-r--r--emulators/qemu/distinfo6
-rw-r--r--emulators/qemu/files/patch-bsdusb.patch9
-rw-r--r--emulators/qemu/files/patch-libmath56
4 files changed, 40 insertions, 35 deletions
diff --git a/emulators/qemu/Makefile b/emulators/qemu/Makefile
index 74c33f2658c9..9f77909d09b2 100644
--- a/emulators/qemu/Makefile
+++ b/emulators/qemu/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= qemu
-PORTVERSION= 0.8.0s.20060408
+PORTVERSION= 0.8.0s.20060414
PORTREVISION= 0
CATEGORIES= emulators
MASTER_SITES= http://www.qemu.org/:release \
@@ -15,7 +15,7 @@ MASTER_SITES= http://www.qemu.org/:release \
http://qemu.dad-answers.com/download/qemu/:snapshot \
http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma \
http://people.freebsd.org/~maho/qemu/:misc
-DISTNAME= ${PORTNAME}-snapshot-2006-04-08_23
+DISTNAME= ${PORTNAME}-snapshot-2006-04-14_23
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
.if defined (WITH_HACKS_CIRRUS) || defined (WITH_HACKS)
DISTFILES+= patch3_cirrus:misc
diff --git a/emulators/qemu/distinfo b/emulators/qemu/distinfo
index 805f63e24350..4b133eb28dfe 100644
--- a/emulators/qemu/distinfo
+++ b/emulators/qemu/distinfo
@@ -1,6 +1,6 @@
-MD5 (qemu/qemu-snapshot-2006-04-08_23.tar.bz2) = 74fd8046d94d5d800f1df35282dba733
-SHA256 (qemu/qemu-snapshot-2006-04-08_23.tar.bz2) = 5cdcab83fa0fa6188c846f2d9c96d019300f6c7742d2ecf3cceae0a014fd6318
-SIZE (qemu/qemu-snapshot-2006-04-08_23.tar.bz2) = 1288264
+MD5 (qemu/qemu-snapshot-2006-04-14_23.tar.bz2) = af94b3a985ba524971b728bbebc6886d
+SHA256 (qemu/qemu-snapshot-2006-04-14_23.tar.bz2) = 993705b18686ce4a1d0843eb823392ade5f4d48bceba97990b12119a31316e1d
+SIZE (qemu/qemu-snapshot-2006-04-14_23.tar.bz2) = 1296192
MD5 (qemu/patch3_cirrus) = ebe7ed9fce804c49e024bc93bfdfc810
SHA256 (qemu/patch3_cirrus) = e862371834b7d895a896fbdb84fd9f70d17b5729a6f6789a48a61504fc941e11
SIZE (qemu/patch3_cirrus) = 8817
diff --git a/emulators/qemu/files/patch-bsdusb.patch b/emulators/qemu/files/patch-bsdusb.patch
index 9fd4ebaa99ff..279c09e49190 100644
--- a/emulators/qemu/files/patch-bsdusb.patch
+++ b/emulators/qemu/files/patch-bsdusb.patch
@@ -654,7 +654,7 @@ Index: qemu/usb-bsd.c
+ usb_host_scan(NULL, usb_host_info_device);
+}
Index: qemu/vl.c
-@@ -2820,10 +2822,12 @@
+@@ -3245,14 +3258,17 @@
dev = usb_host_device_open(p);
if (!dev)
return -1;
@@ -664,10 +664,15 @@ Index: qemu/vl.c
if (!dev)
return -1;
+ dev->isproxied = 0;
+ } else if (!strcmp(devname, "tablet")) {
+ dev = usb_tablet_init();
+ if (!dev)
+ return -1;
++ dev->isproxied = 0;
} else {
return -1;
}
-@@ -2852,6 +2856,8 @@
+@@ -3281,6 +3297,8 @@
if (dev && dev->addr == addr)
break;
}
diff --git a/emulators/qemu/files/patch-libmath b/emulators/qemu/files/patch-libmath
index 08ba92fdb6c8..fb671f5f4235 100644
--- a/emulators/qemu/files/patch-libmath
+++ b/emulators/qemu/files/patch-libmath
@@ -537,7 +537,7 @@ diff -Nru qemu-0.7.0/bsd.orig/amd64/s_ceill.S qemu-0.7.0/bsd/amd64/s_ceill.S
+
+#include <machine/asm.h>
+
-+__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $")
++__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $")
+
+ .file "s_ceill.c"
+ .section .rodata.cst8,"aM",@progbits,8
@@ -824,7 +824,7 @@ diff -Nru qemu-0.7.0/bsd.orig/amd64/s_floorl.S qemu-0.7.0/bsd/amd64/s_floorl.S
+
+#include <machine/asm.h>
+
-+__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $")
++__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $")
+
+ .file "s_floorl.c"
+ .section .rodata.cst8,"aM",@progbits,8
@@ -1085,7 +1085,7 @@ diff -Nru qemu-0.7.0/bsd.orig/amd64/s_isnormal.c qemu-0.7.0/bsd/amd64/s_isnormal
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ *
-+ * $FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $
++ * $FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $
+ */
+
+union IEEEf2bits {
@@ -1149,7 +1149,7 @@ diff -Nru qemu-0.7.0/bsd.orig/amd64/s_llrint.S qemu-0.7.0/bsd/amd64/s_llrint.S
+++ qemu-0.7.0/bsd/amd64/s_llrint.S Fri Apr 29 02:11:27 2005
@@ -0,0 +1,6 @@
+#include <machine/asm.h>
-+__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $")
++__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $")
+
+/* sizeof(long) == sizeof(long long) */
+#define fn llrint
@@ -1159,7 +1159,7 @@ diff -Nru qemu-0.7.0/bsd.orig/amd64/s_llrintf.S qemu-0.7.0/bsd/amd64/s_llrintf.S
+++ qemu-0.7.0/bsd/amd64/s_llrintf.S Fri Apr 29 02:11:27 2005
@@ -0,0 +1,6 @@
+#include <machine/asm.h>
-+__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $")
++__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $")
+
+/* sizeof(long) == sizeof(long long) */
+#define fn llrintf
@@ -1236,7 +1236,7 @@ diff -Nru qemu-0.7.0/bsd.orig/amd64/s_lrint.S qemu-0.7.0/bsd/amd64/s_lrint.S
+#include <machine/asm.h>
+
+#ifndef fn
-+__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $")
++__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $")
+#define fn lrint
+#endif
+
@@ -1276,7 +1276,7 @@ diff -Nru qemu-0.7.0/bsd.orig/amd64/s_lrintf.S qemu-0.7.0/bsd/amd64/s_lrintf.S
+#include <machine/asm.h>
+
+#ifndef fn
-+__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $")
++__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $")
+#define fn lrintf
+#endif
+
@@ -1341,7 +1341,7 @@ diff -Nru qemu-0.7.0/bsd.orig/amd64/s_round.c qemu-0.7.0/bsd/amd64/s_round.c
+ */
+
+#include <sys/cdefs.h>
-+__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $");
++__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $");
+
+#include <math.h>
+
@@ -1354,14 +1354,14 @@ diff -Nru qemu-0.7.0/bsd.orig/amd64/s_round.c qemu-0.7.0/bsd/amd64/s_round.c
+ return (x);
+
+ if (x >= 0.0) {
-+ t = ceil(x);
-+ if (t - x > 0.5)
-+ t -= 1.0;
++ t = floor(x);
++ if (t - x <= -0.5)
++ t += 1.0;
+ return (t);
+ } else {
-+ t = ceil(-x);
-+ if (t + x > 0.5)
-+ t -= 1.0;
++ t = floor(-x);
++ if (t + x <= -0.5)
++ t += 1.0;
+ return (-t);
+ }
+}
@@ -1936,7 +1936,7 @@ diff -Nru qemu-0.7.0/bsd.orig/i386/s_ceill.S qemu-0.7.0/bsd/i386/s_ceill.S
+ */
+
+#include <machine/asm.h>
-+RCSID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $")
++RCSID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $")
+
+ENTRY(ceill)
+ pushl %ebp
@@ -2003,7 +2003,7 @@ diff -Nru qemu-0.7.0/bsd.orig/i386/s_floorl.S qemu-0.7.0/bsd/i386/s_floorl.S
+ */
+
+#include <machine/asm.h>
-+RCSID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $")
++RCSID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $")
+
+ENTRY(floorl)
+ pushl %ebp
@@ -2054,7 +2054,7 @@ diff -Nru qemu-0.7.0/bsd.orig/i386/s_isnormal.c qemu-0.7.0/bsd/i386/s_isnormal.c
+ * OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF
+ * SUCH DAMAGE.
+ *
-+ * $FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $
++ * $FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $
+ */
+
+union IEEEf2bits {
@@ -2144,7 +2144,7 @@ diff -Nru qemu-0.7.0/bsd.orig/i386/s_llrint.S qemu-0.7.0/bsd/i386/s_llrint.S
+ */
+
+#include <machine/asm.h>
-+RCSID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $");
++RCSID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $");
+
+ENTRY(llrint)
+ fldl 4(%esp)
@@ -2184,7 +2184,7 @@ diff -Nru qemu-0.7.0/bsd.orig/i386/s_llrintf.S qemu-0.7.0/bsd/i386/s_llrintf.S
+ */
+
+#include <machine/asm.h>
-+RCSID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $")
++RCSID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $")
+
+ENTRY(llrintf)
+ flds 4(%esp)
@@ -2263,7 +2263,7 @@ diff -Nru qemu-0.7.0/bsd.orig/i386/s_lrint.S qemu-0.7.0/bsd/i386/s_lrint.S
+ */
+
+#include <machine/asm.h>
-+RCSID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $");
++RCSID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $");
+
+ENTRY(lrint)
+ fldl 4(%esp)
@@ -2302,7 +2302,7 @@ diff -Nru qemu-0.7.0/bsd.orig/i386/s_lrintf.S qemu-0.7.0/bsd/i386/s_lrintf.S
+ */
+
+#include <machine/asm.h>
-+RCSID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $")
++RCSID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $")
+
+ENTRY(lrintf)
+ flds 4(%esp)
@@ -2401,7 +2401,7 @@ diff -Nru qemu-0.7.0/bsd.orig/i386/s_round.c qemu-0.7.0/bsd/i386/s_round.c
+ */
+
+#include <sys/cdefs.h>
-+__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.1 2005-05-03 04:02:46 nork Exp $");
++__FBSDID("$FreeBSD: /tmp/pcvs/ports/emulators/qemu/files/patch-libmath,v 1.2 2006-04-16 02:38:02 nork Exp $");
+
+#include <math.h>
+
@@ -2414,14 +2414,14 @@ diff -Nru qemu-0.7.0/bsd.orig/i386/s_round.c qemu-0.7.0/bsd/i386/s_round.c
+ return (x);
+
+ if (x >= 0.0) {
-+ t = ceil(x);
-+ if (t - x > 0.5)
-+ t -= 1.0;
++ t = floor(x);
++ if (t - x <= -0.5)
++ t += 1.0;
+ return (t);
+ } else {
-+ t = ceil(-x);
-+ if (t + x > 0.5)
-+ t -= 1.0;
++ t = floor(-x);
++ if (t + x <= -0.5)
++ t += 1.0;
+ return (-t);
+ }
+}