aboutsummaryrefslogtreecommitdiff
path: root/emulators/qmc2/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-11-01 22:43:18 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-11-01 22:43:18 +0000
commit107430622432ef524af56e28b628c0ea1553296d (patch)
treeb136645b694297ef92e1a1d9ad1bc2cb9d2d2c04 /emulators/qmc2/Makefile
parentad4450acf903a2fc6897a35fe244e7704b1b0bbd (diff)
downloadports-107430622432ef524af56e28b628c0ea1553296d.tar.gz
ports-107430622432ef524af56e28b628c0ea1553296d.zip
- Update to version 0.37 [1]
- Add missing deps - Install desktop entry files PR: ports/171996 [1] Submitted by: KATO Tsuguru <tkato432@yahoo.com> [1] Feature safe: yes
Notes
Notes: svn path=/head/; revision=306825
Diffstat (limited to 'emulators/qmc2/Makefile')
-rw-r--r--emulators/qmc2/Makefile36
1 files changed, 26 insertions, 10 deletions
diff --git a/emulators/qmc2/Makefile b/emulators/qmc2/Makefile
index a3ac7f417f8d..d2f0ecb3869a 100644
--- a/emulators/qmc2/Makefile
+++ b/emulators/qmc2/Makefile
@@ -1,18 +1,24 @@
-# New ports collection makefile for: qmc2
-# Date created: 2007-02-25
-# Whom: alepulver
-#
+# Created by: alepulver
# $FreeBSD$
-#
PORTNAME= qmc2
-PORTVERSION= 0.36
+PORTVERSION= 0.37
CATEGORIES= emulators
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
-COMMENT= Qt 4 based UNIX MAME/MESS frontend
+COMMENT= Qt4 based UNIX MAME/MESS frontend
+LIB_DEPENDS= pthread-stubs:${PORTSDIR}/devel/libpthread-stubs \
+ pcre:${PORTSDIR}/devel/pcre \
+ aa:${PORTSDIR}/graphics/aalib \
+ drm:${PORTSDIR}/graphics/libdrm \
+ png15:${PORTSDIR}/graphics/png \
+ freetype:${PORTSDIR}/print/freetype2 \
+ qzeitgeist:${PORTSDIR}/sysutils/qzeitgeist \
+ expat:${PORTSDIR}/textproc/expat2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig \
+ xcb:${PORTSDIR}/x11/libxcb
RUN_DEPENDS= mame:${PORTSDIR}/emulators/mame \
mess:${PORTSDIR}/emulators/mess
@@ -21,10 +27,15 @@ OPTIONS_DEFINE= DOCS
NO_WRKSUBDIR= yes
USE_BZIP2= yes
-USE_XORG= xmu
+USE_GETTEXT= yes
+USE_ICONV= yes
+USE_GNOME= glib20
+USE_XORG= ice sm x11 xau xdamage xdmcp xmu xext xfixes \
+ xrender xxf86vm
USE_GL= glu
-USE_QT4= gui opengl phonon qtestlib webkit xml \
- moc_build qmake_build rcc_build uic_build
+USE_QT4= corelib declarative dbus gui network opengl phonon \
+ qtestlib script sql svg webkit xml xmlpatterns moc_build \
+ qmake_build rcc_build uic_build
USE_SDL= sdl
USE_GMAKE= yes
MAKE_ARGS= QTDIR="${QT_PREFIX}" QMAKE="${QMAKE}" \
@@ -33,6 +44,11 @@ MAKE_ARGS= QTDIR="${QT_PREFIX}" QMAKE="${QMAKE}" \
CC="${CC}" CXX="${CXX}" LINK="${CXX}"
MAKE_JOBS_UNSAFE=yes
+DESKTOP_ENTRIES="QMC2 (MAME)" "MAME frontend" "${DATADIR}/img/mame.ico" \
+ "${PORTNAME}-sdlmame" "Game;Emulator;" "true" \
+ "QMC2 (MESS)" "MESS frontend" "${DATADIR}/img/mess.ico" \
+ "${PORTNAME}-sdlmess" "Game;Emulator;" "true"
+
.include <bsd.port.options.mk>
post-extract: