aboutsummaryrefslogtreecommitdiff
path: root/emulators/simh-hp2100
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-08 09:52:15 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-07-08 09:52:15 +0000
commit68894bb8fad31dfc4d83239328c1ae0bcc8a6af4 (patch)
tree6f1be90887eeedd74049a6678febdf6a78a1aea8 /emulators/simh-hp2100
parent9e909ae079d4a9d873c645fd6817596364f97120 (diff)
downloadports-68894bb8fad31dfc4d83239328c1ae0bcc8a6af4.tar.gz
ports-68894bb8fad31dfc4d83239328c1ae0bcc8a6af4.zip
emulators/simh-hp2100: fix build on GCC architectures
GCC architectures don't have clang. Tested to build on both 12.1 with GCC and head with LLVM. MFH: 2020Q3 (fix build blanket)
Notes
Notes: svn path=/head/; revision=541475
Diffstat (limited to 'emulators/simh-hp2100')
-rw-r--r--emulators/simh-hp2100/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/emulators/simh-hp2100/Makefile b/emulators/simh-hp2100/Makefile
index a3ed1f251dac..18e3bfcb232b 100644
--- a/emulators/simh-hp2100/Makefile
+++ b/emulators/simh-hp2100/Makefile
@@ -34,7 +34,7 @@ SUB_FILES= hp2100.1
.include <bsd.port.pre.mk>
do-build:
- (cd ${WRKSRC}; GCC=clang ${GMAKE} -C SCP hp2100)
+ (cd ${WRKSRC}; GCC="${CC}" ${GMAKE} -C SCP hp2100)
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/hp2100 ${STAGEDIR}${PREFIX}/bin