aboutsummaryrefslogtreecommitdiff
path: root/emulators/snes9express/Makefile
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2004-03-16 22:58:34 +0000
committerPete Fritchman <petef@FreeBSD.org>2004-03-16 22:58:34 +0000
commit49d0613e6f6b1eec82db10b7b1cf31b6379d9470 (patch)
tree7aafdb9050a85dbe948bcd21faad6359add1d638 /emulators/snes9express/Makefile
parent61b3a6bec83554aeeca93cdf9d7341e6324ccdf3 (diff)
downloadports-49d0613e6f6b1eec82db10b7b1cf31b6379d9470.tar.gz
ports-49d0613e6f6b1eec82db10b7b1cf31b6379d9470.zip
Add snes9express 1.42, GTK interface for snes9x.
Submitted by: Travis Poppe <tlp@liquidx.org>
Notes
Notes: svn path=/head/; revision=104229
Diffstat (limited to 'emulators/snes9express/Makefile')
-rw-r--r--emulators/snes9express/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/emulators/snes9express/Makefile b/emulators/snes9express/Makefile
new file mode 100644
index 000000000000..6db8a68f5d9e
--- /dev/null
+++ b/emulators/snes9express/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: snes9express
+# Date created: 15 Mar 2004
+# Whom: Travis Poppe <tlp@liquidx.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= snes9express
+PORTVERSION= 1.42
+CATEGORIES= emulators
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= tlp@liquidx.org
+COMMENT= GTK interface for snes9x
+
+RUN_DEPENDS= snes9x:${PORTSDIR}/emulators/snes9x
+
+USE_GCC= 3.3
+USE_GETTEXT= yes
+USE_GNOME= gtk20
+USE_REINPLACE= yes
+USE_XLIB= yes
+
+GNU_CONFIGURE= yes
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|lstat$$U.o||' ${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/snes9express ${PREFIX}/bin/snes9express
+ ${MKDIR} ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/snes.s9xskin ${DATADIR}/snes.s9xskin
+ ${INSTALL_DATA} ${WRKSRC}/snsp.s9xskin ${DATADIR}/snsp.s9xskin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for file in AUTHORS ChangeLog COPYING NEWS README
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>