aboutsummaryrefslogtreecommitdiff
path: root/emulators/tiemu3
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-01-22 10:10:55 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-01-22 10:10:55 +0000
commit94ccb0e5450db7c2e8dc2725369407253c97d67a (patch)
treebc9256587a1e008164adab79e3f43e67acfe4450 /emulators/tiemu3
parent0430d14a954aa73378d183932915c5852745f67c (diff)
downloadports-94ccb0e5450db7c2e8dc2725369407253c97d67a.tar.gz
ports-94ccb0e5450db7c2e8dc2725369407253c97d67a.zip
emulators/tiemu3: Modernize Makefile and fix issues
* Add LIB_DEPENDS that stage-qa says should be there * Add USE_GNOME that stage-qa says should be there * Add localbase to USES and remove the parts setting those in CPPFLAGS and LDFLAGS * Correct the linker flag of -export-dynamic to -Wl,-E instead PR: 252890 Submitted by: cyberbotx@cyberbotx.com (maintainer)
Notes
Notes: svn path=/head/; revision=562291
Diffstat (limited to 'emulators/tiemu3')
-rw-r--r--emulators/tiemu3/Makefile19
-rw-r--r--emulators/tiemu3/files/patch-man_Makefile.in6
2 files changed, 15 insertions, 10 deletions
diff --git a/emulators/tiemu3/Makefile b/emulators/tiemu3/Makefile
index 8dd2c51d7cc3..05d438eab14d 100644
--- a/emulators/tiemu3/Makefile
+++ b/emulators/tiemu3/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tiemu3
PORTVERSION= 3.03
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= emulators
MASTER_SITES= SF/gtktiemu/tiemu-linux/TIEmu%20${DISTVERSION}
DISTNAME= tiemu-${DISTVERSION}
@@ -12,19 +12,24 @@ EXTRACT_SUFX= -nogdb.tar.gz
MAINTAINER= cyberbotx@cyberbotx.com
COMMENT= TI89(ti)/92(+)/V200 hand-helds emulator
-LIB_DEPENDS= libticalcs2.so:comms/libticalcs2 \
+LICENSE= GPLv2
+
+LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
+ libfreetype.so:print/freetype2 \
libticables2.so:comms/libticables2 \
+ libticalcs2.so:comms/libticalcs2 \
+ libticonv.so:converters/libticonv \
libtifiles2.so:devel/libtifiles2
-USES= gmake gnome groff libtool pkgconfig sdl
-GNU_CONFIGURE= yes
-USE_GNOME= gtk20 libglade2
+USES= gmake gnome groff libtool localbase pkgconfig sdl
+USE_GNOME= cairo gdkpixbuf2 gtk20 libglade2
USE_SDL= sdl
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib -export-dynamic
+GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-gdb --without-kde
+LDFLAGS+= -Wl,-E
+
OPTIONS_DEFINE= NLS
OPTIONS_SUB= yes
diff --git a/emulators/tiemu3/files/patch-man_Makefile.in b/emulators/tiemu3/files/patch-man_Makefile.in
index 101a3b77e06e..b7d1ca8ef7f3 100644
--- a/emulators/tiemu3/files/patch-man_Makefile.in
+++ b/emulators/tiemu3/files/patch-man_Makefile.in
@@ -1,6 +1,6 @@
---- man/Makefile.in.orig 2009-04-30 16:45:57.000000000 -0400
-+++ man/Makefile.in 2011-07-02 12:20:12.000000000 -0400
-@@ -539,7 +539,7 @@
+--- man/Makefile.in.orig 2009-04-30 20:45:57 UTC
++++ man/Makefile.in
+@@ -539,7 +539,7 @@ view: $(man_MANS)
dist_win: $(man_MANS)
groff -Tascii -man $(man_MANS) > Manpage