aboutsummaryrefslogtreecommitdiff
path: root/emulators/vice
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2017-05-16 19:28:59 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2017-05-16 19:28:59 +0000
commit90d32e9b94fb52763e4b23668037c4c4f1305c6c (patch)
tree00916a98dff1d6c55ca15cc5dd8f3029718d9cb3 /emulators/vice
parentd99874ed4a498eaf594fcae9b0c6a2e27bba62e1 (diff)
downloadports-90d32e9b94fb52763e4b23668037c4c4f1305c6c.tar.gz
ports-90d32e9b94fb52763e4b23668037c4c4f1305c6c.zip
- rename option ASOUND to ALSA
- rename option PULSE to PULSEAUDIO PR: 219120 Submitted by: Tobias Kortkamp
Notes
Notes: svn path=/head/; revision=441050
Diffstat (limited to 'emulators/vice')
-rw-r--r--emulators/vice/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index f844593ab9a2..369b0267eec0 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -3,6 +3,7 @@
PORTNAME= vice
PORTVERSION= 3.1
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/ \
ftp://ftp.zimmers.net/pub/cbm/crossplatform/emulators/VICE/
@@ -50,27 +51,25 @@ LMLINKS= vice.1 x64.1 \
vice.1 xplus4.1 \
vice.1 xcbm2.1
-OPTIONS_DEFINE= SDL ASOUND PULSE DOCS
+OPTIONS_DEFINE= SDL ALSA PULSEAUDIO DOCS
OPTIONS_SINGLE= GUI
OPTIONS_SINGLE_GUI= GNOMEUI3 GNOMEUI2 XAW
-OPTIONS_DEFAULT?= GNOMEUI3 SDL ASOUND
+OPTIONS_DEFAULT?= GNOMEUI3 SDL ALSA
NO_OPTIONS_SORT=yes
OPTIONS_SUB= yes
GNOMEUI3_DESC= use gnome3 user interface
GNOMEUI2_DESC= use gnome2 user interface
XAW_DESC= use plain Xaw library
SDL_DESC= build with SDL2 sound system support
-ASOUND_DESC= build with asound support
-PULSE_DESC= build with pulseaudio support
GNOMEUI2_CONFIGURE_ENABLE= gnomeui
GNOMEUI3_CONFIGURE_ENABLE= gnomeui3
SDL_USE= SDL=sdl2
SDL_CONFIGURE_ON= --with-sdlsound
-ASOUND_CONFIGURE_OFF= --without-alsa
-ASOUND_LIB_DEPENDS= libasound.so:audio/alsa-lib
-PULSE_CONFIGURE_OFF= --without-pulse
-PULSE_LIB_DEPENDS= libpulse.so:audio/pulseaudio
+ALSA_CONFIGURE_OFF= --without-alsa
+ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
+PULSEAUDIO_CONFIGURE_OFF= --without-pulse
+PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
.include <bsd.port.options.mk>