aboutsummaryrefslogtreecommitdiff
path: root/emulators/vice
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2005-10-25 09:41:56 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2005-10-25 09:41:56 +0000
commitee9b676a7cee050575a8b1d1ffa8a011e09f6b93 (patch)
tree88a631869859ab4efef6801eddb859c7050bd93c /emulators/vice
parent3d792bbd184e749c30cab5ec516207323831bdd5 (diff)
downloadports-ee9b676a7cee050575a8b1d1ffa8a011e09f6b93.tar.gz
ports-ee9b676a7cee050575a8b1d1ffa8a011e09f6b93.zip
- update to 1.17
- new MASTER_SITES - honor SDL_CONFIG
Notes
Notes: svn path=/head/; revision=146311
Diffstat (limited to 'emulators/vice')
-rw-r--r--emulators/vice/Makefile19
-rw-r--r--emulators/vice/distinfo4
-rw-r--r--emulators/vice/files/patch-sound88
-rw-r--r--emulators/vice/pkg-plist2
4 files changed, 41 insertions, 72 deletions
diff --git a/emulators/vice/Makefile b/emulators/vice/Makefile
index cd2982c8445e..66483d33c576 100644
--- a/emulators/vice/Makefile
+++ b/emulators/vice/Makefile
@@ -5,10 +5,10 @@
# $FreeBSD$
PORTNAME= vice
-PORTVERSION= 1.16
+PORTVERSION= 1.17
CATEGORIES= emulators
-MASTER_SITES= ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/VICE/ \
- http://distfiles.opendarwin.org/
+MASTER_SITES= http://www.zimmers.net/anonftp/pub/cbm/crossplatform/emulators/VICE/ \
+ ftp://ftp.zimmers.net/pub/cbm/crossplatform/emulators/VICE/
PKGNAMESUFFIX?= ${GNOME_SUFFIX}${PKGNAMESUFFIX2}
MAINTAINER= dinoex@FreeBSD.org
@@ -21,6 +21,7 @@ LIB_DEPENDS= Xaw3d.${XAWVER}:${PORTSDIR}/x11-toolkits/Xaw3d
RESTRICTED= ROMs are copyrighted by Commodore Business Machines
USE_XPM= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
MAKE_ENV+= MAKEINFOFLAGS="--no-split"
@@ -43,6 +44,10 @@ MLINKS= vice.1 x64.1 \
vice.1 xplus4.1 \
vice.1 xcbm2.1
+.if !defined(WITHOUT_SDL)
+USE_SDL= sdl
+.endif
+
.include <bsd.port.pre.mk>
.if ${X_WINDOW_SYSTEM:L} != xfree86-3
@@ -58,9 +63,11 @@ post-extract:
@${RM} -f ${WRKSRC}/doc/vice.info*
post-patch:
- @${MV} ${WRKSRC}/man/vice.1 ${WRKSRC}/man/vice.1.sed
- ${SED} -e "s=%%PREFIX%%=${PREFIX}=g" \
- ${WRKSRC}/man/vice.1.sed > ${WRKSRC}/man/vice.1
+ ${REINPLACE_CMD} -e "s|%%PREFIX%%|${PREFIX}|g" \
+ ${WRKSRC}/man/vice.1
+ ${REINPLACE_CMD} -e "s|sdl-config|${SDL_CONFIG}|g" \
+ -e "s|l-lesd|${SDL_CONFIG}|g" \
+ ${WRKSRC}/configure
pre-install:
${MKDIR} ${DOCSDIR} ${PREFIX}/lib/vice/fonts
diff --git a/emulators/vice/distinfo b/emulators/vice/distinfo
index d0442d579c18..4dd2d3621ef2 100644
--- a/emulators/vice/distinfo
+++ b/emulators/vice/distinfo
@@ -1,2 +1,2 @@
-MD5 (vice-1.16.tar.gz) = 23848e7fe588b32549a5ce4ccf056207
-SIZE (vice-1.16.tar.gz) = 3940579
+MD5 (vice-1.17.tar.gz) = a3b70d5fcef0b345599b6d452401e18e
+SIZE (vice-1.17.tar.gz) = 4412711
diff --git a/emulators/vice/files/patch-sound b/emulators/vice/files/patch-sound
index f6884356b005..b69454529839 100644
--- a/emulators/vice/files/patch-sound
+++ b/emulators/vice/files/patch-sound
@@ -1,81 +1,43 @@
---- configure.orig Sun Aug 22 22:05:49 2004
-+++ configure Fri Sep 17 07:20:22 2004
-@@ -5587,7 +5587,7 @@
- fi
-
- if test x"$with_sdl" = "xyes"; then
-- for ac_prog in sdl-config
-+ for ac_prog in sdl11-config
- do
- # Extract the first word of "$ac_prog", so it can be a program name with args.
- set dummy $ac_prog; ac_word=$2
-@@ -10823,7 +10823,7 @@
-
- if test x"$with_sdl" = "xyes"; then
-
--for ac_header in SDL/SDL_audio.h
-+for ac_header in SDL_audio.h
- do
- as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
- if eval "test \"\${$as_ac_Header+set}\" = set"; then
-@@ -11627,7 +11627,6 @@
- fi
-
- if test x"$with_sdl" = "xyes"; then
-- LIBS="$LIBS `sdl-config --libs`"
-
- echo "$as_me:$LINENO: checking for SDL_OpenAudio in -lSDL" >&5
- echo $ECHO_N "checking for SDL_OpenAudio in -lSDL... $ECHO_C" >&6
-@@ -11635,7 +11634,8 @@
+--- configure.orig Mon Oct 3 00:50:43 2005
++++ configure Tue Oct 25 11:03:40 2005
+@@ -11670,7 +11670,8 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
--LIBS="-lSDL $SOUND_LIBS $LIBS"
-+LIBS="`sdl11-config --libs` $SOUND_LIBS $LIBS"
-+CPPFLAGS="`sld11-config --cflags` $CPPFLAGS"
+-LIBS="-lesd $SOUND_LIBS $LIBS"
++LIBS="`esd-config --libs` $SOUND_LIBS $LIBS"
++CPPFLAGS="`esd-config --cflags` $CPPFLAGS"
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
/* confdefs.h. */
-@@ -11688,7 +11688,7 @@
- #define HAVE_LIBSDL 1
- _ACEOF
-
-- LIBS="-lSDL $LIBS"
-+ LIBS="`sdl11-config --libs` $LIBS"
+@@ -11720,7 +11721,7 @@
+ echo "${ECHO_T}$ac_cv_lib_esd_esd_open_sound" >&6
+ if test $ac_cv_lib_esd_esd_open_sound = yes; then
+ SOUND_DRIVERS="$SOUND_DRIVERS soundesd.o";
+- SOUND_LIBS="$SOUND_LIBS -lesd"; break
++ SOUND_LIBS="$SOUND_LIBS `esd-config --libs`"; break
+ fi
fi
+@@ -11735,7 +11736,7 @@
+ CFLAGS="$CFLAGS `sdl-config --cflags`"
+ LIBS="$LIBS `sdl-config --libs`"
-@@ -11829,7 +11829,8 @@
+-for ac_header in SDL/SDL_audio.h
++for ac_header in SDL/SDL_audio.h SDL_audio.h
+ do
+ as_ac_Header=`echo "ac_cv_header_$ac_header" | $as_tr_sh`
+ if eval "test \"\${$as_ac_Header+set}\" = set"; then
+@@ -11877,7 +11878,8 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
ac_check_lib_save_LIBS=$LIBS
--LIBS="-lesd $SOUND_LIBS $LIBS"
-+LIBS="`esd-config --libs` $SOUND_LIBS $LIBS"
-+CPPFLAGS="`esd-config --cflags` $CPPFLAGS"
+-LIBS="-lSDL $SOUND_LIBS $LIBS"
++LIBS="`sdl-config --libs` $SOUND_LIBS $LIBS"
++CFLAGS="`sdl-config --cflags` $CFLAGS"
cat >conftest.$ac_ext <<_ACEOF
#line $LINENO "configure"
/* confdefs.h. */
-@@ -11882,7 +11883,7 @@
- #define HAVE_LIBESD 1
- _ACEOF
-
-- LIBS="-lesd $LIBS"
-+ LIBS="`esd-config --libs` $LIBS"
-
- fi
-
---- src/config.h.in.orig Mon Jun 9 00:09:47 2003
-+++ src/config.h.in Sun Jun 15 09:35:16 2003
-@@ -200,6 +200,9 @@
- /* Define to 1 if you have the <machine/soundcard.h> header file. */
- #undef HAVE_MACHINE_SOUNDCARD_H
-
-+/* Define to 1 if you have the <sys/soundcard.h> header file. */
-+#undef HAVE_SYS_SOUNDCARD_H
-+
- /* Define to 1 if you have the `memmove' function. */
- #undef HAVE_MEMMOVE
-
--- src/sounddrv/soundsdl.c.orig Sat Jan 12 21:35:58 2002
+++ src/sounddrv/soundsdl.c Fri Feb 14 03:13:41 2003
@@ -26,7 +26,7 @@
diff --git a/emulators/vice/pkg-plist b/emulators/vice/pkg-plist
index 42470134109b..30ae4b56c0a9 100644
--- a/emulators/vice/pkg-plist
+++ b/emulators/vice/pkg-plist
@@ -179,11 +179,11 @@ lib/vice/VIC20/win_sym.vkm
lib/vice/VIC20/x11_pos.vkm
lib/vice/VIC20/x11_sym.vkm
lib/vice/fonts/fonts.dir
-lib/vice/fonts/cbm-directory-charset.fon
lib/vice/fonts/vice-cbm.pcf
%%DOCSDIR%%/64doc.txt
%%DOCSDIR%%/BUGS
%%DOCSDIR%%/COPYING
+%%DOCSDIR%%/MSDOS-Ethernet-Howto.txt
%%DOCSDIR%%/MSDOS-Howto.txt
%%DOCSDIR%%/NEWS
%%DOCSDIR%%/NLS-Howto.txt