aboutsummaryrefslogtreecommitdiff
path: root/emulators/virtio-kmod
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2012-04-22 13:52:23 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2012-04-22 13:52:23 +0000
commitb039fb81285275b445dc10d4f71c67aaee265d56 (patch)
tree1bbfb453288c6e2e6ae517a2c13e10ca9150438b /emulators/virtio-kmod
parent5b2e172d54a54f75240ce785bb0cc4c20e5d4df1 (diff)
downloadports-b039fb81285275b445dc10d4f71c67aaee265d56.tar.gz
ports-b039fb81285275b445dc10d4f71c67aaee265d56.zip
- Update to r234349 of svn.
- But build on OSREL=8.2 failed. So stick old rev on 8.2. - Add support for 8.3-REL. - Copy only required part of source tree [1]. Suggested by: Richard Yao <ryao@cs.stonybrook.edu> from Gentoo [1]
Notes
Notes: svn path=/head/; revision=295254
Diffstat (limited to 'emulators/virtio-kmod')
-rw-r--r--emulators/virtio-kmod/Makefile19
-rw-r--r--emulators/virtio-kmod/distinfo4
-rw-r--r--emulators/virtio-kmod/pkg-message2
3 files changed, 19 insertions, 6 deletions
diff --git a/emulators/virtio-kmod/Makefile b/emulators/virtio-kmod/Makefile
index 2d743a3ee440..b607c2772457 100644
--- a/emulators/virtio-kmod/Makefile
+++ b/emulators/virtio-kmod/Makefile
@@ -13,14 +13,16 @@ MASTER_SITE_SUBDIR= kuriyama
PKGNAMESUFFIX= -kmod
MAINTAINER= kuriyama@FreeBSD.org
-COMMENT= virtio kernel modules port for 8.2/9.0
+COMMENT= virtio kernel modules port for 8.[23]/9.0
ONLY_FOR_ARCHS= amd64 i386
WRKSRC= ${WRKDIR}
-SVN_REV= 228301
+SVN_REV= 234349
KMODDIR?= /boot/modules
PLIST_SUB= KMODDIR=${KMODDIR:C,^/,,}
+NEEDSUBDIRS= amd64 conf contrib dev/pci geom i386 kern net netinet netinet6 \
+ sys tools vm x86
.if !exists(${SRC_BASE}/sys/Makefile)
IGNORE= requires kernel source to be installed
@@ -28,13 +30,20 @@ IGNORE= requires kernel source to be installed
.include <bsd.port.pre.mk>
-.if ${OSREL} != "8.2" && ${OSREL} != "9.0"
+.if ${OSREL} != "8.2" && ${OSREL} != "8.3" && ${OSREL} != "9.0"
IGNORE= not supported $${OSREL} (${OSREL})
.endif
+.if ${OSREL} == "8.2"
+SVN_REV= 228301
+#SVN_REV= 232470
+#SVN_REV= 228301
+.endif
post-extract:
- cd ${WRKSRC} && ${MKDIR} tmp && ${MV} dev modules tmp/
- ${CP} -Rp ${SRC_BASE}/sys ${WRKSRC}/
+ cd ${WRKSRC} && ${MKDIR} sys/dev tmp && ${MV} dev modules tmp/
+ for d in ${NEEDSUBDIRS}; do \
+ ${CP} -Rp ${SRC_BASE}/sys/${d} ${WRKSRC}/sys/${d}; \
+ done
${CP} -Rp ${WRKSRC}/tmp/* ${WRKSRC}/sys/
do-build:
diff --git a/emulators/virtio-kmod/distinfo b/emulators/virtio-kmod/distinfo
index d36eb9d5ab37..8647af983e83 100644
--- a/emulators/virtio-kmod/distinfo
+++ b/emulators/virtio-kmod/distinfo
@@ -1,2 +1,6 @@
+SHA256 (virtio-0.234349.tar.gz) = a776b690c3936f859b4bec3e4157ee6f64789ded18388ec948b5828ba8c9483d
+SIZE (virtio-0.234349.tar.gz) = 47044
+SHA256 (virtio-0.232470.tar.gz) = d9f933271977b4d63cfcc591291534b1b313b0a16e6e878bfa47f369b88681e2
+SIZE (virtio-0.232470.tar.gz) = 47396
SHA256 (virtio-0.228301.tar.gz) = 022b05ce98a88096aacc331fb7ba122d935432a87100fcba6a3b3d7e9e9aa0d6
SIZE (virtio-0.228301.tar.gz) = 47262
diff --git a/emulators/virtio-kmod/pkg-message b/emulators/virtio-kmod/pkg-message
index 7db5130c888f..8a9b95a08f86 100644
--- a/emulators/virtio-kmod/pkg-message
+++ b/emulators/virtio-kmod/pkg-message
@@ -9,7 +9,7 @@ virtio_balloon_load="YES"
and edit fstab and interface config in rc.conf:
# sed -i.bak -Ee 's|/dev/ada?|/dev/vtbd|' /etc/fstab
-# sed -i.bak -e 's|em0|vtnet0|' /etc/rc.conf
+# echo 'ifconfig_vtnet0_name="em0"' >> /etc/rc.conf
and enable virtio devices in host's domain.xml: