aboutsummaryrefslogtreecommitdiff
path: root/emulators/virtualbox-ose-kmod/Makefile
diff options
context:
space:
mode:
authorJohn Baldwin <jhb@FreeBSD.org>2022-05-10 20:48:31 +0000
committerJohn Baldwin <jhb@FreeBSD.org>2022-05-10 20:48:31 +0000
commitbc6d5725ed6c7b6538da70328d89afe901736a90 (patch)
treee22f63a102e3e3032d35fee7c985c4f80d1443ad /emulators/virtualbox-ose-kmod/Makefile
parent2ff1d22f550fc27c4ca5cb60f355b5aa167c8fb4 (diff)
downloadports-bc6d5725ed6c7b6538da70328d89afe901736a90.tar.gz
ports-bc6d5725ed6c7b6538da70328d89afe901736a90.zip
emulators/virtualbox-ose-kmod*: Tie to a specific release branch.
Use a more restricted range of supported __FreeBSD_version values for the virtualbox kernel module since it uses internal KPIs for which KBI stability is not guaranteed. DECLARE_MODULE_TIED would tie the module to a specific __FreeBSD_version which would cause the module to stop loading when an SA or EN is pushed on a release branch. Instead, use DECLARE_MODULE_MAXVER with an upper bound that is limited to the range of a releng branch so that a module built on X.Y will load on X.Y with SAs or ENs applied but will fail to load on X.Y-1 or X.Y+1. Reviewed by: kevans, imp, madpilot, lwhsu (earlier version) Differential Revision: https://reviews.freebsd.org/D16119
Diffstat (limited to 'emulators/virtualbox-ose-kmod/Makefile')
-rw-r--r--emulators/virtualbox-ose-kmod/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/emulators/virtualbox-ose-kmod/Makefile b/emulators/virtualbox-ose-kmod/Makefile
index 9db98ebbbc31..702ebefd075c 100644
--- a/emulators/virtualbox-ose-kmod/Makefile
+++ b/emulators/virtualbox-ose-kmod/Makefile
@@ -2,6 +2,7 @@
PORTNAME= virtualbox-ose
PORTVERSION= 6.1.34
+PORTREVISION= 1
CATEGORIES= emulators
MASTER_SITES= https://download.virtualbox.org/virtualbox/${PORTVERSION}/
PKGNAMESUFFIX= -kmod
@@ -18,6 +19,9 @@ BUILD_DEPENDS= kmk:devel/kBuild
CPE_VENDOR= oracle
CPE_PRODUCT= vm_virtualbox
+SUB_FILES= pkg-message
+SUB_LIST= OPSYS=${OPSYS} OSREL=${OSREL}
+
USES= cpe compiler:c++14-lang kmod tar:bzip2
PATCHDIR= ${.CURDIR}/../${PORTNAME}/files
WRKSRC= ${WRKDIR}/VirtualBox-${PORTVERSION}