aboutsummaryrefslogtreecommitdiff
path: root/emulators/virtualbox-ose-legacy
diff options
context:
space:
mode:
authorDerek Schrock <dereks@lifeofadishwasher.com>2022-02-09 14:22:27 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2022-02-09 14:24:30 +0000
commita60dcd712517e7948e6867f2cbe89938b6c55681 (patch)
tree63c54d76453a8429486402eb2cdbe4fde34e9660 /emulators/virtualbox-ose-legacy
parent39f7031c79eb0da62240461fe830b9df08545f55 (diff)
downloadports-a60dcd712517e7948e6867f2cbe89938b6c55681.tar.gz
ports-a60dcd712517e7948e6867f2cbe89938b6c55681.zip
emulators/virtualbox-ose(-legacy): Take advantage of ccache
This patch teaches the virtualbox ports to take advantage of ccache if the ports are configured to use it. PR: 254616
Diffstat (limited to 'emulators/virtualbox-ose-legacy')
-rw-r--r--emulators/virtualbox-ose-legacy/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/emulators/virtualbox-ose-legacy/Makefile b/emulators/virtualbox-ose-legacy/Makefile
index 9276da479d50..ae08c1b6bc98 100644
--- a/emulators/virtualbox-ose-legacy/Makefile
+++ b/emulators/virtualbox-ose-legacy/Makefile
@@ -324,7 +324,7 @@ post-patch:
do-build:
cd ${WRKSRC} && ${SH} -c '. ${WRKSRC}/env.sh && \
- ${KMK_CONFIG} ${LOCALBASE}/bin/kmk ${KMK_FLAGS}'
+ ${SETENV} ${MAKE_ENV} ${KMK_CONFIG} ${LOCALBASE}/bin/kmk ${KMK_FLAGS}'
.if ${PORT_OPTIONS:MPYTHON}
${PYTHON_CMD} -mcompileall \
${KMK_BUILDDIR}/bin/sdk/bindings/xpcom/python/xpcom