aboutsummaryrefslogtreecommitdiff
path: root/emulators/vxtools
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2007-11-15 22:22:16 +0000
committerMax Khon <fjoe@FreeBSD.org>2007-11-15 22:22:16 +0000
commita557de663f75ce2fff7be3b4d8aedc02056ed5a1 (patch)
tree89d616baa5f5052cc0dc1010a4cc6c39fdaa90c4 /emulators/vxtools
parentb1f1582edfd767592ae9c31d2e85c26861310b0c (diff)
downloadports-a557de663f75ce2fff7be3b4d8aedc02056ed5a1.tar.gz
ports-a557de663f75ce2fff7be3b4d8aedc02056ed5a1.zip
Fix gcc 4.2 build.
Approved by: portmgr (erwin)
Notes
Notes: svn path=/head/; revision=202731
Diffstat (limited to 'emulators/vxtools')
-rw-r--r--emulators/vxtools/Makefile8
-rw-r--r--emulators/vxtools/files/patch-dir.c11
-rw-r--r--emulators/vxtools/files/patch-olt.c11
3 files changed, 23 insertions, 7 deletions
diff --git a/emulators/vxtools/Makefile b/emulators/vxtools/Makefile
index 047b632f5bb6..0b0c53ce837c 100644
--- a/emulators/vxtools/Makefile
+++ b/emulators/vxtools/Makefile
@@ -34,10 +34,4 @@ do-install:
@ ${INSTALL_MAN} ${WRKSRC}/vxmount.1 ${PREFIX}/man/man1
@ ${INSTALL_MAN} ${WRKSRC}/vxumount.1 ${PREFIX}/man/man1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/emulators/vxtools/files/patch-dir.c b/emulators/vxtools/files/patch-dir.c
new file mode 100644
index 000000000000..c287ec8a3494
--- /dev/null
+++ b/emulators/vxtools/files/patch-dir.c
@@ -0,0 +1,11 @@
+--- dir.c.orig 2007-11-16 03:10:42.000000000 +0600
++++ dir.c 2007-11-16 03:11:11.000000000 +0600
+@@ -105,7 +105,7 @@
+ if (direct->ino)
+ filldir (dir, direct->name, direct->namelen, direct->ino);
+
+- (char *) direct += direct->reclen;
++ direct = (char *) direct + direct->reclen;
+ }
+
+ free (block);
diff --git a/emulators/vxtools/files/patch-olt.c b/emulators/vxtools/files/patch-olt.c
new file mode 100644
index 000000000000..26330c7ce4f5
--- /dev/null
+++ b/emulators/vxtools/files/patch-olt.c
@@ -0,0 +1,11 @@
+--- olt.c.orig 2007-11-16 03:09:17.000000000 +0600
++++ olt.c 2007-11-16 03:12:11.000000000 +0600
+@@ -85,7 +85,7 @@
+ case VXFS_OLTSB:
+ break;
+ }
+- (int) ent += ent->oltcommon.size;
++ ent = (char *) ent + ent->oltcommon.size;
+ }
+
+ if (vxdebug)