aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorKyle Evans <kevans@FreeBSD.org>2020-12-04 02:35:41 +0000
committerKyle Evans <kevans@FreeBSD.org>2020-12-04 02:35:41 +0000
commit0f2a95fa2ed4511da999755667c35eb1f1a9d84e (patch)
tree4d16018bc87a5338d19ba298a13b966e3996319a /emulators
parent5518e5006132640c9025d3541955adc861f9cc10 (diff)
downloadports-0f2a95fa2ed4511da999755667c35eb1f1a9d84e.tar.gz
ports-0f2a95fa2ed4511da999755667c35eb1f1a9d84e.zip
emulators/qemu-user-static: fix the build after base r368005
r368005 removed CRIOGET, breaking the qemu-user-static build. We didn't actually implement it anyways, so this update simply ripped it out rather than trying to maintain it for old branches. While here, bring qemu-user-static-devel up to parity with qemu-user-static. We should be soon approaching the point where we can rebase the former forward to a newer qemu. Reported by: gjb
Notes
Notes: svn path=/head/; revision=556947
Diffstat (limited to 'emulators')
-rw-r--r--emulators/qemu-user-static-devel/Makefile15
-rw-r--r--emulators/qemu-user-static-devel/distinfo6
-rw-r--r--emulators/qemu-user-static/Makefile4
-rw-r--r--emulators/qemu-user-static/distinfo6
4 files changed, 11 insertions, 20 deletions
diff --git a/emulators/qemu-user-static-devel/Makefile b/emulators/qemu-user-static-devel/Makefile
index b78d20bf44a7..e3ab027800aa 100644
--- a/emulators/qemu-user-static-devel/Makefile
+++ b/emulators/qemu-user-static-devel/Makefile
@@ -2,7 +2,7 @@
PORTNAME= qemu
PORTVERSION= 3.1.0
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= emulators
PKGNAMESUFFIX= -user-static-devel
DIST_SUBDIR= qemu/${PORTVERSION}
@@ -18,7 +18,7 @@ CONFLICTS_INSTALL= qemu-user-static-[0-9]*
USES= bison compiler:c11 gmake perl5 pkgconfig python:build
USE_GITHUB= yes
-GH_TUPLE= seanbruno:qemu-bsd-user:ed53c04a13 \
+GH_TUPLE= seanbruno:qemu-bsd-user:74de8c0708 \
qemu:keycodemapdb:10739aa:keycodemapdb/ui/keycodemapdb
HAS_CONFIGURE= yes
USE_PERL5= build
@@ -62,21 +62,12 @@ CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC} --enable-docs \
--disable-sdl --disable-gtk --disable-vte --disable-gnutls --disable-vnc \
--disable-curl --disable-opengl --disable-usb-redir --disable-pcap \
--disable-docs --disable-tools --disable-system --disable-guest-agent \
+ --disable-capstone \
--extra-cflags=-I${WRKSRC}\ -I${LOCALBASE}/include\ -DPREFIX=\\\"\"${PREFIX}\\\"\"
QEMU_ARCH= ${ARCH:C/amd64/x86_64/:C/powerpc/ppc/}
MAKE_ARGS+= ARCH=${QEMU_ARCH}
-post-patch:
- @${REINPLACE_CMD} -E \
- -e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing|" \
- -e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \
- ${WRKSRC}/Makefile.target
- @${REINPLACE_CMD} -E \
- -e "s|^(CFLAGS=).*|\1${CFLAGS} -fno-strict-aliasing -I.|" \
- -e "s|^(LDFLAGS=).*|\1${LDFLAGS}|" \
- ${WRKSRC}/Makefile
-
post-install:
@${MV} ${STAGEDIR}${PREFIX}/etc/rc.d ${WRKDIR}
@${RM} -r ${STAGEDIR}${PREFIX}/etc
diff --git a/emulators/qemu-user-static-devel/distinfo b/emulators/qemu-user-static-devel/distinfo
index ca397be8fe3d..e3ab93d2b6a4 100644
--- a/emulators/qemu-user-static-devel/distinfo
+++ b/emulators/qemu-user-static-devel/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1600104424
-SHA256 (qemu/3.1.0/seanbruno-qemu-bsd-user-3.1.0-ed53c04a13_GH0.tar.gz) = e464282b0a953b2622801fa370841ec6073cda0fd78c9946e0e9fcf0b2956d48
-SIZE (qemu/3.1.0/seanbruno-qemu-bsd-user-3.1.0-ed53c04a13_GH0.tar.gz) = 16904224
+TIMESTAMP = 1607041204
+SHA256 (qemu/3.1.0/seanbruno-qemu-bsd-user-3.1.0-74de8c0708_GH0.tar.gz) = d987e290523f3ff96c7c2a0b691e2074d22cef85178adbeffb702d65a6a080ba
+SIZE (qemu/3.1.0/seanbruno-qemu-bsd-user-3.1.0-74de8c0708_GH0.tar.gz) = 16904437
SHA256 (qemu/3.1.0/qemu-keycodemapdb-10739aa_GH0.tar.gz) = ae43fb1e2b07b78be88a7882306b6e71383eb77472a35d7d78fed21e345d134a
SIZE (qemu/3.1.0/qemu-keycodemapdb-10739aa_GH0.tar.gz) = 47895
diff --git a/emulators/qemu-user-static/Makefile b/emulators/qemu-user-static/Makefile
index fcf6308086c8..136f384f7dc9 100644
--- a/emulators/qemu-user-static/Makefile
+++ b/emulators/qemu-user-static/Makefile
@@ -2,7 +2,7 @@
PORTNAME= qemu
PORTVERSION= 3.1.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= emulators
PKGNAMESUFFIX= -user-static
DIST_SUBDIR= qemu/${PORTVERSION}
@@ -18,7 +18,7 @@ CONFLICTS_INSTALL= qemu-user-static-devel-[0-9]*
USES= bison compiler:c11 gmake perl5 pkgconfig python:build
USE_GITHUB= yes
-GH_TUPLE= seanbruno:qemu-bsd-user:6f1319e1138ccb97 \
+GH_TUPLE= seanbruno:qemu-bsd-user:74de8c0708 \
qemu:keycodemapdb:10739aa:keycodemapdb/ui/keycodemapdb
HAS_CONFIGURE= yes
USE_PERL5= build
diff --git a/emulators/qemu-user-static/distinfo b/emulators/qemu-user-static/distinfo
index a1a7d1afdf49..3d161e25f317 100644
--- a/emulators/qemu-user-static/distinfo
+++ b/emulators/qemu-user-static/distinfo
@@ -1,5 +1,5 @@
-TIMESTAMP = 1606014699
-SHA256 (qemu/3.1.0/seanbruno-qemu-bsd-user-3.1.0-6f1319e1138ccb97_GH0.tar.gz) = b1446caf0f4a989d053b379ad1f90691821f7734ea4d6b70139bac609b13aa02
-SIZE (qemu/3.1.0/seanbruno-qemu-bsd-user-3.1.0-6f1319e1138ccb97_GH0.tar.gz) = 16908717
+TIMESTAMP = 1607041766
+SHA256 (qemu/3.1.0/seanbruno-qemu-bsd-user-3.1.0-74de8c0708_GH0.tar.gz) = d987e290523f3ff96c7c2a0b691e2074d22cef85178adbeffb702d65a6a080ba
+SIZE (qemu/3.1.0/seanbruno-qemu-bsd-user-3.1.0-74de8c0708_GH0.tar.gz) = 16904437
SHA256 (qemu/3.1.0/qemu-keycodemapdb-10739aa_GH0.tar.gz) = ae43fb1e2b07b78be88a7882306b6e71383eb77472a35d7d78fed21e345d134a
SIZE (qemu/3.1.0/qemu-keycodemapdb-10739aa_GH0.tar.gz) = 47895