aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2022-02-02 21:19:19 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-02-02 21:19:19 +0000
commit1e385d0870c454cad7ddfedfe2130a5771420dc8 (patch)
tree0b5b05b0f75aef6e30fcd00a01d0b373d2a93add /emulators
parentabdb68bca159e2d97ace0f3d98406646e72cda33 (diff)
downloadports-1e385d0870c454cad7ddfedfe2130a5771420dc8.tar.gz
ports-1e385d0870c454cad7ddfedfe2130a5771420dc8.zip
emulators/bochs: Include CFLAGS directive needed for SB16 config flag
PR: 261259 Reported by: Marty Stanquist <martys1oi@att.net>
Diffstat (limited to 'emulators')
-rw-r--r--emulators/bochs/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/emulators/bochs/Makefile b/emulators/bochs/Makefile
index b2d638667b39..7569b6f08a09 100644
--- a/emulators/bochs/Makefile
+++ b/emulators/bochs/Makefile
@@ -24,7 +24,8 @@ CPE_VENDOR= bochs_project
SUB_FILES= pkg-message
-CFLAGS+= -fomit-frame-pointer
+CFLAGS+= -fomit-frame-pointer \
+ -I${LOCALBASE}/include
CXXFLAGS+= -fno-exceptions
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -139,6 +140,7 @@ RFB_DESC= RFB protocol support (works with VNC viewer)
RFB_CONFIGURE_WITH= rfb
SB16_DESC= Sound Blaster 16 emulation
SB16_CONFIGURE_ENABLE= sb16
+SB16_LIB_DEPENDS= libsamplerate.so:audio/libsamplerate
SDL1_DESC= Simple Direct Media Layer 1 support
SDL1_USES= sdl
SDL1_USE= SDL=sdl