aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2023-10-06 10:43:26 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2023-10-06 10:44:54 +0000
commit1f30727c4cbfd5683c22880e58d0e85864ff6d1f (patch)
tree17ee4a6f369ec425fcb141632d17b231db18da2f /emulators
parent6bb51752661ab30c216f3642c7906e9b1b430dfa (diff)
downloadports-1f30727c4cbfd5683c22880e58d0e85864ff6d1f.tar.gz
ports-1f30727c4cbfd5683c22880e58d0e85864ff6d1f.zip
emulators/dolphin-emu: Update to 5.0.19870
Also: - Fix xxhash detection - Enable noaslr (now needed) - Switch to Qt6 - Update pkg-descr
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dolphin-emu/Makefile42
-rw-r--r--emulators/dolphin-emu/Makefile.tuples6
-rw-r--r--emulators/dolphin-emu/distinfo16
-rw-r--r--emulators/dolphin-emu/files/gen_gh_tuple.sh29
-rw-r--r--emulators/dolphin-emu/files/patch-CMakeLists.txt53
-rw-r--r--emulators/dolphin-emu/files/patch-Source-Core-Common-MsgHandler.h32
-rw-r--r--emulators/dolphin-emu/files/patch-Source-Core-DolphinQt-CMakeLists.txt6
-rw-r--r--emulators/dolphin-emu/pkg-descr6
-rw-r--r--emulators/dolphin-emu/pkg-plist57
9 files changed, 184 insertions, 63 deletions
diff --git a/emulators/dolphin-emu/Makefile b/emulators/dolphin-emu/Makefile
index c8f7dd702f2f..4e93b8d3d59f 100644
--- a/emulators/dolphin-emu/Makefile
+++ b/emulators/dolphin-emu/Makefile
@@ -1,6 +1,5 @@
PORTNAME= dolphin-emu
-PORTVERSION= 5.0.16795
-PORTREVISION= 6
+PORTVERSION= 5.0.19870
CATEGORIES= emulators
MAINTAINER= martymac@FreeBSD.org
@@ -15,7 +14,6 @@ LICENSE_COMB= multi
# - enet and soundtouch come from Externals/ as Dolphin's versions diverge
# (see comments in CMakeLists.txt)
# Various problems that may be addressed in the future:
-# - xxhash comes from Externals/ as it cannot be properly detected yet
# - freesurround comes from Externals/ as it is not available from ports yet
# - cubeb comes from Externals/ as it is not available from ports yet
# - gtest detection is missing (Externals/ version enforced by CMakeLists.txt)
@@ -28,10 +26,12 @@ LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
libswscale.so:multimedia/ffmpeg \
libfmt.so:devel/libfmt \
libpugixml.so:textproc/pugixml \
+ libxxhash.so:devel/xxhash \
libzstd.so:archivers/zstd \
libminizip-ng.so:archivers/minizip-ng \
liblzo2.so:archivers/lzo2 \
- libpng.so:graphics/png \
+ libspng.so:graphics/libspng \
+ libspeexdsp.so:audio/speexdsp \
libpulse.so:audio/pulseaudio \
libjack.so:audio/jack \
libsndio.so:audio/sndio \
@@ -40,30 +40,35 @@ LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
libmbedtls.so:security/mbedtls \
libcurl.so:ftp/curl \
libhidapi.so:comms/hidapi \
- libxml2.so:textproc/libxml2
+ libxkbcommon.so:x11/libxkbcommon
-USES= cmake compiler:c++17-lang desktop-file-utils gl iconv \
- pkgconfig qmake qt:5 sdl xorg
+USES= cmake compiler:c++17-lang desktop-file-utils elfctl gl iconv \
+ pkgconfig qmake qt:6 sdl xorg
+
+ELF_FEATURES= +noaslr:Binaries/dolphin-emu*
# See: https://fr.dolphin-emu.org/download/?ref=btn
# for latest beta version and associated commit
USE_GITHUB= yes
GH_PROJECT= dolphin
-GH_TAGNAME= 7321802
+GH_TAGNAME= 8c2a1c1
+.include "${.CURDIR}/Makefile.tuples"
-USE_GL= gl glew glu
+USE_GL= egl gl
USE_SDL= sdl2
USE_XORG= ice sm x11 xext xi xrandr
-USE_QT= buildtools:build core gui widgets
+USE_QT= base svg
# XXX USE_MGBA crashes configure step
CMAKE_ARGS+= -DUSE_UPNP:BOOL=ON \
-DENABLE_QT:BOOL=ON \
-DENABLE_ALSA:BOOL=OFF \
-DENABLE_PULSEAUDIO:BOOL=ON \
+ -DENABLE_VULKAN:BOOL=OFF \
-DUSE_DISCORD_PRESENCE:BOOL=OFF \
- -DENABLE_AUTOUPDATE=OFF \
- -DUSE_MGBA=OFF
+ -DUSE_MGBA:BOOL=OFF \
+ -DENABLE_AUTOUPDATE:BOOL=OFF \
+ -DCMAKE_INSTALL_MANDIR:PATH=${MANPREFIX}/man
MAKE_ENV+= DESTDIR="${STAGEDIR}"
# XXX Fix build on archs where 'unsigned long' is 32bit
@@ -94,4 +99,17 @@ LIB_DEPENDS+= libLLVM-${LLVM_DEFAULT:C/^([6-9])0/\1/}.so:devel/llvm${LLVM_DEFAUL
CMAKE_ARGS+= -DENABLE_LLVM:BOOL=OFF
.endif
+# For maintainer (do not forget to clean up Makefile.tuples afterwards to
+# remove useless submodules)
+Makefile.tuples::
+ @${ECHO_CMD} -n > ${.CURDIR}/Makefile.tuples
+ @${RM} -rf ${WRKDIR}/.maintainer.checkout
+ @${MKDIR} ${WRKDIR}/.maintainer.checkout && \
+ cd ${WRKDIR}/.maintainer.checkout && \
+ git clone https://github.com/${GH_ACCOUNT}/${GH_PROJECT} . && \
+ git checkout ${GH_TAGNAME} && \
+ git submodule init && \
+ git submodule update --recursive && \
+ ${SH} ${FILESDIR}/gen_gh_tuple.sh > ${.CURDIR}/Makefile.tuples
+
.include <bsd.port.post.mk>
diff --git a/emulators/dolphin-emu/Makefile.tuples b/emulators/dolphin-emu/Makefile.tuples
new file mode 100644
index 000000000000..87c22a0232cd
--- /dev/null
+++ b/emulators/dolphin-emu/Makefile.tuples
@@ -0,0 +1,6 @@
+GH_TUPLE= \
+ mozilla:cubeb:27d2a102b0b75d9e49d43bc1ea516233fb87d778:cubeb/Externals/cubeb/cubeb \
+ epezent:implot:d87512353495e7760e7fda7566a05beef7627d8f:implot/Externals/implot/implot \
+ google:googletest:58d77fa8070e8cec2dc1ed015d66b454c8d78850:googletest/Externals/gtest \
+ RetroAchievements:rcheevos:d9e990e6d13527532b7e2bb23164a1f3b7f33bb5:rcheevos/Externals/rcheevos/rcheevos \
+ arsenm:sanitizers-cmake:aab6948fa863bc1cbe5d0850bc46b9ef02ed4c1a:sanitizerscmake/Externals/cubeb/cubeb/cmake/sanitizers-cmake \
diff --git a/emulators/dolphin-emu/distinfo b/emulators/dolphin-emu/distinfo
index 15ac2b26c97f..e8076eb3effd 100644
--- a/emulators/dolphin-emu/distinfo
+++ b/emulators/dolphin-emu/distinfo
@@ -1,3 +1,13 @@
-TIMESTAMP = 1657135938
-SHA256 (dolphin-emu-dolphin-5.0.16795-7321802_GH0.tar.gz) = 89c314a186240ac71b30e7620469e5245e4fe50ed52a24f4c9a3b98688be4507
-SIZE (dolphin-emu-dolphin-5.0.16795-7321802_GH0.tar.gz) = 34939218
+TIMESTAMP = 1696355651
+SHA256 (dolphin-emu-dolphin-5.0.19870-8c2a1c1_GH0.tar.gz) = 539fb312ad194b35dfce0cb1b9aeac64f29490ea2cebbd1a42da0cf696525f87
+SIZE (dolphin-emu-dolphin-5.0.19870-8c2a1c1_GH0.tar.gz) = 20538143
+SHA256 (mozilla-cubeb-27d2a102b0b75d9e49d43bc1ea516233fb87d778_GH0.tar.gz) = 9326a22d41b30b6d613c248a8ea2eb56c5ffc76a7080b0127165682fd8eba13e
+SIZE (mozilla-cubeb-27d2a102b0b75d9e49d43bc1ea516233fb87d778_GH0.tar.gz) = 223102
+SHA256 (epezent-implot-d87512353495e7760e7fda7566a05beef7627d8f_GH0.tar.gz) = b85b27cde80816c6ecbd63390e5cb9d3ea56211a63564372b7a7f89fe5b76a9b
+SIZE (epezent-implot-d87512353495e7760e7fda7566a05beef7627d8f_GH0.tar.gz) = 137760
+SHA256 (google-googletest-58d77fa8070e8cec2dc1ed015d66b454c8d78850_GH0.tar.gz) = c6ab3b6b33f51ef7465921f8f8c10c15d7cbc510761a15a18ad85babf6d73278
+SIZE (google-googletest-58d77fa8070e8cec2dc1ed015d66b454c8d78850_GH0.tar.gz) = 855887
+SHA256 (RetroAchievements-rcheevos-d9e990e6d13527532b7e2bb23164a1f3b7f33bb5_GH0.tar.gz) = dc165d4e7ce7b2b36169d94cc3291012e4b1fdf6a49b6b1d33c5126b289c888f
+SIZE (RetroAchievements-rcheevos-d9e990e6d13527532b7e2bb23164a1f3b7f33bb5_GH0.tar.gz) = 540722
+SHA256 (arsenm-sanitizers-cmake-aab6948fa863bc1cbe5d0850bc46b9ef02ed4c1a_GH0.tar.gz) = 9f5b073625375322236a94ce8d2d803cdedad321c91e63845f487b9ebfb2c433
+SIZE (arsenm-sanitizers-cmake-aab6948fa863bc1cbe5d0850bc46b9ef02ed4c1a_GH0.tar.gz) = 7234
diff --git a/emulators/dolphin-emu/files/gen_gh_tuple.sh b/emulators/dolphin-emu/files/gen_gh_tuple.sh
new file mode 100644
index 000000000000..ab014ef5f473
--- /dev/null
+++ b/emulators/dolphin-emu/files/gen_gh_tuple.sh
@@ -0,0 +1,29 @@
+#!/bin/sh
+
+echo "GH_TUPLE= \\"
+for _sm_root in $(find . -type f -name .gitmodules | sed 's/\.gitmodules$//' | sort)
+do
+ (
+ cd "${_sm_root}"
+
+ # Crawl name|path|url list of submodules within _sm_root
+ grep -e '^\[submodule "' -e 'path = ' -e 'url = ' .gitmodules | \
+ sed -E -e 's|.*"([^"]+)".*|\1|' -e 's|.*= ||' | \
+ paste - - - | \
+ sed -E 's/[[:space:]]+/|/g' | \
+ while read _sm
+ do
+ _sm_name=$(echo "${_sm}" | cut -d '|' -f 1)
+ _sm_path=$(echo "${_sm}" | cut -d '|' -f 2)
+ _sm_url=$(echo "${_sm}" | cut -d '|' -f 3)
+
+ _sm_prefix=$(echo "${_sm_root}" | sed 's|^\./||')
+
+ _account_project=$(echo "${_sm_url}" | sed -e 's|^https://github.com/||' -e 's|/|:|g' -e 's|\.git$||')
+ _group=$(echo "${_account_project}" | cut -d ':' -f 2 | tr -cd 'a-zA-Z0-9_')
+ _tagname_group_subdir=$(git submodule status "${_sm_path}" | sed -E -e 's|^.||' -e "s|[[:space:]]+|:${_group}/${_sm_prefix}|" -e 's|[[:space:]]+.*$||')
+ echo -e "\t${_account_project}:${_tagname_group_subdir} \\"
+ done
+ )
+done
+echo ""
diff --git a/emulators/dolphin-emu/files/patch-CMakeLists.txt b/emulators/dolphin-emu/files/patch-CMakeLists.txt
index f19cde716d56..1ee3b806760d 100644
--- a/emulators/dolphin-emu/files/patch-CMakeLists.txt
+++ b/emulators/dolphin-emu/files/patch-CMakeLists.txt
@@ -1,11 +1,44 @@
---- CMakeLists.txt.orig 2022-07-06 07:23:55 UTC
+Fix detection of several libraries
+
+1) Use system zlib instead of zlib-ng
+
+archivers/zlib-ng port is built with native mode enabled and exposes symbols
+with a 'zng_' prefix that causes link-time errors.
+
+See: https://github.com/zlib-ng/zlib-ng/blob/develop/PORTING.md#zlib-ng-native-mode
+
+2) Fix minizip detection
+
+minizip is found using the name 'minizip-ng' with pkgconf
+
+3) Fix xxhash detection
+
+Add missing call to dolphin_find_optional_system_library_pkgconfig() to
+detect libxxhash
+
+--- CMakeLists.txt.orig 2023-07-23 02:24:09 UTC
+++ CMakeLists.txt
-@@ -133,7 +133,7 @@ set_property(GLOBAL PROPERTY USE_FOLDERS ON)
- # Set up paths
- set(bindir ${CMAKE_INSTALL_PREFIX}/bin CACHE PATH "bindir")
- set(datadir ${CMAKE_INSTALL_PREFIX}/share/dolphin-emu CACHE PATH "datadir")
--set(mandir ${CMAKE_INSTALL_PREFIX}/share/man CACHE PATH "mandir")
-+set(mandir ${CMAKE_INSTALL_PREFIX}/man CACHE PATH "mandir")
- add_definitions(-DDATA_DIR="${datadir}/")
-
- if(CMAKE_SYSROOT)
+@@ -663,10 +663,7 @@ dolphin_find_optional_system_library(pugixml Externals
+
+ dolphin_find_optional_system_library_pkgconfig(ENET libenet>=1.3.8 enet::enet Externals/enet)
+
+-if(NOT XXHASH_FOUND)
+- message(STATUS "Using static xxhash from Externals")
+- add_subdirectory(Externals/xxhash)
+-endif()
++dolphin_find_optional_system_library_pkgconfig(XXHASH libxxhash xxhash:xxhash Externals/xxhash)
+
+ dolphin_find_optional_system_library(BZip2 Externals/bzip2)
+
+@@ -676,9 +673,9 @@ dolphin_make_imported_target_if_missing(LibLZMA::LibLZ
+
+ dolphin_find_optional_system_library_pkgconfig(ZSTD libzstd>=1.4.0 zstd::zstd Externals/zstd)
+
+-dolphin_find_optional_system_library_pkgconfig(ZLIB zlib-ng ZLIB::ZLIB Externals/zlib-ng)
++dolphin_find_optional_system_library_pkgconfig(ZLIB zlib ZLIB::ZLIB Externals/zlib-ng)
+
+-dolphin_find_optional_system_library_pkgconfig(MINIZIP minizip>=3.0.0 minizip::minizip Externals/minizip)
++dolphin_find_optional_system_library_pkgconfig(MINIZIP minizip-ng>=3.0.0 minizip::minizip Externals/minizip)
+
+ dolphin_find_optional_system_library(LZO Externals/LZO)
+
diff --git a/emulators/dolphin-emu/files/patch-Source-Core-Common-MsgHandler.h b/emulators/dolphin-emu/files/patch-Source-Core-Common-MsgHandler.h
deleted file mode 100644
index 0e2673dbdece..000000000000
--- a/emulators/dolphin-emu/files/patch-Source-Core-Common-MsgHandler.h
+++ /dev/null
@@ -1,32 +0,0 @@
-commit 66f330e57316257fe81b46f57dad22ea6dee7bae
-Author: Christopher Rudolph <rudolchr@b-tu.de>
-Date: Sat Jul 9 17:02:09 2022 +0200
-
- Add a check for libfmt version so that in case libfmt-9 is used the function is_compile_string is called under it's new namespace
-
---- Source/Core/Common/MsgHandler.h.orig 2022-07-06 07:23:55 UTC
-+++ Source/Core/Common/MsgHandler.h
-@@ -41,7 +41,11 @@ bool MsgAlertFmt(bool yes_no, MsgType style, Common::L
- static_assert(NumFields == sizeof...(args),
- "Unexpected number of replacement fields in format string; did you pass too few or "
- "too many arguments?");
-+#if FMT_VERSION >= 90000
-+ static_assert(fmt::detail::is_compile_string<S>::value);
-+#else
- static_assert(fmt::is_compile_string<S>::value);
-+#endif
- return MsgAlertFmtImpl(yes_no, style, log_type, file, line, format,
- fmt::make_format_args(args...));
- }
-@@ -56,7 +60,11 @@ bool MsgAlertFmtT(bool yes_no, MsgType style, Common::
- static_assert(NumFields == sizeof...(args),
- "Unexpected number of replacement fields in format string; did you pass too few or "
- "too many arguments?");
-+#if FMT_VERSION >= 90000
-+ static_assert(fmt::detail::is_compile_string<S>::value);
-+#else
- static_assert(fmt::is_compile_string<S>::value);
-+#endif
- auto arg_list = fmt::make_format_args(args...);
- return MsgAlertFmtImpl(yes_no, style, log_type, file, line, translated_format, arg_list);
- }
diff --git a/emulators/dolphin-emu/files/patch-Source-Core-DolphinQt-CMakeLists.txt b/emulators/dolphin-emu/files/patch-Source-Core-DolphinQt-CMakeLists.txt
index 34cd0ddc78c4..12994febd8c3 100644
--- a/emulators/dolphin-emu/files/patch-Source-Core-DolphinQt-CMakeLists.txt
+++ b/emulators/dolphin-emu/files/patch-Source-Core-DolphinQt-CMakeLists.txt
@@ -1,8 +1,8 @@
Add DISABLE_NLS option
---- Source/Core/DolphinQt/CMakeLists.txt.orig 2022-07-06 07:23:55 UTC
+--- Source/Core/DolphinQt/CMakeLists.txt.orig 2023-07-23 02:24:09 UTC
+++ Source/Core/DolphinQt/CMakeLists.txt
-@@ -475,6 +475,9 @@ if(WIN32)
+@@ -479,6 +479,9 @@ if(WIN32)
)
endif()
@@ -12,7 +12,7 @@ Add DISABLE_NLS option
# Handle localization
find_package(Gettext)
-@@ -526,6 +529,8 @@ if(GETTEXT_MSGFMT_EXECUTABLE)
+@@ -530,6 +533,8 @@ if(GETTEXT_MSGFMT_EXECUTABLE)
endif()
endforeach()
endif()
diff --git a/emulators/dolphin-emu/pkg-descr b/emulators/dolphin-emu/pkg-descr
index bcfb06c96c91..bfbdecb0b562 100644
--- a/emulators/dolphin-emu/pkg-descr
+++ b/emulators/dolphin-emu/pkg-descr
@@ -1 +1,5 @@
-Dolphin is a free Gamecube and Wii emulator.
+Dolphin is an emulator for two recent Nintendo video game consoles: the
+GameCube and the Wii. It allows PC gamers to enjoy games for these two
+consoles in full HD (1080p) with several enhancements: compatibility
+with all PC controllers, turbo speed, networked multiplayer, and even
+more!
diff --git a/emulators/dolphin-emu/pkg-plist b/emulators/dolphin-emu/pkg-plist
index be96227a28d9..f7fd6530f280 100644
--- a/emulators/dolphin-emu/pkg-plist
+++ b/emulators/dolphin-emu/pkg-plist
@@ -173,6 +173,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/G5N.ini
%%DATADIR%%/sys/GameSettings/G5T.ini
%%DATADIR%%/sys/GameSettings/G6Q.ini
+%%DATADIR%%/sys/GameSettings/G6S.ini
%%DATADIR%%/sys/GameSettings/G6T.ini
%%DATADIR%%/sys/GameSettings/G6W.ini
%%DATADIR%%/sys/GameSettings/G8M.ini
@@ -195,6 +196,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/GALE01r2.ini
%%DATADIR%%/sys/GameSettings/GALP01.ini
%%DATADIR%%/sys/GameSettings/GAP.ini
+%%DATADIR%%/sys/GameSettings/GAS.ini
%%DATADIR%%/sys/GameSettings/GAU.ini
%%DATADIR%%/sys/GameSettings/GAUE08.ini
%%DATADIR%%/sys/GameSettings/GAV.ini
@@ -209,6 +211,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/GBS.ini
%%DATADIR%%/sys/GameSettings/GBV.ini
%%DATADIR%%/sys/GameSettings/GBW.ini
+%%DATADIR%%/sys/GameSettings/GBZ.ini
%%DATADIR%%/sys/GameSettings/GBZP08.ini
%%DATADIR%%/sys/GameSettings/GC2.ini
%%DATADIR%%/sys/GameSettings/GC3.ini
@@ -240,6 +243,8 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/GDK.ini
%%DATADIR%%/sys/GameSettings/GDM.ini
%%DATADIR%%/sys/GameSettings/GDQ.ini
+%%DATADIR%%/sys/GameSettings/GDREAF.ini
+%%DATADIR%%/sys/GameSettings/GDRP69.ini
%%DATADIR%%/sys/GameSettings/GDS.ini
%%DATADIR%%/sys/GameSettings/GDT.ini
%%DATADIR%%/sys/GameSettings/GDTE69.ini
@@ -251,6 +256,8 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/GE9.ini
%%DATADIR%%/sys/GameSettings/GEA.ini
%%DATADIR%%/sys/GameSettings/GED.ini
+%%DATADIR%%/sys/GameSettings/GEME7F.ini
+%%DATADIR%%/sys/GameSettings/GEMJ28.ini
%%DATADIR%%/sys/GameSettings/GEN.ini
%%DATADIR%%/sys/GameSettings/GEO.ini
%%DATADIR%%/sys/GameSettings/GEZ.ini
@@ -326,6 +333,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/GJB.ini
%%DATADIR%%/sys/GameSettings/GJCE8P.ini
%%DATADIR%%/sys/GameSettings/GJD.ini
+%%DATADIR%%/sys/GameSettings/GJF.ini
%%DATADIR%%/sys/GameSettings/GJK.ini
%%DATADIR%%/sys/GameSettings/GJN.ini
%%DATADIR%%/sys/GameSettings/GJUE78.ini
@@ -395,6 +403,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/GNM.ini
%%DATADIR%%/sys/GameSettings/GNN.ini
%%DATADIR%%/sys/GameSettings/GNO.ini
+%%DATADIR%%/sys/GameSettings/GNW.ini
%%DATADIR%%/sys/GameSettings/GNWE69.ini
%%DATADIR%%/sys/GameSettings/GO2.ini
%%DATADIR%%/sys/GameSettings/GO2E4F.ini
@@ -447,7 +456,6 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/GRK.ini
%%DATADIR%%/sys/GameSettings/GRNE52.ini
%%DATADIR%%/sys/GameSettings/GRQ.ini
-%%DATADIR%%/sys/GameSettings/GRS.ini
%%DATADIR%%/sys/GameSettings/GRSPAF.ini
%%DATADIR%%/sys/GameSettings/GRU.ini
%%DATADIR%%/sys/GameSettings/GRUE78.ini
@@ -456,6 +464,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/GS2.ini
%%DATADIR%%/sys/GameSettings/GS2E78.ini
%%DATADIR%%/sys/GameSettings/GSAP01.ini
+%%DATADIR%%/sys/GameSettings/GSB.ini
%%DATADIR%%/sys/GameSettings/GSM.ini
%%DATADIR%%/sys/GameSettings/GSN.ini
%%DATADIR%%/sys/GameSettings/GSNE8P.ini
@@ -482,6 +491,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/GTR.ini
%%DATADIR%%/sys/GameSettings/GTSE4F.ini
%%DATADIR%%/sys/GameSettings/GTW.ini
+%%DATADIR%%/sys/GameSettings/GTY.ini
%%DATADIR%%/sys/GameSettings/GTZ.ini
%%DATADIR%%/sys/GameSettings/GU2.ini
%%DATADIR%%/sys/GameSettings/GU2D78.ini
@@ -510,6 +520,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/GVS46J.ini
%%DATADIR%%/sys/GameSettings/GW2.ini
%%DATADIR%%/sys/GameSettings/GW7.ini
+%%DATADIR%%/sys/GameSettings/GW9.ini
%%DATADIR%%/sys/GameSettings/GWJ.ini
%%DATADIR%%/sys/GameSettings/GWK.ini
%%DATADIR%%/sys/GameSettings/GWL.ini
@@ -554,8 +565,12 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/HA9.ini
%%DATADIR%%/sys/GameSettings/HAB.ini
%%DATADIR%%/sys/GameSettings/HAC.ini
+%%DATADIR%%/sys/GameSettings/HAF.ini
%%DATADIR%%/sys/GameSettings/HAG.ini
%%DATADIR%%/sys/GameSettings/HAT.ini
+%%DATADIR%%/sys/GameSettings/HATE01.ini
+%%DATADIR%%/sys/GameSettings/HATJ01.ini
+%%DATADIR%%/sys/GameSettings/HATP01.ini
%%DATADIR%%/sys/GameSettings/HBA.ini
%%DATADIR%%/sys/GameSettings/HBB.ini
%%DATADIR%%/sys/GameSettings/HBC.ini
@@ -736,6 +751,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/R9B.ini
%%DATADIR%%/sys/GameSettings/R9D.ini
%%DATADIR%%/sys/GameSettings/R9E.ini
+%%DATADIR%%/sys/GameSettings/R9G.ini
%%DATADIR%%/sys/GameSettings/R9I.ini
%%DATADIR%%/sys/GameSettings/R9Q.ini
%%DATADIR%%/sys/GameSettings/R9R.ini
@@ -860,6 +876,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/RHO.ini
%%DATADIR%%/sys/GameSettings/RHP.ini
%%DATADIR%%/sys/GameSettings/RHR.ini
+%%DATADIR%%/sys/GameSettings/RHT.ini
%%DATADIR%%/sys/GameSettings/RHV.ini
%%DATADIR%%/sys/GameSettings/RHZ.ini
%%DATADIR%%/sys/GameSettings/RI2.ini
@@ -902,6 +919,8 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/RKW.ini
%%DATADIR%%/sys/GameSettings/RL5.ini
%%DATADIR%%/sys/GameSettings/RLD.ini
+%%DATADIR%%/sys/GameSettings/RLEEFS.ini
+%%DATADIR%%/sys/GameSettings/RLI.ini
%%DATADIR%%/sys/GameSettings/RLJ.ini
%%DATADIR%%/sys/GameSettings/RLK.ini
%%DATADIR%%/sys/GameSettings/RLL.ini
@@ -949,6 +968,8 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/RNX.ini
%%DATADIR%%/sys/GameSettings/RO2P7N.ini
%%DATADIR%%/sys/GameSettings/RO3.ini
+%%DATADIR%%/sys/GameSettings/RO7.ini
+%%DATADIR%%/sys/GameSettings/RO8.ini
%%DATADIR%%/sys/GameSettings/RO9.ini
%%DATADIR%%/sys/GameSettings/ROA.ini
%%DATADIR%%/sys/GameSettings/ROB.ini
@@ -997,6 +1018,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/RQB.ini
%%DATADIR%%/sys/GameSettings/RQE.ini
%%DATADIR%%/sys/GameSettings/RQF.ini
+%%DATADIR%%/sys/GameSettings/RQL.ini
%%DATADIR%%/sys/GameSettings/RQM.ini
%%DATADIR%%/sys/GameSettings/RQP.ini
%%DATADIR%%/sys/GameSettings/RQQ.ini
@@ -1035,6 +1057,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/RSL.ini
%%DATADIR%%/sys/GameSettings/RSM.ini
%%DATADIR%%/sys/GameSettings/RSN.ini
+%%DATADIR%%/sys/GameSettings/RSO.ini
%%DATADIR%%/sys/GameSettings/RSP.ini
%%DATADIR%%/sys/GameSettings/RSR.ini
%%DATADIR%%/sys/GameSettings/RSS.ini
@@ -1103,6 +1126,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/RXC.ini
%%DATADIR%%/sys/GameSettings/RXF.ini
%%DATADIR%%/sys/GameSettings/RXH.ini
+%%DATADIR%%/sys/GameSettings/RXI.ini
%%DATADIR%%/sys/GameSettings/RXR.ini
%%DATADIR%%/sys/GameSettings/RXV.ini
%%DATADIR%%/sys/GameSettings/RXX.ini
@@ -1206,16 +1230,20 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/SER.ini
%%DATADIR%%/sys/GameSettings/SEU.ini
%%DATADIR%%/sys/GameSettings/SEV.ini
+%%DATADIR%%/sys/GameSettings/SF2.ini
%%DATADIR%%/sys/GameSettings/SF7.ini
%%DATADIR%%/sys/GameSettings/SF8.ini
%%DATADIR%%/sys/GameSettings/SFI.ini
%%DATADIR%%/sys/GameSettings/SFP.ini
%%DATADIR%%/sys/GameSettings/SFR.ini
+%%DATADIR%%/sys/GameSettings/SFU.ini
%%DATADIR%%/sys/GameSettings/SG2.ini
%%DATADIR%%/sys/GameSettings/SG3.ini
%%DATADIR%%/sys/GameSettings/SG7.ini
%%DATADIR%%/sys/GameSettings/SG8.ini
%%DATADIR%%/sys/GameSettings/SGD.ini
+%%DATADIR%%/sys/GameSettings/SGL.ini
+%%DATADIR%%/sys/GameSettings/SGLEA4.ini
%%DATADIR%%/sys/GameSettings/SGT.ini
%%DATADIR%%/sys/GameSettings/SGV.ini
%%DATADIR%%/sys/GameSettings/SGX.ini
@@ -1258,6 +1286,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/SKW.ini
%%DATADIR%%/sys/GameSettings/SKX.ini
%%DATADIR%%/sys/GameSettings/SL2.ini
+%%DATADIR%%/sys/GameSettings/SLE.ini
%%DATADIR%%/sys/GameSettings/SLP.ini
%%DATADIR%%/sys/GameSettings/SLS.ini
%%DATADIR%%/sys/GameSettings/SLW.ini
@@ -1271,6 +1300,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/SMNE01.ini
%%DATADIR%%/sys/GameSettings/SMNP01.ini
%%DATADIR%%/sys/GameSettings/SMO.ini
+%%DATADIR%%/sys/GameSettings/SMS.ini
%%DATADIR%%/sys/GameSettings/SMU.ini
%%DATADIR%%/sys/GameSettings/SMZ.ini
%%DATADIR%%/sys/GameSettings/SNC.ini
@@ -1339,6 +1369,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/SUK.ini
%%DATADIR%%/sys/GameSettings/SUKE01.ini
%%DATADIR%%/sys/GameSettings/SUKJ01.ini
+%%DATADIR%%/sys/GameSettings/SUKP01.ini
%%DATADIR%%/sys/GameSettings/SUM.ini
%%DATADIR%%/sys/GameSettings/SUO.ini
%%DATADIR%%/sys/GameSettings/SUS.ini
@@ -1566,10 +1597,14 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/GameSettings/XIV.ini
%%DATADIR%%/sys/Load/GraphicMods/All Games Bloom Removal/all.txt
%%DATADIR%%/sys/Load/GraphicMods/All Games Bloom Removal/metadata.json
+%%DATADIR%%/sys/Load/GraphicMods/All Games DOF Removal/all.txt
+%%DATADIR%%/sys/Load/GraphicMods/All Games DOF Removal/metadata.json
%%DATADIR%%/sys/Load/GraphicMods/All Games HUD Removal/all.txt
%%DATADIR%%/sys/Load/GraphicMods/All Games HUD Removal/metadata.json
%%DATADIR%%/sys/Load/GraphicMods/All Games Native Resolution Bloom/all.txt
%%DATADIR%%/sys/Load/GraphicMods/All Games Native Resolution Bloom/metadata.json
+%%DATADIR%%/sys/Load/GraphicMods/All Games Native Resolution DOF/all.txt
+%%DATADIR%%/sys/Load/GraphicMods/All Games Native Resolution DOF/metadata.json
%%DATADIR%%/sys/Load/GraphicMods/Arc Rise Fantasia/RPJ.txt
%%DATADIR%%/sys/Load/GraphicMods/Arc Rise Fantasia/metadata.json
%%DATADIR%%/sys/Load/GraphicMods/Battalion Wars 2/RBW.txt
@@ -1586,6 +1621,8 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/Load/GraphicMods/Mario Kart Wii/metadata.json
%%DATADIR%%/sys/Load/GraphicMods/Mario Strikers Charged/R4Q.txt
%%DATADIR%%/sys/Load/GraphicMods/Mario Strikers Charged/metadata.json
+%%DATADIR%%/sys/Load/GraphicMods/Metroid Prime 3 - Corruption/RM3.txt
+%%DATADIR%%/sys/Load/GraphicMods/Metroid Prime 3 - Corruption/metadata.json
%%DATADIR%%/sys/Load/GraphicMods/Monster Hunter Tri/DMH.txt
%%DATADIR%%/sys/Load/GraphicMods/Monster Hunter Tri/RMH.txt
%%DATADIR%%/sys/Load/GraphicMods/Monster Hunter Tri/metadata.json
@@ -1593,12 +1630,24 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/Load/GraphicMods/Nights Journey of Dreams/metadata.json
%%DATADIR%%/sys/Load/GraphicMods/Okami/ROW.txt
%%DATADIR%%/sys/Load/GraphicMods/Okami/metadata.json
+%%DATADIR%%/sys/Load/GraphicMods/Pandora's Tower/SX3.txt
+%%DATADIR%%/sys/Load/GraphicMods/Pandora's Tower/metadata.json
%%DATADIR%%/sys/Load/GraphicMods/Rune Factory Frontier/RUF.txt
%%DATADIR%%/sys/Load/GraphicMods/Rune Factory Frontier/metadata.json
+%%DATADIR%%/sys/Load/GraphicMods/Sin and Punishment - Star Successor/R2V.txt
+%%DATADIR%%/sys/Load/GraphicMods/Sin and Punishment - Star Successor/metadata.json
+%%DATADIR%%/sys/Load/GraphicMods/Skylanders Spyro's Adventure/SSP.txt
+%%DATADIR%%/sys/Load/GraphicMods/Skylanders Spyro's Adventure/metadata.json
%%DATADIR%%/sys/Load/GraphicMods/Skyward Sword Bloom/SOU.txt
%%DATADIR%%/sys/Load/GraphicMods/Skyward Sword Bloom/metadata.json
+%%DATADIR%%/sys/Load/GraphicMods/Sonic Colors/SNC.txt
+%%DATADIR%%/sys/Load/GraphicMods/Sonic Colors/metadata.json
%%DATADIR%%/sys/Load/GraphicMods/Super Mario Galaxy 2/SB4.txt
%%DATADIR%%/sys/Load/GraphicMods/Super Mario Galaxy 2/metadata.json
+%%DATADIR%%/sys/Load/GraphicMods/Super Mario Galaxy/RMG.txt
+%%DATADIR%%/sys/Load/GraphicMods/Super Mario Galaxy/metadata.json
+%%DATADIR%%/sys/Load/GraphicMods/Super Mario Sunshine/GMS.txt
+%%DATADIR%%/sys/Load/GraphicMods/Super Mario Sunshine/metadata.json
%%DATADIR%%/sys/Load/GraphicMods/The Conduit/RCJ.txt
%%DATADIR%%/sys/Load/GraphicMods/The Conduit/metadata.json
%%DATADIR%%/sys/Load/GraphicMods/The House of the Dead Overkill/RHO.txt
@@ -1612,7 +1661,6 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/Load/GraphicMods/Xenoblade Chronicles/SX4.txt
%%DATADIR%%/sys/Load/GraphicMods/Xenoblade Chronicles/metadata.json
%%DATADIR%%/sys/Profiles/Wiimote/Wii Remote with MotionPlus Pointing.ini
-%%DATADIR%%/sys/Resources/Dolphin.png
%%DATADIR%%/sys/Resources/Flag_Australia.png
%%DATADIR%%/sys/Resources/Flag_Australia@2x.png
%%DATADIR%%/sys/Resources/Flag_Australia@4x.png
@@ -1688,6 +1736,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/Shaders/acidmetal.glsl
%%DATADIR%%/sys/Shaders/acidtrip.glsl
%%DATADIR%%/sys/Shaders/acidtrip2.glsl
+%%DATADIR%%/sys/Shaders/asciiart.glsl
%%DATADIR%%/sys/Shaders/auto_toon.glsl
%%DATADIR%%/sys/Shaders/auto_toon2.glsl
%%DATADIR%%/sys/Shaders/bad_bloom.glsl
@@ -1695,12 +1744,14 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/Shaders/chrismas.glsl
%%DATADIR%%/sys/Shaders/cool1.glsl
%%DATADIR%%/sys/Shaders/darkerbrighter.glsl
+%%DATADIR%%/sys/Shaders/default_pre_post_process.glsl
%%DATADIR%%/sys/Shaders/emboss.glsl
%%DATADIR%%/sys/Shaders/fire.glsl
%%DATADIR%%/sys/Shaders/fire2.glsl
%%DATADIR%%/sys/Shaders/firewater.glsl
%%DATADIR%%/sys/Shaders/grayscale.glsl
%%DATADIR%%/sys/Shaders/grayscale2.glsl
+%%DATADIR%%/sys/Shaders/integer_scaling.glsl
%%DATADIR%%/sys/Shaders/invert.glsl
%%DATADIR%%/sys/Shaders/invert_blue.glsl
%%DATADIR%%/sys/Shaders/invertedoutline.glsl
@@ -1713,6 +1764,7 @@ share/applications/dolphin-emu.desktop
%%DATADIR%%/sys/Shaders/posterize2.glsl
%%DATADIR%%/sys/Shaders/primarycolors.glsl
%%DATADIR%%/sys/Shaders/sepia.glsl
+%%DATADIR%%/sys/Shaders/sharp_bilinear.glsl
%%DATADIR%%/sys/Shaders/sketchy.glsl
%%DATADIR%%/sys/Shaders/spookey1.glsl
%%DATADIR%%/sys/Shaders/spookey2.glsl
@@ -2149,6 +2201,7 @@ share/icons/hicolor/scalable/apps/dolphin-emu.svg
%%NLS%%share/locale/en/LC_MESSAGES/dolphin-emu.mo
%%NLS%%share/locale/es/LC_MESSAGES/dolphin-emu.mo
%%NLS%%share/locale/fa/LC_MESSAGES/dolphin-emu.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/dolphin-emu.mo
%%NLS%%share/locale/fr/LC_MESSAGES/dolphin-emu.mo
%%NLS%%share/locale/hr/LC_MESSAGES/dolphin-emu.mo
%%NLS%%share/locale/hu/LC_MESSAGES/dolphin-emu.mo