aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJoerg Wunsch <joerg@FreeBSD.org>2020-12-09 19:53:29 +0000
committerJoerg Wunsch <joerg@FreeBSD.org>2020-12-09 19:53:29 +0000
commit31b286bd46a74c38f18fcddc1d101daa02937a23 (patch)
tree1162293c287cef301a8223ae09bf9b13aecdf6d8 /emulators
parent20d233a5bec5d7ea3b8e0c712529bbebffea0545 (diff)
downloadports-31b286bd46a74c38f18fcddc1d101daa02937a23.tar.gz
ports-31b286bd46a74c38f18fcddc1d101daa02937a23.zip
Add tnylpo, an elegant CP/M emulator
Unlike other emulators, it does not only emulate a Z80 CPU, but essentially all the CP/M 2.2 BDOS services straight at the Unix level. Thus, one can run any CP/M command straight from the Unix command prompt.
Notes
Notes: svn path=/head/; revision=557387
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/tnylpo/Makefile31
-rw-r--r--emulators/tnylpo/distinfo3
-rw-r--r--emulators/tnylpo/pkg-descr12
-rw-r--r--emulators/tnylpo/pkg-plist6
5 files changed, 53 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 7d60f4d320d6..4c6a811bfa73 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -142,6 +142,7 @@
SUBDIR += tme
SUBDIR += tpm-emulator
SUBDIR += tuxnes
+ SUBDIR += tnylpo
SUBDIR += uae
SUBDIR += ucon64
SUBDIR += ukncbtl
diff --git a/emulators/tnylpo/Makefile b/emulators/tnylpo/Makefile
new file mode 100644
index 000000000000..234b57f2c10e
--- /dev/null
+++ b/emulators/tnylpo/Makefile
@@ -0,0 +1,31 @@
+# Created by: Joerg Wunsch <joerg@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= tnylpo
+DISTVERSION= 1.1.2
+CATEGORIES= emulators
+MASTER_SITES= https://gitlab.com/gbrein/${PORTNAME}/-/archive/${DISTVERSION}/
+
+MAINTAINER= joerg@FreeBSD.org
+COMMENT= CP/M emulator
+
+LICENSE= BSD3CLAUSE
+
+USES= tar:bzip2 gmake
+
+MAKEFILE= makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/tnylpo ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/tnylpo-convert ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/tnylpo.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/tnylpo-convert.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/mine/mine.com \
+ ${STAGEDIR}${PREFIX}/share/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/mine/README.md \
+ ${STAGEDIR}${PREFIX}/share/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/emulators/tnylpo/distinfo b/emulators/tnylpo/distinfo
new file mode 100644
index 000000000000..5e70943f5844
--- /dev/null
+++ b/emulators/tnylpo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1607526134
+SHA256 (tnylpo-1.1.2.tar.bz2) = 2d151ad957a8d076f78399ef14e2a308e9f3df4f491152886f8bd93cfcb6b236
+SIZE (tnylpo-1.1.2.tar.bz2) = 82899
diff --git a/emulators/tnylpo/pkg-descr b/emulators/tnylpo/pkg-descr
new file mode 100644
index 000000000000..399138676d90
--- /dev/null
+++ b/emulators/tnylpo/pkg-descr
@@ -0,0 +1,12 @@
+tnylpo allows the execution of programs written for CP/M-80 version
+2.2 under Unixy operating systems. It has been tested under Linux
+(Debian 8 i386; Debian 9 amd64; Debian 10 amd64, i386; Ubuntu 18.04.1
+LTS amd64; CentOS 7; Slackware 14.2 i386), FreeBSD (12.0 amd64),
+NetBSD (9.0 amd64; 8.0 i386, sparc, vax), OpenBSD (6.4, 6.7 i386),
+Solaris (10 x86, 32 and 64 bit; 9 sparc, 32 bit; 9 x86; 7 sparc, 32
+bit), and Mac OS X (10.5 ppc, 10.6, 10.9, 10.11, 10.13), but should
+need little to no modifications to run under any other reasonably
+recent system. The companion program tnylpo-convert converts text
+files to and from the CP/M format.
+
+WWW: https://gitlab.com/gbrein/tnylpo
diff --git a/emulators/tnylpo/pkg-plist b/emulators/tnylpo/pkg-plist
new file mode 100644
index 000000000000..5b223a5c59a1
--- /dev/null
+++ b/emulators/tnylpo/pkg-plist
@@ -0,0 +1,6 @@
+bin/tnylpo
+bin/tnylpo-convert
+man/man1/tnylpo-convert.1.gz
+man/man1/tnylpo.1.gz
+share/tnylpo/mine.com
+share/tnylpo/README.md