aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2016-02-16 13:56:24 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2016-02-16 13:56:24 +0000
commit42e4937d50f15f8e850b762a7cfd511543794fa4 (patch)
treef07f3805f21194fedd5e55f17e710dd649ce928f /emulators
parent880bb91de1a51476958b1e5e0afa4e7869115f28 (diff)
downloadports-42e4937d50f15f8e850b762a7cfd511543794fa4.tar.gz
ports-42e4937d50f15f8e850b762a7cfd511543794fa4.zip
On FreeBSD 9.x, even when CHOSEN_COMPILER_TYPE from Mk/Uses/compiler.mk
is set to clang, COMPILER_VERSION is still at 42 from the system compiler that is GCC 4.2. Work around this for the time being, while retaining the fix from PR 206527, by special casing this situation. PR: 206527
Notes
Notes: svn path=/head/; revision=408996
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index c3e549741245..6a0afaf85a21 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -120,7 +120,10 @@ X11_LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig \
CONFIGURE_ARGS+= --enable-win64 --libdir=${PREFIX}/lib
PLIST_SUB+= WINE32="@comment " WINE64=""
-.if ${CHOSEN_COMPILER_TYPE} == clang && ${COMPILER_VERSION} < 38
+# On FreeBSD 9.x, even when CHOSEN_COMPILER_TYPE from Mk/Uses/compiler.mk
+# is set to clang, COMPILER_VERSION is still at 42 from the system compiler
+# that is GCC 4.2. Hack around this a bit.
+.if ${CHOSEN_COMPILER_TYPE} == clang && ( ${COMPILER_VERSION} < 38 || ${COMPILER_VERSION} == 42 )
CPPFLAGS+= -D__builtin_ms_va_list=__builtin_va_list \
-D__builtin_ms_va_start=__builtin_va_start \
-D__builtin_ms_va_end=__builtin_va_end \