aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2014-08-19 12:42:11 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2014-08-19 12:42:11 +0000
commit45840046f2e64711e742d52f6f7b949077f13bcc (patch)
treec2ec12e373b9ea32d32721b6252a5a12c4b508b6 /emulators
parent4439fe268dea19732581d3debf91af78d1f463bd (diff)
downloadports-45840046f2e64711e742d52f6f7b949077f13bcc.tar.gz
ports-45840046f2e64711e742d52f6f7b949077f13bcc.zip
- Switch to sfml1 in preparation to sfml update
- SFML is only needed for LINK option - Fix build when LIRC is enabled Approved by: portmgr blanket
Notes
Notes: svn path=/head/; revision=365375
Diffstat (limited to 'emulators')
-rw-r--r--emulators/visualboyadvance-m/Makefile15
1 files changed, 11 insertions, 4 deletions
diff --git a/emulators/visualboyadvance-m/Makefile b/emulators/visualboyadvance-m/Makefile
index 3a4e5675ea21..387b575e1a7b 100644
--- a/emulators/visualboyadvance-m/Makefile
+++ b/emulators/visualboyadvance-m/Makefile
@@ -3,7 +3,7 @@
PORTNAME= visualboyadvance-m
PORTVERSION= 1.8.0r${SVN_REV}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= emulators
MASTER_SITES= https://cooltrainer.org/freebsd-ports/visualboyadvance-m/
@@ -12,8 +12,7 @@ COMMENT= Game Boy Advance emulator with GTK frontend
LICENSE= GPLv2
-LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png \
- libsfml-system.so:${PORTSDIR}/devel/sfml
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
OPTIONS_DEFINE= NLS FFMPEG LINK LIRC DEBUGGER
OPTIONS_MULTI= INTERFACE
@@ -104,6 +103,7 @@ CMAKE_ARGS+= -DENABLE_NLS:BOOL=no
.if ${PORT_OPTIONS:MLINK}
CMAKE_ARGS+= -DENABLE_LINK:BOOL=yes
+LIB_DEPENDS+= libsfml1-system.so:${PORTSDIR}/devel/sfml1
.else
CMAKE_ARGS+= -DENABLE_LINK:BOOL=no
.endif
@@ -117,7 +117,14 @@ CMAKE_ARGS+= -DENABLE_LIRC:BOOL=no
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g' ${WRKSRC}/CMakeScripts/FindSFML.cmake
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|g; s|include/SFML|&1|; \
+ s|NAMES sfml-|NAMES sfml1-|' ${WRKSRC}/CMakeScripts/FindSFML.cmake
+ @${REINPLACE_CMD} -e '/#include/ s|SFML|&1|' \
+ ${WRKSRC}/src/gba/GBASockClient.h \
+ ${WRKSRC}/src/gba/GBALink.cpp \
+ ${WRKSRC}/src/gba/GBALink.h
+ @${REINPLACE_CMD} -e '/SET.*LIRC_CLIENT_LIBRARY/ s|lirc_client|${LOCALBASE}/lib/lib&.so|' \
+ ${WRKSRC}/CMakeLists.txt
maint-gen-distfile:
@if [ -f ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ]; then \