aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2022-02-04 19:07:24 +0000
committerRenato Botelho <garga@FreeBSD.org>2022-02-04 19:10:16 +0000
commit491b15ab8eebb36886d344bbf262a515bb46b6cd (patch)
tree08409786258273546ef5609cefc0847ec890fc45 /emulators
parent6d353fa7ab7772a010d00edc5a2dc1c89d0fe1da (diff)
downloadports-491b15ab8eebb36886d344bbf262a515bb46b6cd.tar.gz
ports-491b15ab8eebb36886d344bbf262a515bb46b6cd.zip
emulators/open-vm-tools: Fix build on current
After src commit 66c5fbca7719dca1ac361a010fa511a4514a662d, insmntque1() changed to have only 2 arguments, breaking open-vm-tools. Added a patch to call the new version on recent current and call destructor to make sure it runs. Suggested by: kib Sponsored by: Rubicon Communications, LLC ("Netgate")
Diffstat (limited to 'emulators')
-rw-r--r--emulators/open-vm-tools/Makefile2
-rw-r--r--emulators/open-vm-tools/files/patch-modules_freebsd_vmblock_subr.c17
2 files changed, 18 insertions, 1 deletions
diff --git a/emulators/open-vm-tools/Makefile b/emulators/open-vm-tools/Makefile
index e243cf0085bf..53b597627f74 100644
--- a/emulators/open-vm-tools/Makefile
+++ b/emulators/open-vm-tools/Makefile
@@ -2,7 +2,7 @@
PORTNAME= open-vm-tools
PORTVERSION= 11.3.5
-PORTREVISION= 1
+PORTREVISION= 2
DISTVERSIONPREFIX= stable-
PORTEPOCH= 2
CATEGORIES= emulators
diff --git a/emulators/open-vm-tools/files/patch-modules_freebsd_vmblock_subr.c b/emulators/open-vm-tools/files/patch-modules_freebsd_vmblock_subr.c
new file mode 100644
index 000000000000..c64602d1b9e5
--- /dev/null
+++ b/emulators/open-vm-tools/files/patch-modules_freebsd_vmblock_subr.c
@@ -0,0 +1,17 @@
+--- modules/freebsd/vmblock/subr.c.orig 2022-02-04 12:59:09 UTC
++++ modules/freebsd/vmblock/subr.c
+@@ -392,7 +392,13 @@ VMBlockNodeGet(struct mount *mp, // IN: VMBlock
+ }
+
+ /* Before FreeBSD 7, insmntque was called by getnewvnode. */
+-#if __FreeBSD_version >= 700055
++#if __FreeBSD_version >= 1400051
++ error = insmntque1(vp, mp);
++ if (error != 0) {
++ VMBlockInsMntQueDtr(vp, xp);
++ return error;
++ }
++#else
+ error = insmntque1(vp, mp, VMBlockInsMntQueDtr, xp);
+ if (error != 0) {
+ return error;