aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2020-10-11 10:16:32 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2020-10-11 10:16:32 +0000
commit57879ba2e23d899b71230185993181abe15f9529 (patch)
treed4bb44fc31ba250e34d5ddf2575de86941bd4608 /emulators
parent6d2ac836e923d992196f0195fd6089ade674e7f3 (diff)
downloadports-57879ba2e23d899b71230185993181abe15f9529.tar.gz
ports-57879ba2e23d899b71230185993181abe15f9529.zip
Update to Wine 5.19.
This includes the following changes from Wine 5.18 which we had to skip since it failed to build on FreeBSD: - USER32 library converted to PE. - Console no longer requires the curses library. - Support for display modes with various orientations. - A number of syntax fixes in the WIDL compiler. - Vulkan shader compilation using the new vkd3d-shader library. - Non-recursive makefiles. Plus the following changes from version 5.19 itself: - Wine Mono engine updated to 5.1.1, with WPF text formatting support. - KERNEL32 library converted to PE. - DSS cryptographic provider. - Windowing support in the new console host. - A number of exception handling fixes. - Various bug fixes. Our local patch files/patch-tools-makedep became obsolete by those changes that first broke version 5.18 and now appear fixed in 5.19. files/patch-dlls_kernel32_Makefile.in needs some adjustments due to changed context, but retains the core tweak we've been carrying.
Notes
Notes: svn path=/head/; revision=552045
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile5
-rw-r--r--emulators/wine-devel/distinfo8
-rw-r--r--emulators/wine-devel/files/patch-dlls_kernel32_Makefile.in12
-rw-r--r--emulators/wine-devel/files/patch-tools-makedep32
-rw-r--r--emulators/wine-devel/pkg-plist10
5 files changed, 22 insertions, 45 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index ee03977b0acf..95b489275101 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= wine
-DISTVERSION= 5.17
-PORTREVISION= 1
+DISTVERSION= 5.19
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SF/${PORTNAME}/Source \
@@ -95,7 +94,7 @@ LDAP_USE= OPENLDAP=yes
LIBXSLT_CONFIGURE_WITH= xslt
LIBXSLT_LIB_DEPENDS= libxslt.so:textproc/libxslt
-MONO_RUN_DEPENDS= ${DATADIR}/mono/wine-mono-5.1.0-x86.msi:emulators/wine-mono-devel
+MONO_RUN_DEPENDS= ${DATADIR}/mono/wine-mono-5.1.1-x86.msi:emulators/wine-mono-devel
MPG123_CONFIGURE_WITH= mpg123
MPG123_LIB_DEPENDS= libmpg123.so:audio/mpg123
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index 0bf4ed13535f..d420cd5122e4 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,5 +1,3 @@
-TIMESTAMP = 1599901008
-SHA256 (wine-5.17.tar.xz) = f6438bd01314838131010b0a6e8c04f413bdd890cd10e69ba3e199d0090a1e4f
-SIZE (wine-5.17.tar.xz) = 24064512
-SHA256 (v5.17.tar.gz) = 75fda21f97b8548033aac4432fb163b5653c8924cea053679edb012ebdd6e34f
-SIZE (v5.17.tar.gz) = 10342408
+TIMESTAMP = 1602322053
+SHA256 (wine-5.19.tar.xz) = 0020482b9eeae84ea1a1281323a4bcd1b17dbd45ea2e8beb3a10073787e697c7
+SIZE (wine-5.19.tar.xz) = 24201860
diff --git a/emulators/wine-devel/files/patch-dlls_kernel32_Makefile.in b/emulators/wine-devel/files/patch-dlls_kernel32_Makefile.in
index 07070763a842..094590a598b6 100644
--- a/emulators/wine-devel/files/patch-dlls_kernel32_Makefile.in
+++ b/emulators/wine-devel/files/patch-dlls_kernel32_Makefile.in
@@ -2,6 +2,8 @@ Author: David Naylor <naylor.b.david@gmail.com>
Date: Mon Feb 2 22:10:55 2015 +0200
Author: Gerald Pfeifer <gerald@pfeifer.com>
Date: Sat Jun 6, 17:32:59 UTC 2020
+Author: Gerald Pfeifer <gerald@pfeifer.com>
+Date: Sat Oct 10 12:33:41 EEST 2020
kernel32: force 4096 byte page alignment.
@@ -14,12 +16,12 @@ diff --git a/dlls/kernel32/Makefile.in b/dlls/kernel32/Makefile.in
index c09771d..a006c2c 100644
--- dlls/kernel32/Makefile.in
+++ dlls/kernel32/Makefile.in
-@@ -3,7 +3,7 @@
+@@ -2,7 +2,7 @@
+ MODULE = kernel32.dll
IMPORTLIB = kernel32
- IMPORTS = winecrt0 kernelbase ntdll
- EXTRALIBS = $(COREFOUNDATION_LIBS) $(POLL_LIBS) $(RT_LIBS)
--EXTRADLLFLAGS = -nodefaultlibs -Wb,-F,KERNEL32.dll -Wl,--image-base,0x7b600000
-+EXTRADLLFLAGS = -nodefaultlibs -Wb,-F,KERNEL32.dll -Wl,--image-base,0x7b600000 -Wl,-z,max-page-size=0x1000
+ IMPORTS = kernelbase ntdll winecrt0
+-EXTRADLLFLAGS = -mno-cygwin -nodefaultlibs -Wb,-F,KERNEL32.dll -Wl,--image-base,0x7b600000
++EXTRADLLFLAGS = -mno-cygwin -nodefaultlibs -Wb,-F,KERNEL32.dll -Wl,--image-base,0x7b600000 -Wl,-z,max-page-size=0x1000
C_SRCS = \
atom.c \
diff --git a/emulators/wine-devel/files/patch-tools-makedep b/emulators/wine-devel/files/patch-tools-makedep
deleted file mode 100644
index 407b6cff6f48..000000000000
--- a/emulators/wine-devel/files/patch-tools-makedep
+++ /dev/null
@@ -1,32 +0,0 @@
-Revert
-
- commit 7571fa87df453e404d8b6ca58e2da95340156849
- Author: Alexandre Julliard <julliard@winehq.org>
- Date: Mon Aug 24 13:30:12 2020 +0200
-
- makefiles: Don't implicitly import the module itself when -nodefaultlibs is used.
-
- Signed-off-by: Alexandre Julliard <julliard@winehq.org>
-
-which breaks the build with GCC 9.
-
-Disclaimer: This is a temporary hack!
-
---- UTC
-diff --git a/tools/makedep.c b/tools/makedep.c
-index 4bd20d469d..825458156f 100644
---- tools/makedep.c
-+++ tools/makedep.c
-@@ -2212,11 +2212,7 @@ static struct strarray add_import_libs( const struct makefile *make, struct stra
- const char *lib = NULL;
-
- /* skip module's own importlib, its object files will be linked directly */
-- if (make->importlib && !strcmp( make->importlib, imports.str[i] ))
-- {
-- if (!is_unix) continue;
-- if (strarray_exists( &make->extradllflags, "-nodefaultlibs" )) continue;
-- }
-+ if (make->importlib && !is_unix && !strcmp( make->importlib, imports.str[i] )) continue;
-
- for (j = 0; j < top_makefile->subdirs.count; j++)
- {
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index 4360ace46b48..df6c9b74ec0c 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -242,6 +242,8 @@ include/wine/windows/d3d11sdklayers.idl
include/wine/windows/d3d11shader.h
include/wine/windows/d3d12.h
include/wine/windows/d3d12.idl
+include/wine/windows/d3d12sdklayers.h
+include/wine/windows/d3d12sdklayers.idl
include/wine/windows/d3d12shader.h
include/wine/windows/d3d12shader.idl
include/wine/windows/d3d8.h
@@ -675,6 +677,8 @@ include/wine/windows/objectarray.h
include/wine/windows/objectarray.idl
include/wine/windows/objidl.h
include/wine/windows/objidl.idl
+include/wine/windows/objidlbase.h
+include/wine/windows/objidlbase.idl
include/wine/windows/objsafe.h
include/wine/windows/objsafe.idl
include/wine/windows/objsel.h
@@ -1319,6 +1323,7 @@ lib/wine/avifil32.dll.so
%%WINE32%%lib/wine/avifile.dll16.so
lib/wine/avrt.dll.so
lib/wine/bcrypt.dll.so
+lib/wine/bcrypt.so
lib/wine/bluetoothapis.dll.so
lib/wine/browseui.dll.so
lib/wine/bthprops.cpl.so
@@ -2394,6 +2399,7 @@ lib/wine/fakedlls/wdscore.dll
lib/wine/fakedlls/webservices.dll
lib/wine/fakedlls/wer.dll
lib/wine/fakedlls/wevtapi.dll
+lib/wine/fakedlls/wevtsvc.dll
lib/wine/fakedlls/wevtutil.exe
lib/wine/fakedlls/where.exe
lib/wine/fakedlls/whoami.exe
@@ -2935,6 +2941,7 @@ lib/wine/ntprint.dll.so
%%WINE64%%%%STAGING%%lib/wine/nvencodeapi64.dll.so
lib/wine/objsel.dll.so
lib/wine/odbc32.dll.so
+lib/wine/odbc32.so
lib/wine/odbcbcp.dll.so
lib/wine/odbccp32.dll.so
lib/wine/odbccu32.dll.so
@@ -3091,6 +3098,7 @@ lib/wine/urlmon.dll.so
lib/wine/usbd.sys.so
%%WINE32%%lib/wine/user.exe16.so
lib/wine/user32.dll.so
+lib/wine/user32.so
lib/wine/userenv.dll.so
lib/wine/usp10.dll.so
lib/wine/utildll.dll.so
@@ -3126,6 +3134,7 @@ lib/wine/wdscore.dll.so
lib/wine/webservices.dll.so
lib/wine/wer.dll.so
lib/wine/wevtapi.dll.so
+lib/wine/wevtsvc.dll.so
lib/wine/wevtutil.exe.so
lib/wine/where.exe.so
lib/wine/whoami.exe.so
@@ -3325,6 +3334,7 @@ share/applications/wine.desktop
%%DATADIR%%/nls/c_28605.nls
%%DATADIR%%/nls/c_437.nls
%%DATADIR%%/nls/c_500.nls
+%%DATADIR%%/nls/c_708.nls
%%DATADIR%%/nls/c_737.nls
%%DATADIR%%/nls/c_775.nls
%%DATADIR%%/nls/c_850.nls