aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-12-20 12:40:07 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-12-20 12:40:07 +0000
commit59b8ce2440f0716777dee49eb321281117a85825 (patch)
treefeb772252a0b5426d9c9ba46993ed6ab8ea5fdfe /emulators
parent640fff83fe3524262e48a9808f7d0cb0715ee003 (diff)
downloadports-59b8ce2440f0716777dee49eb321281117a85825.tar.gz
ports-59b8ce2440f0716777dee49eb321281117a85825.zip
DBoxFE is a Qt4 frontend for DOSBox. With DBoxFE you can create and
manage your configuration files very easily, which are needed by DOSBox. In addition it's also possible to create gameprofiles to generate different configuration files WWW: http://chmaster.freeforge.net/dboxfe-project.htm/ PR: ports/118495 Submitted by: Max Brazhnikov <makc at issp.ac.ru>
Notes
Notes: svn path=/head/; revision=204209
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/dboxfe/Makefile53
-rw-r--r--emulators/dboxfe/distinfo3
-rw-r--r--emulators/dboxfe/files/patch-src__dboxfe.cpp30
-rw-r--r--emulators/dboxfe/pkg-descr6
5 files changed, 93 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 5ad5793d8c1b..5b577922041d 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -19,6 +19,7 @@
SUBDIR += cpmtools
SUBDIR += cygne-sdl
SUBDIR += darcnes
+ SUBDIR += dboxfe
SUBDIR += desmume
SUBDIR += dgen-sdl
SUBDIR += dlx
diff --git a/emulators/dboxfe/Makefile b/emulators/dboxfe/Makefile
new file mode 100644
index 000000000000..c9606f61df00
--- /dev/null
+++ b/emulators/dboxfe/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: dboxfe
+# Date created: 2007-12-08
+# Whom: Max Brazhnikov <makc@issp.ac.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dboxfe
+PORTVERSION= 0.1.3
+CATEGORIES= emulators
+MASTER_SITES= ${MASTER_SITE_BERLIOS}
+MASTER_SITE_SUBDIR=${PORTNAME}
+
+MAINTAINER= makc@issp.ac.ru
+COMMENT= A Qt4 front-end to DOSBox
+
+RUN_DEPENDS= dosbox:${PORTSDIR}/emulators/dosbox
+
+USE_BZIP2= yes
+USE_QT_VER= 4
+QT_COMPONENTS= gui network xml uic_build moc_build qmake_build rcc_build
+HAS_CONFIGURE= yes
+
+PLIST_FILES= dboxfe dboxfetray
+
+.include <bsd.port.pre.mk>
+
+PRO_DIRS= . dboxfetray
+
+do-configure:
+.for dir in ${PRO_DIRS}
+ @(cd ${WRKSRC}/${dir} && ${SETENV} ${CONFIGURE_ENV} ${QMAKE})
+.endfor
+
+post-configure:
+.for dir in ${PRO_DIRS}
+ @${REINPLACE_CMD} -e \
+ 's|^CC .*|CC=${CC}|; \
+ s|^CXX .*|CXX=${CXX}|; \
+ s|^LINK .*|LINK=${CXX}|' \
+ ${WRKSRC}/${dir}/Makefile
+.endfor
+
+do-build:
+.for dir in ${PRO_DIRS}
+ @(cd ${WRKSRC}/${dir} && ${SETENV} ${MAKE_ENV} ${MAKE})
+.endfor
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/dboxfe ${PREFIX}/bin/dboxfe
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/dboxfetray ${PREFIX}/bin/dboxfetray
+
+.include <bsd.port.post.mk>
diff --git a/emulators/dboxfe/distinfo b/emulators/dboxfe/distinfo
new file mode 100644
index 000000000000..2f89a9951871
--- /dev/null
+++ b/emulators/dboxfe/distinfo
@@ -0,0 +1,3 @@
+MD5 (dboxfe-0.1.3.tar.bz2) = 1f6224c0eae16502349504e1b722d4aa
+SHA256 (dboxfe-0.1.3.tar.bz2) = a1e8e2fa1b3221f3e7dc14c065e93eede3b9d744d94047118cc730207eb52c5c
+SIZE (dboxfe-0.1.3.tar.bz2) = 260934
diff --git a/emulators/dboxfe/files/patch-src__dboxfe.cpp b/emulators/dboxfe/files/patch-src__dboxfe.cpp
new file mode 100644
index 000000000000..61c6141a5127
--- /dev/null
+++ b/emulators/dboxfe/files/patch-src__dboxfe.cpp
@@ -0,0 +1,30 @@
+--- ./src/dboxfe.cpp.orig 2007-09-22 13:25:00.000000000 +0400
++++ ./src/dboxfe.cpp 2007-12-08 16:43:17.000000000 +0300
+@@ -65,7 +65,7 @@
+ connect ( chkBoxStartTrayIcon, SIGNAL ( toggled ( bool ) ), this, SLOT ( slotChkBoxStartTrayIconToggled ( bool ) ) );
+
+ // windows title for the application
+- titleLin = tr ( "DBoxFE - Front End for DOSBox 0.7x - Linux Version " ) + getAppVersion();
++ titleLin = tr ( "DBoxFE" );
+ titleWin = tr ( "DBoxFE - Front End for DOSBox 0.7x - Windows Version " ) + getAppVersion();
+ titleMac = tr ( "DBoxFE - Front End for DOSBox 0.7x - Mac Version " ) + getAppVersion();
+
+@@ -83,18 +83,6 @@
+ QApplication::setStyle ( "plastique" );
+ #endif
+
+-#ifdef Q_OS_UNIX
+- setWindowTitle ( titleLin );
+- QApplication::setStyle ( "plastique" );
+-#endif
+-
+- // center the application on desktop screen
+- QDesktopWidget *desktop = qApp->desktop();
+- const QRect rect = desktop->availableGeometry ( desktop->primaryScreen() );
+- int left = ( rect.width() - width() ) / 2;
+- int top = ( rect.height() - height() ) / 2;
+- setGeometry ( left, top, width(), height() );
+-
+ //for future release :)
+ chkBoxStartTrayIcon->setVisible( false );
+ }
diff --git a/emulators/dboxfe/pkg-descr b/emulators/dboxfe/pkg-descr
new file mode 100644
index 000000000000..889d191e303b
--- /dev/null
+++ b/emulators/dboxfe/pkg-descr
@@ -0,0 +1,6 @@
+DBoxFE is a Qt4 frontend for DOSBox. With DBoxFE you can create and
+manage your configuration files very easily, which are needed by
+DOSBox. In addition it's also possible to create gameprofiles to
+generate different configuration files
+
+WWW: http://chmaster.freeforge.net/dboxfe-project.htm/