aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2023-02-28 03:07:35 +0000
committerJan Beich <jbeich@FreeBSD.org>2023-02-28 16:03:50 +0000
commit5e71e4d451294a5456ceedd94512fea1d958e2c8 (patch)
tree0a69c6d8ca60e905b3540ac0d76efa6c7442c68d /emulators
parentc55c1afc5f796a5c77c07ffe7299dce66b789ea3 (diff)
downloadports-5e71e4d451294a5456ceedd94512fea1d958e2c8.tar.gz
ports-5e71e4d451294a5456ceedd94512fea1d958e2c8.zip
emulators/yuzu: unbreak LTO on FreeBSD < 13.2
/usr/bin/llvm-ar: error: src/video_core/libvideo_core.a: Not an int attribute (Producer: 'LLVM15.0.7' Reader: 'LLVM 13.0.0')
Diffstat (limited to 'emulators')
-rw-r--r--emulators/yuzu/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index aea3102ac570..2fdb96ab627c 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -1,5 +1,6 @@
PORTNAME= yuzu
PORTVERSION= s20230226
+PORTREVISION= 1
CATEGORIES= emulators wayland
.if make(makesum)
MASTER_SITES= https://api.yuzu-emu.org/gamedb/?dummy=/:gamedb
@@ -150,11 +151,11 @@ post-patch-VAAPI-off:
.if !exists(/usr/include/c++/v1/__ranges/as_rvalue_view.h) || make(makesum) || make(fetch)
. if !exists(/usr/include/c++/v1/__memory/concepts.h)
USES+= llvm:min=14,build
+PATH:= ${LLVM_PREFIX}/bin:${PATH} # XXX _CMAKE_TOOLCHAIN_SUFFIX vs. devel/llvm*
CC= clang${LLVM_VERSION}
CXX= clang++${LLVM_VERSION}
CPP= clang-cpp${LLVM_VERSION}
CONFIGURE_ENV+= CC="${CC}" CXX="${CXX}" CPP="${CPP}"
-OPTIONS_EXCLUDE+= LTO # llvm-ar
. endif
# XXX Move into separate port and standardize via USES