aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJung-uk Kim <jkim@FreeBSD.org>2015-05-15 19:29:10 +0000
committerJung-uk Kim <jkim@FreeBSD.org>2015-05-15 19:29:10 +0000
commit61fe94530ad8af5ea87f8689aacfea5911d109a0 (patch)
tree4ab6d567922417ed4c2af8da63de23ffbea8e6dc /emulators
parentcbe79b758081bb63947ab59443f624d2ee40f258 (diff)
downloadports-61fe94530ad8af5ea87f8689aacfea5911d109a0.tar.gz
ports-61fe94530ad8af5ea87f8689aacfea5911d109a0.zip
Fix build without OpenSSL in the base.
PR: 199377
Notes
Notes: svn path=/head/; revision=386475
Diffstat (limited to 'emulators')
-rw-r--r--emulators/virtualbox-ose/Makefile5
-rw-r--r--emulators/virtualbox-ose/files/patch-configure17
2 files changed, 18 insertions, 4 deletions
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index 888c51a9eb7f..1f91394d33ff 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -36,6 +36,7 @@ ONLY_FOR_ARCHS= i386 amd64
USES= compiler cpe iconv pkgconfig tar:bzip2
USE_GNOME= libidl
USE_LDCONFIG= ${VBOX_DIR}
+USE_OPENSSL= yes
HAS_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-java --passive-mesa
@@ -206,6 +207,10 @@ EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-Config.kmk \
${PATCHDIR}/extrapatch-src-recompiler-Makefile.kmk
.endif
+.if !defined(WITH_OPENSSL_BASE)
+CONFIGURE_ARGS+= --with-openssl-dir="${OPENSSLBASE}"
+.endif
+
pre-everything::
.if ${ARCH} == "amd64"
.if !exists(/usr/lib32/libc.so)
diff --git a/emulators/virtualbox-ose/files/patch-configure b/emulators/virtualbox-ose/files/patch-configure
index 4bea77d203cc..9d9a366fdf76 100644
--- a/emulators/virtualbox-ose/files/patch-configure
+++ b/emulators/virtualbox-ose/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig 2012-03-16 10:34:01.000000000 +0100
-+++ configure 2012-03-24 18:52:57.271018829 +0100
-@@ -135,6 +135,8 @@
+--- configure.orig 2015-05-13 11:08:57.000000000 -0400
++++ configure 2015-05-15 14:16:05.988372000 -0400
+@@ -140,6 +140,8 @@
LIBPULSE="-L/usr/local/lib"
INCPNG="-I/usr/local/include"
LIBPNG="-L/usr/local/lib -lpng"
@@ -9,7 +9,7 @@
else
INCCURL=""
LIBCURL="-lcurl"
-@@ -1837,8 +1839,8 @@
+@@ -1947,8 +1949,8 @@
echo "compiling the following source file:" >> $LOG
cat $ODIR.tmp_src.cc >> $LOG
echo "using the following command line:" >> $LOG
@@ -20,3 +20,12 @@
if [ $? -eq 0 ]; then
found=1
break
+@@ -2357,7 +2359,7 @@
+ --with-openssl-dir=*)
+ OPENSSLDIR=`echo $option | cut -d'=' -f2`
+ INCCRYPTO="-I${OPENSSLDIR}/include"
+- LIBCRYPTO="${OPENSSLDIR}/lib/libcrypto.a ${OPENSSLDIR}/lib/libssl.a"
++ LIBCRYPTO="-L${OPENSSLDIR}/lib -lcrypto -lssl"
+ ;;
+ --with-ow-dir=*)
+ WATCOM=`echo $option | cut -d'=' -f2`