aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2022-11-07 17:32:58 +0000
committerJan Beich <jbeich@FreeBSD.org>2022-11-07 20:22:25 +0000
commit64c2cc440f5882a61fc5a13f4f1d4a0216946698 (patch)
treeae938a4d34795dce40ed4bbc95c7740af211fd9b /emulators
parent4a1ebb41252cb1bf51efa9c4649330880df89f07 (diff)
downloadports-64c2cc440f5882a61fc5a13f4f1d4a0216946698.tar.gz
ports-64c2cc440f5882a61fc5a13f4f1d4a0216946698.zip
emulators/yuzu: avoid gcc* dep via shlib_required after 4021ff7b85d9
Error: /usr/local/bin/yuzu is linked to /usr/local/lib/gcc11/libgcc_s.so.1 from lang/gcc11 but it is not declared as a dependency
Diffstat (limited to 'emulators')
-rw-r--r--emulators/yuzu/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/emulators/yuzu/Makefile b/emulators/yuzu/Makefile
index ec37b1d185b6..60e7c873aafd 100644
--- a/emulators/yuzu/Makefile
+++ b/emulators/yuzu/Makefile
@@ -1,5 +1,6 @@
PORTNAME= yuzu
PORTVERSION= s20221105
+PORTREVISION= 1
CATEGORIES= emulators
.if make(makesum)
MASTER_SITES= https://api.yuzu-emu.org/gamedb/?dummy=/:gamedb
@@ -62,7 +63,7 @@ CMAKE_ON+= BUNDLE_SPEEX # only used by cubeb tests
CMAKE_OFF= YUZU_USE_BUNDLED_OPUS YUZU_USE_EXTERNAL_SDL2
CMAKE_OFF+= ${CMAKE_TESTING_ON}
CMAKE_TESTING_ON= YUZU_TESTS
-LDFLAGS+= -static-libstdc++ # avoid libc++ conflict, requires files/patch-fmt
+LDFLAGS+= -static-libstdc++ -static-libgcc # avoid libc++ conflict, requires files/patch-fmt
LDFLAGS+= -Wl,--as-needed # Qt5Network
ELF_FEATURES= ${PLIST_FILES:Mbin/*:S/^/+wxneeded:/}
PLIST_FILES= bin/${PORTNAME}-cmd \