aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2021-01-23 09:07:12 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2021-01-23 09:07:12 +0000
commit7be0d7f0a55d7d1901047a380152e00e7e5fc33d (patch)
tree2cd09e089a5dceaef1780efe0ef3a05c3a9a087a /emulators
parent608bb53853fe73b31145eb315e93e567e1d93f29 (diff)
downloadports-7be0d7f0a55d7d1901047a380152e00e7e5fc33d.tar.gz
ports-7be0d7f0a55d7d1901047a380152e00e7e5fc33d.zip
emulators/dosbox-staging:
- Update to 0.76.0 - Add midi support via fluidsynth (enabled by default) Release notes: https://dosbox-staging.github.io/v0-76-0/
Notes
Notes: svn path=/head/; revision=562382
Diffstat (limited to 'emulators')
-rw-r--r--emulators/dosbox-staging/Makefile10
-rw-r--r--emulators/dosbox-staging/distinfo6
-rw-r--r--emulators/dosbox-staging/files/patch-Makefile.am9
3 files changed, 19 insertions, 6 deletions
diff --git a/emulators/dosbox-staging/Makefile b/emulators/dosbox-staging/Makefile
index 60064b666455..6889a956ffad 100644
--- a/emulators/dosbox-staging/Makefile
+++ b/emulators/dosbox-staging/Makefile
@@ -2,7 +2,7 @@
PORTNAME= dosbox-staging
DISTVERSIONPREFIX= v
-DISTVERSION= 0.75.2
+DISTVERSION= 0.76.0
CATEGORIES= emulators
MAINTAINER= makc@FreeBSD.org
@@ -13,7 +13,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libopusfile.so:audio/opusfile \
libpng.so:graphics/png
-USES= autoreconf compiler:c++11-lang gl pkgconfig sdl
+USES= autoreconf compiler:c++14-lang gl pkgconfig sdl
USE_GL= gl
USE_SDL= sdl2 net2
@@ -22,12 +22,16 @@ USE_GITHUB= yes
GNU_CONFIGURE= yes
LDFLAGS+= -pthread
-OPTIONS_DEFINE= ALSA DOCS
+OPTIONS_DEFINE= ALSA DOCS FLUIDSYNTH
+OPTIONS_DEFAULT= FLUIDSYNTH
ALSA_DESC= ALSA midi support
ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_CONFIGURE_ENABLE= alsa-midi
+FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
+FLUIDSYNTH_CONFIGURE_ENABLE= fluidsynth
+
PORTDOCS= NEWS README README.md
post-patch:
diff --git a/emulators/dosbox-staging/distinfo b/emulators/dosbox-staging/distinfo
index f594cbcd16ad..a2c5494e7584 100644
--- a/emulators/dosbox-staging/distinfo
+++ b/emulators/dosbox-staging/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1604131390
-SHA256 (dosbox-staging-dosbox-staging-v0.75.2_GH0.tar.gz) = 6546427cb3218224a5e3f97c5a4a30960aca5eced3e44ab94810357f36fcfafb
-SIZE (dosbox-staging-dosbox-staging-v0.75.2_GH0.tar.gz) = 1816233
+TIMESTAMP = 1611347947
+SHA256 (dosbox-staging-dosbox-staging-v0.76.0_GH0.tar.gz) = 7df53c22f7ce78c70afb60b26b06742b90193b56c510219979bf12e0bb2dc6c7
+SIZE (dosbox-staging-dosbox-staging-v0.76.0_GH0.tar.gz) = 1908605
diff --git a/emulators/dosbox-staging/files/patch-Makefile.am b/emulators/dosbox-staging/files/patch-Makefile.am
new file mode 100644
index 000000000000..14def1d9eda0
--- /dev/null
+++ b/emulators/dosbox-staging/files/patch-Makefile.am
@@ -0,0 +1,9 @@
+--- Makefile.am.orig 2021-01-22 20:52:17 UTC
++++ Makefile.am
+@@ -1,6 +1,5 @@
+ # Main Makefile for DOSBox
+
+-AM_MAKEFLAGS ?= --no-print-directory
+
+ EXTRA_DIST = autogen.sh contrib
+