aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorAlejandro Pulver <alepulver@FreeBSD.org>2007-03-05 09:47:15 +0000
committerAlejandro Pulver <alepulver@FreeBSD.org>2007-03-05 09:47:15 +0000
commit876be751dff8dbadb9ff2cf95eca1bad7c45a410 (patch)
treecdef32a4de30cefd1c9b2e7a0b73e44d90f73e1a /emulators
parentf5a409d7cb404df3af994e00fa07c42dc7e6ded9 (diff)
downloadports-876be751dff8dbadb9ff2cf95eca1bad7c45a410.tar.gz
ports-876be751dff8dbadb9ff2cf95eca1bad7c45a410.zip
- Update to version 0.16.
- Do not use PYTHON_PKGNAMEPREFIX since it is not a Python module. - Remove default DISTNAME. - Use Bourne Shell (/bin/sh) script instead of bash (also it was not listed in RUN_DEPENDS). - Make PSYCHO an option instead of a knob. - Respect NOPORTDOCS. - Clean up. PR: ports/109421 Submitted by: alepulver (myself) Approved by: robb_force@holybuffalo.net (maintainer, timeout)
Notes
Notes: svn path=/head/; revision=186569
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wahcade/Makefile105
-rw-r--r--emulators/wahcade/distinfo6
-rw-r--r--emulators/wahcade/files/pkg-message.in (renamed from emulators/wahcade/pkg-message)16
-rw-r--r--emulators/wahcade/pkg-plist106
4 files changed, 119 insertions, 114 deletions
diff --git a/emulators/wahcade/Makefile b/emulators/wahcade/Makefile
index 6ce3e6c06c22..754e5327577d 100644
--- a/emulators/wahcade/Makefile
+++ b/emulators/wahcade/Makefile
@@ -5,87 +5,62 @@
# $FreeBSD$
#
-PORTNAME= wahcade
-PORTVERSION= 0.11
-CATEGORIES= emulators
-MASTER_SITES= http://www.anti-particle.com/projects/wahcade/
-PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= ${PORTNAME}-${PORTVERSION}
+PORTNAME= wahcade
+PORTVERSION= 0.16
+CATEGORIES= emulators
+MASTER_SITES= http://www.anti-particle.com/projects/wahcade/
-MAINTAINER= robb_force@holybuffalo.net
-COMMENT= A frontend for almost any emulator (MameWAH clone)
+MAINTAINER= robb_force@holybuffalo.net
+COMMENT= A frontend for almost any emulator (MameWAH clone)
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygtk.pth:${PORTSDIR}/x11-toolkits/py-gtk2 \
- ${PYTHON_SITELIBDIR}/cElementTree.so:${PORTSDIR}/devel/py-celementtree
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pygtk.pth:${PORTSDIR}/x11-toolkits/py-gtk2 \
+ ${PYTHON_SITELIBDIR}/cElementTree.so:${PORTSDIR}/devel/py-celementtree
-WRKSRC= ${WRKDIR}/${PORTNAME}
-USE_PYTHON= 2.4+
-NO_BUILD= yes
-OPTIONS= MPLAYER "For movie playback." off
-# Bypass infrasructure bug (taken from www/py-turbogears)
-OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
-BINDIR= ${PREFIX}/bin
+USE_PYTHON= 2.4+
+WRKSRC= ${WRKDIR}/${PORTNAME}
-.include <bsd.port.pre.mk>
+OPTIONS= MPLAYER "Install mplayer for movie playback" off \
+ PSYCHO "Enable psycho optimization" on
-.if ${ARCH} != "i386"
-WITHOUT_PSYCO= yes
-.endif
+SUB_FILES= pkg-message
-# required for PSYCO
-.ifndef(WITHOUT_PSYCO)
-RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
-.endif
+.include <bsd.port.pre.mk>
.if defined(WITH_MPLAYER)
-RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
+RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
.endif
-pre-everything::
-.ifndef(WITHOUT_PSYCO)
- @${ECHO_MSG} '===> Define WITHOUT_PSYCO to disable devel/py-psyco optimization'
+.if !defined(WITHOUT_PSYCHO) && ${ARCH} == "i386"
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/psyco/_psyco.so:${PORTSDIR}/devel/py-psyco
.endif
-# setup.py seems to be for windows, so run the patched install script
-do-install:
- #wahcade start script
- echo "#!${BINDIR}/bash" > ${BINDIR}/${PORTNAME}
- echo "cd ${DATADIR}" >> ${BINDIR}/${PORTNAME}
- echo "python ${PORTNAME} \$*" >> ${BINDIR}/${PORTNAME}
- ${CHMOD} 755 ${BINDIR}/${PORTNAME}
-
- #install files
- ${INSTALL} -d -v ${DATADIR}
- ${INSTALL} -m 644 ${WRKSRC}/*.py ${DATADIR}
- ${INSTALL} -m 755 ${WRKSRC}/${PORTNAME} ${DATADIR}
- ${INSTALL} -d -v ${DATADIR}/config.dist
- ${INSTALL} -d -v ${DATADIR}/config.dist/ctrlr
- ${INSTALL} -d -v ${DATADIR}/config.dist/files
- ${INSTALL} -d -v ${DATADIR}/config.dist/ini
- ${INSTALL} -d -v ${DATADIR}/config.dist/layouts
- ${INSTALL} -d -v ${DATADIR}/config.dist/layouts/classic\ 640x480
- ${INSTALL} -d -v ${DATADIR}/config.dist/layouts/classic\ 800x600
- ${INSTALL} -d -v ${DATADIR}/config.dist/layouts/classic\ 1024x768
- ${INSTALL} -d -v ${DATADIR}/config.dist/layouts/cpviewer
- ${INSTALL} -d -v ${DATADIR}/pixmaps
- ${INSTALL} -m 644 ${WRKSRC}/config.dist/*.ini ${DATADIR}/config.dist
- ${INSTALL} -m 644 ${WRKSRC}/config.dist/ctrlr/*.ini ${DATADIR}/config.dist/ctrlr
- #${INSTALL} -m 644 ${WRKSRC}/config.dist/files/* ${DATADIR}/config.dist/files
- ${INSTALL} -m 644 ${WRKSRC}/config.dist/ini/*.ini ${DATADIR}/config.dist/ini
- ${INSTALL} -m 644 ${WRKSRC}/config.dist/layouts/classic\ 640x480/* ${DATADIR}/config.dist/layouts/classic\ 640x480
- ${INSTALL} -m 644 ${WRKSRC}/config.dist/layouts/classic\ 800x600/* ${DATADIR}/config.dist/layouts/classic\ 800x600
- ${INSTALL} -m 644 ${WRKSRC}/config.dist/layouts/classic\ 1024x768/* ${DATADIR}/config.dist/layouts/classic\ 1024x768
- ${INSTALL} -m 644 ${WRKSRC}/config.dist/layouts/cpviewer/* ${DATADIR}/config.dist/layouts/cpviewer
- ${INSTALL} -m 644 ${WRKSRC}/pixmaps/*.png ${DATADIR}/pixmaps
+do-build:
+ @(${ECHO_CMD} "#!${SH}"; \
+ ${ECHO_CMD} "cd ${DATADIR} || exit 1"; \
+ ${ECHO_CMD} 'exec ${PYTHON_CMD} ${PORTNAME}.py "$$@"') \
+ > ${WRKSRC}/${PORTNAME}
- #compile everything python
- ${PYTHON_CMD} -c "import compileall; compileall.compile_dir('${DATADIR}')"
-
-post-install:
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
+ ${MKDIR} ${DATADIR}
+.for f in *.py config.dist glade locale pixmaps templates
+ ${CP} -R ${WRKSRC}/${f} ${DATADIR}
+.endfor
+ ${MKDIR} ${PREFIX}/share/applications
+ ${INSTALL_DATA} ${WRKSRC}/${PORTNAME}.desktop \
+ ${PREFIX}/share/applications
+ @${FIND} ${DATADIR} -type d -print0 | ${XARGS} -0 ${CHMOD} ${BINMODE}
+ @${FIND} ${DATADIR} -type f -print0 | ${XARGS} -0 ${CHMOD} ${SHAREMODE}
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/* ${DOCSDIR}
+ ${CP} -R ${WRKSRC}/doc/* ${DOCSDIR}
+ @${FIND} ${DOCSDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} ${BINMODE}
+ @${FIND} ${DOCSDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} ${SHAREMODE}
.endif
+
+post-install:
+ @${ECHO_CMD}
@${CAT} ${PKGMESSAGE}
+ @${ECHO_CMD}
.include <bsd.port.post.mk>
diff --git a/emulators/wahcade/distinfo b/emulators/wahcade/distinfo
index 53167db5c11f..69a07ab45c73 100644
--- a/emulators/wahcade/distinfo
+++ b/emulators/wahcade/distinfo
@@ -1,3 +1,3 @@
-MD5 (wahcade-0.11.tar.gz) = 899003aace0ec93709cbb6496cc83dfb
-SHA256 (wahcade-0.11.tar.gz) = 52ad28d8397aee6ddd27992d039bc1de7e7f1d2bd1fb3804a5e04fd6e30f91cb
-SIZE (wahcade-0.11.tar.gz) = 134497
+MD5 (wahcade-0.16.tar.gz) = f5c5ad11755cf68e01a0fc45de20ddea
+SHA256 (wahcade-0.16.tar.gz) = 01d61cf4b920b19df34282c50559f1f24597b4982f9f712f891959ded0afa553
+SIZE (wahcade-0.16.tar.gz) = 194939
diff --git a/emulators/wahcade/pkg-message b/emulators/wahcade/files/pkg-message.in
index 7c2666c4db41..6083505dad57 100644
--- a/emulators/wahcade/pkg-message
+++ b/emulators/wahcade/files/pkg-message.in
@@ -1,10 +1,14 @@
-************************************************************************
+==============================================================================
+
Wah!Cade has been successfully installed!
-The default config files are stored in wahcade/config.dist.
+The default config files are stored in
+"%%DATADIR%%/config.dist".
+
When Wah!Cade is first run these files are copied into the user's
-~/.wahcade directory.
+"~/.wahcade" directory.
+
+Please read the README file for information on initial setup & configuration
+in "%%DOCSDIR%%".
-HINT: Please read the README file in docs/wahcade for information on
-initial setup & configuration!
-************************************************************************
+==============================================================================
diff --git a/emulators/wahcade/pkg-plist b/emulators/wahcade/pkg-plist
index 9ddfb974067d..bad3657888b6 100644
--- a/emulators/wahcade/pkg-plist
+++ b/emulators/wahcade/pkg-plist
@@ -1,24 +1,29 @@
bin/wahcade
-%%DOCSDIR%%/CHANGELOG
-%%DOCSDIR%%/COPYING
-%%DOCSDIR%%/INI_FILES
-%%DOCSDIR%%/INSTALL
-%%DOCSDIR%%/KEYS
-%%DOCSDIR%%/README
-%%DOCSDIR%%/TODO
-%%DOCSDIR%%/fav_format.txt
-%%DOCSDIR%%/filter_format.txt
-%%DOCSDIR%%/gamelist_format.txt
-%%DOCSDIR%%/layout_format.txt
-%%DOCSDIR%%/xmame-x11rc
-%%DOCSDIR%%/xmame-x11rc.pre88
-%%DOCSDIR%%/xmame_options.pre88.txt
-%%DOCSDIR%%/xmame_options.txt
-%%DOCSDIR%%/xmamerc
-%%DOCSDIR%%/xmamerc.pre88
+share/applications/wahcade.desktop
+%%PORTDOCS%%%%DOCSDIR%%/CHANGELOG
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/INI_FILES
+%%PORTDOCS%%%%DOCSDIR%%/INSTALL
+%%PORTDOCS%%%%DOCSDIR%%/KEYS
+%%PORTDOCS%%%%DOCSDIR%%/LAYOUT_EDITOR
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/SETUP_EDITOR
+%%PORTDOCS%%%%DOCSDIR%%/TODO
+%%PORTDOCS%%%%DOCSDIR%%/file_formats/fav_format.txt
+%%PORTDOCS%%%%DOCSDIR%%/file_formats/filter_format.txt
+%%PORTDOCS%%%%DOCSDIR%%/file_formats/gamelist_format.txt
+%%PORTDOCS%%%%DOCSDIR%%/file_formats/layout_format.txt
+%%PORTDOCS%%%%DOCSDIR%%/xmame/xmame-x11rc
+%%PORTDOCS%%%%DOCSDIR%%/xmame/xmame-x11rc.pre88
+%%PORTDOCS%%%%DOCSDIR%%/xmame/xmamerc
+%%PORTDOCS%%%%DOCSDIR%%/xmame/xmamerc.post105
+%%PORTDOCS%%%%DOCSDIR%%/xmame/xmamerc.pre88
%%DATADIR%%/config.dist/cpviewer.ini
+%%DATADIR%%/config.dist/ctrlr/.dir
%%DATADIR%%/config.dist/ctrlr/default.ini
+%%DATADIR%%/config.dist/files/.dir
%%DATADIR%%/config.dist/histview.ini
+%%DATADIR%%/config.dist/ini/.dir
%%DATADIR%%/config.dist/ini/genesis-0.ini
%%DATADIR%%/config.dist/ini/genesis.ini
%%DATADIR%%/config.dist/ini/mame-0.ini
@@ -26,53 +31,74 @@ bin/wahcade
%%DATADIR%%/config.dist/ini/mame.ini
%%DATADIR%%/config.dist/ini/zsnes-0.ini
%%DATADIR%%/config.dist/ini/zsnes.ini
-%%DATADIR%%/config.dist/layouts/classic 1024x768/layout.lay
-%%DATADIR%%/config.dist/layouts/classic 640x480/layout.lay
-%%DATADIR%%/config.dist/layouts/classic 800x600/layout.lay
+%%DATADIR%%/config.dist/layouts/.dir
+%%DATADIR%%/config.dist/layouts/classic_1024x768/layout.lay
+%%DATADIR%%/config.dist/layouts/classic_640x480/layout.lay
+%%DATADIR%%/config.dist/layouts/classic_800x600/layout.lay
%%DATADIR%%/config.dist/layouts/cpviewer/example.jpg
%%DATADIR%%/config.dist/layouts/cpviewer/example.lay
-%%DATADIR%%/config.dist/layouts/cpviewer/wahcade.glade
+%%DATADIR%%/config.dist/layouts/histview/example.lay
%%DATADIR%%/config.dist/wahcade.ini
%%DATADIR%%/constants.py
-%%DATADIR%%/constants.pyc
%%DATADIR%%/filters.py
-%%DATADIR%%/filters.pyc
+%%DATADIR%%/glade/layout_editor.glade
+%%DATADIR%%/glade/wahcade_setup.glade
+%%DATADIR%%/glade/win_cpviewer.png
+%%DATADIR%%/glade/win_main.png
+%%DATADIR%%/glade/win_msg.png
+%%DATADIR%%/glade/win_options.png
+%%DATADIR%%/glade/win_scrsave.png
+%%DATADIR%%/glade2.py
%%DATADIR%%/key_consts.py
-%%DATADIR%%/key_consts.pyc
+%%DATADIR%%/layout_editor.py
+%%DATADIR%%/layout_props.py
+%%DATADIR%%/layout_scr_props.py
+%%DATADIR%%/locale/en_GB/LC_MESSAGES/wahcade.mo
%%DATADIR%%/mamewah_ini.py
-%%DATADIR%%/mamewah_ini.pyc
%%DATADIR%%/mplayer.py
-%%DATADIR%%/mplayer.pyc
%%DATADIR%%/pixmaps/empty.png
+%%DATADIR%%/pixmaps/wahcade-logo.png
+%%DATADIR%%/pixmaps/wahcade.ico
%%DATADIR%%/pixmaps/wahcade.png
+%%DATADIR%%/pixmaps/win_cpviewer.png
+%%DATADIR%%/pixmaps/win_main.png
+%%DATADIR%%/pixmaps/win_msg.png
+%%DATADIR%%/pixmaps/win_options.png
+%%DATADIR%%/pixmaps/win_scrsave.png
%%DATADIR%%/scrolled_list.py
-%%DATADIR%%/scrolled_list.pyc
%%DATADIR%%/setup.py
-%%DATADIR%%/setup.pyc
-%%DATADIR%%/wahcade
+%%DATADIR%%/templates/new_emulator-0.ini
+%%DATADIR%%/templates/new_emulator-1.ini
+%%DATADIR%%/templates/new_emulator.ini
+%%DATADIR%%/wahcade-layout-editor.py
+%%DATADIR%%/wahcade-setup.py
+%%DATADIR%%/wahcade.py
%%DATADIR%%/wc_common.py
-%%DATADIR%%/wc_common.pyc
+%%DATADIR%%/wc_setup.py
%%DATADIR%%/win_cpviewer.py
-%%DATADIR%%/win_cpviewer.pyc
%%DATADIR%%/win_history.py
-%%DATADIR%%/win_history.pyc
%%DATADIR%%/win_main.py
-%%DATADIR%%/win_main.pyc
%%DATADIR%%/win_message.py
-%%DATADIR%%/win_message.pyc
%%DATADIR%%/win_options.py
-%%DATADIR%%/win_options.pyc
%%DATADIR%%/win_scrsaver.py
-%%DATADIR%%/win_scrsaver.pyc
+@dirrmtry share/applications
+@dirrm %%DATADIR%%/templates
@dirrm %%DATADIR%%/pixmaps
+@dirrm %%DATADIR%%/locale/en_GB/LC_MESSAGES
+@dirrm %%DATADIR%%/locale/en_GB
+@dirrm %%DATADIR%%/locale
+@dirrm %%DATADIR%%/glade
+@dirrm %%DATADIR%%/config.dist/layouts/histview
@dirrm %%DATADIR%%/config.dist/layouts/cpviewer
-@dirrm %%DATADIR%%/config.dist/layouts/classic 800x600
-@dirrm %%DATADIR%%/config.dist/layouts/classic 640x480
-@dirrm %%DATADIR%%/config.dist/layouts/classic 1024x768
+@dirrm %%DATADIR%%/config.dist/layouts/classic_800x600
+@dirrm %%DATADIR%%/config.dist/layouts/classic_640x480
+@dirrm %%DATADIR%%/config.dist/layouts/classic_1024x768
@dirrm %%DATADIR%%/config.dist/layouts
@dirrm %%DATADIR%%/config.dist/ini
@dirrm %%DATADIR%%/config.dist/files
@dirrm %%DATADIR%%/config.dist/ctrlr
@dirrm %%DATADIR%%/config.dist
@dirrm %%DATADIR%%
-@dirrm %%DOCSDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/xmame
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/file_formats
+%%PORTDOCS%%@dirrm %%DOCSDIR%%