aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2020-12-01 17:27:47 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2020-12-01 17:27:47 +0000
commit888b4fbe406b5202b58957844b960394be7a5ce6 (patch)
tree8625b69ef88657ff057b65e8de13d3230ed1f266 /emulators
parent90c303dd5c6f73f4fa9a34f54b5b818bec624c0f (diff)
downloadports-888b4fbe406b5202b58957844b960394be7a5ce6.tar.gz
ports-888b4fbe406b5202b58957844b960394be7a5ce6.zip
- Update to 1.26.1
- Add patch for fix joystick detection if devel/evdev-proto is installed [1] PR: 244157 [1] Submitted by: vedge at hypertriton.com
Notes
Notes: svn path=/head/; revision=556768
Diffstat (limited to 'emulators')
-rw-r--r--emulators/mednafen/Makefile3
-rw-r--r--emulators/mednafen/distinfo6
-rw-r--r--emulators/mednafen/files/patch-src-drivers_Joystick.cpp20
3 files changed, 24 insertions, 5 deletions
diff --git a/emulators/mednafen/Makefile b/emulators/mednafen/Makefile
index 94ebdb4797a3..c4416863b5ae 100644
--- a/emulators/mednafen/Makefile
+++ b/emulators/mednafen/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= mednafen
-PORTVERSION= 1.24.3
-PORTREVISION= 2
+PORTVERSION= 1.26.1
PORTEPOCH= 1
CATEGORIES= emulators games
MASTER_SITES= https://mednafen.github.io/releases/files/
diff --git a/emulators/mednafen/distinfo b/emulators/mednafen/distinfo
index d48dc832b146..1a02d1ce9f9a 100644
--- a/emulators/mednafen/distinfo
+++ b/emulators/mednafen/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1588897626
-SHA256 (mednafen-1.24.3.tar.xz) = 3dea853f784364557fa59e9ba11a17eb2674fc0fb93205f33bdbdaba1da3f70f
-SIZE (mednafen-1.24.3.tar.xz) = 3296980
+TIMESTAMP = 1606839934
+SHA256 (mednafen-1.26.1.tar.xz) = 842907c25c4292c9ba497c9cb9229c7d10e04e22cb4740d154ab690e6587fdf4
+SIZE (mednafen-1.26.1.tar.xz) = 3319756
diff --git a/emulators/mednafen/files/patch-src-drivers_Joystick.cpp b/emulators/mednafen/files/patch-src-drivers_Joystick.cpp
new file mode 100644
index 000000000000..76d158e5efa6
--- /dev/null
+++ b/emulators/mednafen/files/patch-src-drivers_Joystick.cpp
@@ -0,0 +1,20 @@
+--- src/drivers/Joystick.cpp 2020-11-10 01:04:17.000000000 -0500
++++ src/drivers/Joystick.cpp 2020-12-01 11:34:01.154240000 -0500
+@@ -32,7 +32,7 @@
+ #include "Joystick_SDL.h"
+ #endif
+
+-#ifdef HAVE_LINUX_JOYSTICK
++#if defined(HAVE_LINUX_JOYSTICK) && !defined(__FreeBSD__)
+ #include "Joystick_Linux.h"
+ #endif
+
+@@ -175,7 +175,7 @@
+
+ try
+ {
+- #ifdef HAVE_LINUX_JOYSTICK
++ #if defined(HAVE_LINUX_JOYSTICK) && !defined(__FreeBSD__)
+ main_driver = JoystickDriver_Linux_New();
+ #elif defined(WIN32)
+ {