aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-05-17 16:52:10 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-05-17 16:52:36 +0000
commit8b2e8906137bf5b0ef7e6c6008a22ad93a1d12f8 (patch)
treece07e656b61b4fa7ec41e3b679ec06b0264da52c /emulators
parent5b7dd7b8beefba76482ea5346cb85112d62e7f81 (diff)
downloadports-8b2e8906137bf5b0ef7e6c6008a22ad93a1d12f8.tar.gz
ports-8b2e8906137bf5b0ef7e6c6008a22ad93a1d12f8.zip
New port: emulators/magia: GBA emulator written in golang
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/magia/Makefile34
-rw-r--r--emulators/magia/distinfo19
-rw-r--r--emulators/magia/pkg-descr5
4 files changed, 59 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 7e3771b08e8f..0cbd4e7c5cb1 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -66,6 +66,7 @@
SUBDIR += linux-power9-functional-sim
SUBDIR += linux_base-c7
SUBDIR += lisaem
+ SUBDIR += magia
SUBDIR += mame
SUBDIR += mastergear
SUBDIR += mednafen
diff --git a/emulators/magia/Makefile b/emulators/magia/Makefile
new file mode 100644
index 000000000000..f13c9f59e988
--- /dev/null
+++ b/emulators/magia/Makefile
@@ -0,0 +1,34 @@
+PORTNAME= magia
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.2.0
+CATEGORIES= emulators
+
+MAINTAINER= nc@FreeBSD.org
+COMMENT= GBA emulator written in golang
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+
+LIB_DEPENDS= libglfw.so:graphics/glfw
+
+USES= gl go:modules openal pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= pokemium
+
+GH_TUPLE= anthonynsimon:bild:v0.13.0:anthonynsimon_bild/vendor/github.com/anthonynsimon/bild \
+ go-gl:glfw:5321531c36a2:go_gl_glfw_glfw/vendor/github.com/go-gl/glfw \
+ golang:exp:ec7cb31e5a56:golang_exp/vendor/golang.org/x/exp \
+ golang:image:e162460cd6b5:golang_image/vendor/golang.org/x/image \
+ golang:mobile:f462b3930c8f:golang_mobile/vendor/golang.org/x/mobile \
+ golang:sys:dfb3f7c4e634:golang_sys/vendor/golang.org/x/sys \
+ hajimehoshi:ebiten:v2.0.8:hajimehoshi_ebiten_v2/vendor/github.com/hajimehoshi/ebiten/v2 \
+ hajimehoshi:oto:v0.7.1:hajimehoshi_oto/vendor/github.com/hajimehoshi/oto
+
+USE_GL= glu
+
+GO_TARGET= ./cmd:${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/emulators/magia/distinfo b/emulators/magia/distinfo
new file mode 100644
index 000000000000..68c8421d13dd
--- /dev/null
+++ b/emulators/magia/distinfo
@@ -0,0 +1,19 @@
+TIMESTAMP = 1621221623
+SHA256 (pokemium-magia-v0.2.0_GH0.tar.gz) = 0a26dde821fdfff68513751cd83c73f6076c9f9e68388eede24f099c8190672f
+SIZE (pokemium-magia-v0.2.0_GH0.tar.gz) = 2303299
+SHA256 (anthonynsimon-bild-v0.13.0_GH0.tar.gz) = 0ad6a39bc4981d323968f301c23e52016699895273fd8bc7e33640a1ee18d9e0
+SIZE (anthonynsimon-bild-v0.13.0_GH0.tar.gz) = 3999622
+SHA256 (go-gl-glfw-5321531c36a2_GH0.tar.gz) = c9cd1d1d91649a7721e21819b9f3f32a5f93790d81eccbd1409782102ce46fc2
+SIZE (go-gl-glfw-5321531c36a2_GH0.tar.gz) = 1213640
+SHA256 (golang-exp-ec7cb31e5a56_GH0.tar.gz) = 2bd5bb1f2ae2c74cad1b87d4ecba26b7098f34fa700ffb9b64b37818cc027688
+SIZE (golang-exp-ec7cb31e5a56_GH0.tar.gz) = 1487133
+SHA256 (golang-image-e162460cd6b5_GH0.tar.gz) = 95fcb6953e5bcd38391879e007eb143d98f67b1659be7737bd3e502890a6d0cc
+SIZE (golang-image-e162460cd6b5_GH0.tar.gz) = 4900398
+SHA256 (golang-mobile-f462b3930c8f_GH0.tar.gz) = c1ca0ffd49ba2eecaef0d51758ca2331f0157e7d6fcd58712431729d3a60eaf3
+SIZE (golang-mobile-f462b3930c8f_GH0.tar.gz) = 1207175
+SHA256 (golang-sys-dfb3f7c4e634_GH0.tar.gz) = 75ee7af59b89e26f37f4dd30cc1bff80f89a55a0721baee3d3ec0cb23b2bbbbb
+SIZE (golang-sys-dfb3f7c4e634_GH0.tar.gz) = 1067796
+SHA256 (hajimehoshi-ebiten-v2.0.8_GH0.tar.gz) = 85304044bceecc7c9ea4c85ebc46f1548fd6ed7b258b5fcae8cfad0e8c35534a
+SIZE (hajimehoshi-ebiten-v2.0.8_GH0.tar.gz) = 17069843
+SHA256 (hajimehoshi-oto-v0.7.1_GH0.tar.gz) = 4cf95017fac961c3ed3bcf3b7810149a24d587f9d5ecdac24e5aa033f2084e05
+SIZE (hajimehoshi-oto-v0.7.1_GH0.tar.gz) = 26477
diff --git a/emulators/magia/pkg-descr b/emulators/magia/pkg-descr
new file mode 100644
index 000000000000..c47b873357a2
--- /dev/null
+++ b/emulators/magia/pkg-descr
@@ -0,0 +1,5 @@
+Magia is GBA emulator written in golang.
+
+Warning: This emulator is WIP, so many ROMs don't work correctly now.
+
+WWW: https://github.com/pokemium/magia