aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2009-04-21 11:44:03 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2009-04-21 11:44:03 +0000
commit90f23327c2ee4417baf71c842909339a0c6c883f (patch)
tree79ee83a1f49dd7388ee580738d9c8926c335699a /emulators
parent01cfcae3cb294e52c8056a55f162f1aad4390596 (diff)
downloadports-90f23327c2ee4417baf71c842909339a0c6c883f.tar.gz
ports-90f23327c2ee4417baf71c842909339a0c6c883f.zip
Update to Wine 1.1.19. Among others, this includes the following changes:
- Support for Visual C++ project files in winemaker. - Improvements to the Esound driver. - Many Direct3D code cleanups. - Fixes to OLE clipboard handling. - Various bug fixes. Also set MAKE_JOBS_SAFE to allow for parallel builds.
Notes
Notes: svn path=/head/; revision=232419
Diffstat (limited to 'emulators')
-rw-r--r--emulators/wine-devel/Makefile3
-rw-r--r--emulators/wine-devel/distinfo6
-rw-r--r--emulators/wine-devel/pkg-plist6
-rw-r--r--emulators/wine/Makefile3
-rw-r--r--emulators/wine/distinfo6
-rw-r--r--emulators/wine/pkg-plist6
6 files changed, 20 insertions, 10 deletions
diff --git a/emulators/wine-devel/Makefile b/emulators/wine-devel/Makefile
index 01e204c6c891..39daa9420808 100644
--- a/emulators/wine-devel/Makefile
+++ b/emulators/wine-devel/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-DISTVERSION= 1.1.18
+DISTVERSION= 1.1.19
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SFE \
@@ -30,6 +30,7 @@ CONFIGURE_ARGS= --datadir=${DATADIR} --verbose --disable-tests \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/wine
+MAKE_JOBS_SAFE= yes
MAN1= widl.1 wine.1 winebuild.1 winedbg.1 winedump.1 winegcc.1 \
winemaker.1 wineprefixcreate.1 wineserver.1 wmc.1 wrc.1
MLINKS= winegcc.1 wineg++.1
diff --git a/emulators/wine-devel/distinfo b/emulators/wine-devel/distinfo
index 6370c0593d4e..1201b5e843b3 100644
--- a/emulators/wine-devel/distinfo
+++ b/emulators/wine-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (wine-1.1.18.tar.bz2) = 86f72ab472b4f5d30961149831d0a0e1
-SHA256 (wine-1.1.18.tar.bz2) = 87e0afbce038d6cfd95d21fe824e97e7e88f5af6007a9d1bbad424160dfffc49
-SIZE (wine-1.1.18.tar.bz2) = 15184906
+MD5 (wine-1.1.19.tar.bz2) = 95957027df57eca2a6f4686204dfb33a
+SHA256 (wine-1.1.19.tar.bz2) = 795863589c8603c8570c3352f75c1f33dd5b0bfbd4f8e926dbdab33839771252
+SIZE (wine-1.1.19.tar.bz2) = 15222941
diff --git a/emulators/wine-devel/pkg-plist b/emulators/wine-devel/pkg-plist
index bed342ec72a0..bc9512dfa2c8 100644
--- a/emulators/wine-devel/pkg-plist
+++ b/emulators/wine-devel/pkg-plist
@@ -532,6 +532,8 @@ include/wine/windows/winver.h
include/wine/windows/wmistr.h
include/wine/windows/wnaspi32.h
include/wine/windows/wownt32.h
+include/wine/windows/ws2def.h
+include/wine/windows/ws2ipdef.h
include/wine/windows/ws2spi.h
include/wine/windows/ws2tcpip.h
include/wine/windows/wshisotp.h
@@ -581,6 +583,7 @@ lib/wine/authz.dll.so
lib/wine/avicap32.dll.so
lib/wine/avifil32.dll.so
lib/wine/avifile.dll16.so
+lib/wine/bcrypt.dll.so
lib/wine/browseui.dll.so
lib/wine/cabinet.dll.so
lib/wine/cacls.exe.so
@@ -633,6 +636,7 @@ lib/wine/d3dx9_37.dll.so
lib/wine/d3dx9_38.dll.so
lib/wine/d3dx9_39.dll.so
lib/wine/d3dx9_40.dll.so
+lib/wine/d3dx9_41.dll.so
lib/wine/d3dxof.dll.so
lib/wine/dbghelp.dll.so
lib/wine/dciman32.dll.so
@@ -983,7 +987,7 @@ lib/wine/sfc.dll.so
lib/wine/sfc_os.dll.so
lib/wine/shdoclc.dll.so
lib/wine/shdocvw.dll.so
-lib/wine/shell.dll16
+lib/wine/shell.dll16.so
lib/wine/shell32.dll.so
lib/wine/shfolder.dll.so
lib/wine/shlwapi.dll.so
diff --git a/emulators/wine/Makefile b/emulators/wine/Makefile
index 01e204c6c891..39daa9420808 100644
--- a/emulators/wine/Makefile
+++ b/emulators/wine/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= wine
-DISTVERSION= 1.1.18
+DISTVERSION= 1.1.19
PORTEPOCH= 1
CATEGORIES= emulators
MASTER_SITES= SFE \
@@ -30,6 +30,7 @@ CONFIGURE_ARGS= --datadir=${DATADIR} --verbose --disable-tests \
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
USE_LDCONFIG= ${PREFIX}/lib ${PREFIX}/lib/wine
+MAKE_JOBS_SAFE= yes
MAN1= widl.1 wine.1 winebuild.1 winedbg.1 winedump.1 winegcc.1 \
winemaker.1 wineprefixcreate.1 wineserver.1 wmc.1 wrc.1
MLINKS= winegcc.1 wineg++.1
diff --git a/emulators/wine/distinfo b/emulators/wine/distinfo
index 6370c0593d4e..1201b5e843b3 100644
--- a/emulators/wine/distinfo
+++ b/emulators/wine/distinfo
@@ -1,3 +1,3 @@
-MD5 (wine-1.1.18.tar.bz2) = 86f72ab472b4f5d30961149831d0a0e1
-SHA256 (wine-1.1.18.tar.bz2) = 87e0afbce038d6cfd95d21fe824e97e7e88f5af6007a9d1bbad424160dfffc49
-SIZE (wine-1.1.18.tar.bz2) = 15184906
+MD5 (wine-1.1.19.tar.bz2) = 95957027df57eca2a6f4686204dfb33a
+SHA256 (wine-1.1.19.tar.bz2) = 795863589c8603c8570c3352f75c1f33dd5b0bfbd4f8e926dbdab33839771252
+SIZE (wine-1.1.19.tar.bz2) = 15222941
diff --git a/emulators/wine/pkg-plist b/emulators/wine/pkg-plist
index bed342ec72a0..bc9512dfa2c8 100644
--- a/emulators/wine/pkg-plist
+++ b/emulators/wine/pkg-plist
@@ -532,6 +532,8 @@ include/wine/windows/winver.h
include/wine/windows/wmistr.h
include/wine/windows/wnaspi32.h
include/wine/windows/wownt32.h
+include/wine/windows/ws2def.h
+include/wine/windows/ws2ipdef.h
include/wine/windows/ws2spi.h
include/wine/windows/ws2tcpip.h
include/wine/windows/wshisotp.h
@@ -581,6 +583,7 @@ lib/wine/authz.dll.so
lib/wine/avicap32.dll.so
lib/wine/avifil32.dll.so
lib/wine/avifile.dll16.so
+lib/wine/bcrypt.dll.so
lib/wine/browseui.dll.so
lib/wine/cabinet.dll.so
lib/wine/cacls.exe.so
@@ -633,6 +636,7 @@ lib/wine/d3dx9_37.dll.so
lib/wine/d3dx9_38.dll.so
lib/wine/d3dx9_39.dll.so
lib/wine/d3dx9_40.dll.so
+lib/wine/d3dx9_41.dll.so
lib/wine/d3dxof.dll.so
lib/wine/dbghelp.dll.so
lib/wine/dciman32.dll.so
@@ -983,7 +987,7 @@ lib/wine/sfc.dll.so
lib/wine/sfc_os.dll.so
lib/wine/shdoclc.dll.so
lib/wine/shdocvw.dll.so
-lib/wine/shell.dll16
+lib/wine/shell.dll16.so
lib/wine/shell32.dll.so
lib/wine/shfolder.dll.so
lib/wine/shlwapi.dll.so