aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-05-01 23:27:09 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-05-01 23:27:09 +0000
commit93e25a991f745a57e5dcdac28db0a749430484cf (patch)
tree9fc90268c82e17ce26d64e72410af385a194fbaf /emulators
parenta85f9de4a03709204d57dd774303c3804739c87b (diff)
downloadports-93e25a991f745a57e5dcdac28db0a749430484cf.tar.gz
ports-93e25a991f745a57e5dcdac28db0a749430484cf.zip
A multiplayer Atari 2600 emulator written in pure Java.
No external libs. WWW: http://javatari.org PR: ports/178248 Submitted by: Danilo Egea Gondolfo <danilogondolfo@gmail.com>
Notes
Notes: svn path=/head/; revision=317067
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/javatari/Makefile38
-rw-r--r--emulators/javatari/distinfo2
-rw-r--r--emulators/javatari/files/javatari.in8
-rw-r--r--emulators/javatari/pkg-descr4
5 files changed, 53 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index 970d3dcb9ef3..b5dd42c3df9c 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -62,6 +62,7 @@
SUBDIR += ia64sim
SUBDIR += ines
SUBDIR += its
+ SUBDIR += javatari
SUBDIR += joytran
SUBDIR += jzintv
SUBDIR += kcemu
diff --git a/emulators/javatari/Makefile b/emulators/javatari/Makefile
new file mode 100644
index 000000000000..c2a5d8c7d34d
--- /dev/null
+++ b/emulators/javatari/Makefile
@@ -0,0 +1,38 @@
+# $FreeBSD$
+
+PORTNAME= javatari
+PORTVERSION= 3.20
+CATEGORIES= emulators java
+MASTER_SITES= http://javatari.org/files/
+DISTNAME= ${PORTNAME}320
+EXTRACT_SUFX= .jar
+EXTRACT_ONLY=
+
+MAINTAINER= danilogondolfo@gmail.com
+COMMENT= Multiplayer Atari 2600 emulator written in pure Java
+
+EXTRACT_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
+USE_JAVA= yes
+JAVA_VERSION= 1.6+
+NO_BUILD= yes
+PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}320.jar \
+ bin/javatari
+SUB_FILES= javatari
+SUB_LIST+= JARFILE="${JARFILE}"
+JARFILE= ${PORTNAME}320.jar
+
+DESKTOP_ENTRIES= "Javatari" "${COMMENT}" "${PORTNAME}" "${PORTNAME}" "Application;Game;" ${FALSE}
+PLIST_FILES+= share/pixmaps/${PORTNAME}.png
+
+post-extract:
+ @(cd ${DISTDIR}/${DIST_SUBDIR} && ${UNZIP_CMD} -d ${WRKDIR} ${JARFILE} \
+ org/javatari/pc/screen/images/LogoIcon32.png)
+
+do-install:
+ ${INSTALL_DATA} ${DISTDIR}/${JARFILE} ${JAVAJARDIR}
+ ${INSTALL_SCRIPT} ${WRKDIR}/javatari ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKDIR}/org/javatari/pc/screen/images/LogoIcon32.png \
+ ${PREFIX}/share/pixmaps/${PORTNAME}.png
+
+.include <bsd.port.mk>
diff --git a/emulators/javatari/distinfo b/emulators/javatari/distinfo
new file mode 100644
index 000000000000..4a03a885f8b2
--- /dev/null
+++ b/emulators/javatari/distinfo
@@ -0,0 +1,2 @@
+SHA256 (javatari320.jar) = 5588ea7e7c5752ea81fbddcdd952d33b8d345d1715858b0c52046d99e705dc81
+SIZE (javatari320.jar) = 947296
diff --git a/emulators/javatari/files/javatari.in b/emulators/javatari/files/javatari.in
new file mode 100644
index 000000000000..556c8a1fa02b
--- /dev/null
+++ b/emulators/javatari/files/javatari.in
@@ -0,0 +1,8 @@
+#!/bin/csh
+# $FreeBSD$
+
+set JAVA = "%%LOCALBASE%%/bin/java"
+set JARPATH = "%%JAVALIBDIR%%"
+setenv JAVA_VERSION "%%JAVA_VERSION%%"
+
+exec "${JAVA}" -jar %%JAVAJARDIR%%/%%JARFILE%%
diff --git a/emulators/javatari/pkg-descr b/emulators/javatari/pkg-descr
new file mode 100644
index 000000000000..ee5a07a17eb3
--- /dev/null
+++ b/emulators/javatari/pkg-descr
@@ -0,0 +1,4 @@
+A multiplayer Atari 2600 emulator written in pure Java.
+No external libs.
+
+WWW: http://javatari.org