aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-06-28 17:39:53 +0000
commitb1a1d38bf9ef78334b640d30046388a9c055c3a9 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /emulators
parentbc77780d41178cf3d0327c79ac10737af704f236 (diff)
downloadports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.tar.gz
ports-b1a1d38bf9ef78334b640d30046388a9c055c3a9.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Notes
Notes: svn path=/head/; revision=473503
Diffstat (limited to 'emulators')
-rw-r--r--emulators/aqemu/Makefile4
-rw-r--r--emulators/citra/Makefile4
-rw-r--r--emulators/dboxfe/Makefile4
-rw-r--r--emulators/higan/Makefile3
-rw-r--r--emulators/mame/Makefile4
-rw-r--r--emulators/mgba/Makefile4
-rw-r--r--emulators/mupen64plus-qt/Makefile4
-rw-r--r--emulators/ppsspp/Makefile3
-rw-r--r--emulators/q4wine/Makefile7
-rw-r--r--emulators/qmc2/Makefile4
-rw-r--r--emulators/qtemu/Makefile7
-rw-r--r--emulators/rpcs3/Makefile4
-rw-r--r--emulators/swine/Makefile4
-rw-r--r--emulators/virtualbox-ose/Makefile6
-rw-r--r--emulators/yabause/Makefile10
15 files changed, 39 insertions, 33 deletions
diff --git a/emulators/aqemu/Makefile b/emulators/aqemu/Makefile
index 7985311e9d33..d5a1a2707ff3 100644
--- a/emulators/aqemu/Makefile
+++ b/emulators/aqemu/Makefile
@@ -13,8 +13,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libvncclient.so:net/libvncserver
-USES= cmake:noninja
-USE_QT5= buildtools_build linguisttools_build qmake_build \
+USES= cmake:noninja qt:5
+USE_QT= buildtools_build linguisttools_build qmake_build \
core dbus gui network printsupport testlib widgets
USE_GITHUB= yes
diff --git a/emulators/citra/Makefile b/emulators/citra/Makefile
index e7ed18205e65..d41827b6fa6d 100644
--- a/emulators/citra/Makefile
+++ b/emulators/citra/Makefile
@@ -71,8 +71,8 @@ SDL_PLIST_FILES=bin/${PORTNAME} \
bin/${PORTNAME}-room \
man/man6/${PORTNAME}.6.gz
-QT5_USES= desktop-file-utils shared-mime-info
-QT5_USE= QT5=qmake_build,buildtools_build,concurrent_build,core,gui,multimedia,opengl,widgets
+QT5_USES= desktop-file-utils qt:5 shared-mime-info
+QT5_USE= QT=qmake_build,buildtools_build,concurrent_build,core,gui,multimedia,opengl,widgets
QT5_CMAKE_BOOL= ENABLE_QT
QT5_PLIST_FILES=bin/${PORTNAME}-qt \
"@comment bin/${PORTNAME}-room" \
diff --git a/emulators/dboxfe/Makefile b/emulators/dboxfe/Makefile
index 0dfbb0aac04e..5e910bee10a7 100644
--- a/emulators/dboxfe/Makefile
+++ b/emulators/dboxfe/Makefile
@@ -14,8 +14,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.GPL
RUN_DEPENDS= dosbox:emulators/dosbox
-USE_QT4= corelib gui network xml uic_build moc_build qmake_build rcc_build
-USES= qmake tar:bzip2
+USE_QT= corelib gui network xml uic_build moc_build qmake_build rcc_build
+USES= qmake qt:4 tar:bzip2
PLIST_FILES= bin/dboxfe \
bin/dboxfetray \
diff --git a/emulators/higan/Makefile b/emulators/higan/Makefile
index f691ed7123c4..9c6a3ca25eb1 100644
--- a/emulators/higan/Makefile
+++ b/emulators/higan/Makefile
@@ -45,7 +45,8 @@ GTK2_USE= GNOME=cairo,gdkpixbuf2,gtk20,gtksourceview2
GTK2_USES= gettext
QT4_MAKE_ENV= hiro="qt"
-QT4_USE= QT4=corelib,gui,moc_build
+QT4_USES= qt:4
+QT4_USE= QT=corelib,gui,moc_build
GLX_USE= GL=gl
GLX_VARS= VIDEO_DRIVER+=video.glx
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index f41f1c6bee2f..7ba2c4037921 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
libfreetype.so:print/freetype2
RUN_DEPENDS= liberation-fonts-ttf>=0:x11-fonts/liberation-fonts-ttf
-USES= compiler:c++14-lang gmake jpeg pkgconfig python:2.7,build shebangfix
+USES= compiler:c++14-lang gmake jpeg pkgconfig python:2.7,build qt:5 shebangfix
USE_GITHUB= yes
GH_ACCOUNT= mamedev
@@ -35,7 +35,7 @@ SHEBANG_FILES= src/devices/cpu/m6502/m6502make.py \
USE_XORG= x11 xext xi xinerama xrender
USE_GL= gl
USE_SDL= sdl2 ttf2
-USE_QT5= buildtools core gui qmake_build widgets
+USE_QT= buildtools core gui qmake_build widgets
MTARGET?= mame
MSUBTARGET?= mame
CFLAGS+= -I${LOCALBASE}/include
diff --git a/emulators/mgba/Makefile b/emulators/mgba/Makefile
index bebc68916ee3..57132c865201 100644
--- a/emulators/mgba/Makefile
+++ b/emulators/mgba/Makefile
@@ -62,8 +62,8 @@ MAGICK_LIB_DEPENDS= libMagickWand-6.so:graphics/ImageMagick \
libMagickCore-6.so:graphics/ImageMagick
QT5_CMAKE_BOOL= BUILD_QT
-QT5_USE= qt5=qmake_build,buildtools_build,core,gui,widgets,network,opengl,multimedia
-QT5_USES= desktop-file-utils
+QT5_USE= qt=qmake_build,buildtools_build,core,gui,widgets,network,opengl,multimedia
+QT5_USES= desktop-file-utils qt:5
QT5_VARS= installs_icons=yes
.include <bsd.port.mk>
diff --git a/emulators/mupen64plus-qt/Makefile b/emulators/mupen64plus-qt/Makefile
index a2d864ef434d..777c8d6c788b 100644
--- a/emulators/mupen64plus-qt/Makefile
+++ b/emulators/mupen64plus-qt/Makefile
@@ -17,9 +17,9 @@ RUN_DEPENDS= ${LOCALBASE}/lib/libmupen64plus.so.2:emulators/mupen64plus-core \
${LOCALBASE}/lib/mupen64plus/mupen64plus-video-rice.so:emulators/mupen64plus-video-rice \
mupen64plus:emulators/mupen64plus-ui-console
-USES= qmake
+USES= qmake qt:5
USE_GL= gl
-USE_QT5= core gui network sql widgets xml \
+USE_QT= core gui network sql widgets xml \
buildtools_build \
sql-sqlite3_run
diff --git a/emulators/ppsspp/Makefile b/emulators/ppsspp/Makefile
index c2fa217d9ed4..97c44ed9fd05 100644
--- a/emulators/ppsspp/Makefile
+++ b/emulators/ppsspp/Makefile
@@ -64,7 +64,8 @@ LIBRETRO_PLIST_FILES= lib/libretro/${PORTNAME}_libretro.so
LIBRETRO_IMPLIES= SDL
OLDJOY_DESC= Old joystick support with fixed button mappings (deprecated)
OLDJOY_EXTRA_PATCHES= ${PATCHDIR}/extra-patch-old-joy
-QT5_USE= QT5=qmake_build,buildtools_build,linguisttools_build,gui,opengl,widgets
+QT5_USES= qt:5
+QT5_USE= QT=qmake_build,buildtools_build,linguisttools_build,gui,opengl,widgets
QT5_CMAKE_BOOL= USING_QT_UI
QT5_VARS= EXENAME=PPSSPPQt
SDL_BUILD_DEPENDS= png>=1.6:graphics/png
diff --git a/emulators/q4wine/Makefile b/emulators/q4wine/Makefile
index 784ad635a25a..55f480e833a9 100644
--- a/emulators/q4wine/Makefile
+++ b/emulators/q4wine/Makefile
@@ -19,11 +19,11 @@ RUN_DEPENDS= sudo:security/sudo \
cabextract:archivers/cabextract \
icotool:graphics/icoutils
-USES= cmake desktop-file-utils
+USES= cmake desktop-file-utils qt:4
CMAKE_ARGS+= -DMANPAGE_ENTRY_PATH=${MANPREFIX}/man
USE_LDCONFIG= yes
INSTALLS_ICONS= yes
-USE_QT4= qmake_build rcc_build moc_build uic_build \
+USE_QT= qmake_build rcc_build moc_build uic_build \
linguisttools_build corelib gui sql sql-sqlite3_run network
ONLY_FOR_ARCHS= i386 amd64
@@ -36,7 +36,8 @@ OPTIONS_SUB= yes
DBUS_CMAKE_ON= -DWITH_DBUS:BOOL=ON
DBUS_CMAKE_OFF= -DWITH_DBUS:BOOL=OFF
-DBUS_USE= QT4=dbus
+DBUS_USES= qt:4
+DBUS_USE= QT=dbus
.include <bsd.port.options.mk>
diff --git a/emulators/qmc2/Makefile b/emulators/qmc2/Makefile
index d75502f73473..2e7c1c733aff 100644
--- a/emulators/qmc2/Makefile
+++ b/emulators/qmc2/Makefile
@@ -16,10 +16,10 @@ OPTIONS_DEFINE= DOCS
NO_WRKSUBDIR= yes
-USES= gmake tar:bzip2
+USES= gmake qt:5 tar:bzip2
USE_XORG= x11 xmu
USE_GL= gl glu
-USE_QT5= buildtools_build core gui multimedia \
+USE_QT= buildtools_build core gui multimedia \
network opengl quick qmake_build qml \
testlib script scripttools sql svg \
webkit widgets xml xmlpatterns
diff --git a/emulators/qtemu/Makefile b/emulators/qtemu/Makefile
index 066f5a545619..6ebddf983e49 100644
--- a/emulators/qtemu/Makefile
+++ b/emulators/qtemu/Makefile
@@ -12,8 +12,8 @@ COMMENT= Qt 4 based frontend for QEMU
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= qmake tar:bzip2
-USE_QT4= gui xml uic_build moc_build rcc_build
+USES= qmake qt:4 tar:bzip2
+USE_QT= gui xml uic_build moc_build rcc_build
CONFIGURE_ENV= LOCALBASE=${LOCALBASE}
DESKTOP_ENTRIES="QtEmu" "QEMU frontend" "" \
@@ -22,7 +22,8 @@ DESKTOP_ENTRIES="QtEmu" "QEMU frontend" "" \
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
-NLS_USE= QT4=linguisttools_build
+NLS_USES= qt:4
+NLS_USE= QT=linguisttools_build
post-configure-NLS-on:
(cd ${WRKSRC} && ${LRELEASE} qtemu.pro)
diff --git a/emulators/rpcs3/Makefile b/emulators/rpcs3/Makefile
index 17cd12e9d198..63acd0820b31 100644
--- a/emulators/rpcs3/Makefile
+++ b/emulators/rpcs3/Makefile
@@ -36,9 +36,9 @@ GH_TUPLE= RPCS3:hidapi:hidapi-0.8.0-rc1-25-gca39ce8:hidapi/3rdparty/hidapi \
zeux:pugixml:v1.9:pugixml/3rdparty/pugixml
USES= cmake:outsource compiler:c++14-lang iconv:wchar_t localbase:ldflags \
- openal:soft pkgconfig
+ openal:soft pkgconfig qt:5
USE_GL= gl glew
-USE_QT5= qmake_build buildtools_build core dbus gui network widgets qml
+USE_QT= qmake_build buildtools_build core dbus gui network widgets qml
USE_XORG= x11
CMAKE_ON= CMAKE_SKIP_RPATH USE_SYSTEM_FFMPEG USE_SYSTEM_LIBPNG
CMAKE_OFF= USE_NATIVE_INSTRUCTIONS
diff --git a/emulators/swine/Makefile b/emulators/swine/Makefile
index 0c3a593df414..0437d56949ef 100644
--- a/emulators/swine/Makefile
+++ b/emulators/swine/Makefile
@@ -22,11 +22,11 @@ USE_GITHUB= yes
GH_ACCOUNT= dswd
GH_PROJECT= Swine
-USES= gmake python:2.7 shebangfix pyqt:4
+USES= gmake python:2.7 qt:4 shebangfix pyqt:4
SHEBANG_FILES= *.py
NO_BUILD= yes
USE_PYQT= gui_run xml_build
-USE_QT4= linguist_build
+USE_QT= linguist_build
ONLY_FOR_ARCHS= i386 amd64
NO_ARCH= yes
diff --git a/emulators/virtualbox-ose/Makefile b/emulators/virtualbox-ose/Makefile
index 6e33861118a4..4e6720863b30 100644
--- a/emulators/virtualbox-ose/Makefile
+++ b/emulators/virtualbox-ose/Makefile
@@ -156,10 +156,10 @@ USES+= python:build
.if ${PORT_OPTIONS:MQT5}
CONFIGURE_ARGS+= --enable-qt5
PLIST_SUB+= QT=""
-QT_NONSTANDARD= yes
USE_GL= gl
-USE_QT5= buildtools_build core dbus gui linguisttools_build opengl
-USE_QT5+= printsupport widgets x11extras
+USES+= qmake:no_env qt:5
+USE_QT= buildtools_build core dbus gui linguisttools_build opengl
+USE_QT+= printsupport widgets x11extras
USE_XORG= xcb
INSTALLS_ICONS= yes
VBOX_PROGS+= VirtualBox
diff --git a/emulators/yabause/Makefile b/emulators/yabause/Makefile
index 3f29f92d7cfe..be7c285eda90 100644
--- a/emulators/yabause/Makefile
+++ b/emulators/yabause/Makefile
@@ -31,11 +31,13 @@ GTK2_LIB_DEPENDS= libgtkglext-x11-1.0.so:x11-toolkits/gtkglext
GTK2_USE= gnome=gtk20
GTK2_CMAKE_ON= -DYAB_PORTS:STRING=gtk
GTK2_CMAKE_OFF= -DYAB_PORTS:STRING=qt
-QT4_USE= qt4=corelib,gui,opengl \
- qt4=moc_build,qmake_build,rcc_build,uic_build
+QT4_USES= qt:4
+QT4_USE= qt=corelib,gui,opengl \
+ qt=moc_build,qmake_build,rcc_build,uic_build
QT4_CMAKE_ON= -DQt5_FOUND:BOOL=OFF
-QT5_USE= qt5=core,gui,opengl \
- qt5=buildtools_build,qmake_build
+QT5_USES= qt:5
+QT5_USE= qt=core,gui,opengl \
+ qt=buildtools_build,qmake_build
SDL2_DESC= SDL2 libraries support
SDL2_USE= sdl=sdl2
SDL2_USE_OFF= sdl=sdl