aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-05-20 01:02:14 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-05-20 01:18:12 +0000
commite68388943479a40b76501705b136467b74b64cec (patch)
tree98e7a3e82ac1ceedc363249fefe7ae53c0bd9327 /emulators
parentb093791110ccef997776f2ba3eccfc0de4234036 (diff)
downloadports-e68388943479a40b76501705b136467b74b64cec.tar.gz
ports-e68388943479a40b76501705b136467b74b64cec.zip
emulators/yuzu: limit sdl < 2.0.15 workaround to PS5 rumble
- devel/sdl20 currently disables HIDAPI by default - rumble hint is only necessary for bluetooth
Diffstat (limited to 'emulators')
-rw-r--r--emulators/yuzu/files/patch-sdl25
1 files changed, 2 insertions, 3 deletions
diff --git a/emulators/yuzu/files/patch-sdl2 b/emulators/yuzu/files/patch-sdl2
index 352e22153016..a540dc413999 100644
--- a/emulators/yuzu/files/patch-sdl2
+++ b/emulators/yuzu/files/patch-sdl2
@@ -22,12 +22,11 @@ CMake Error at externals/CMakeLists.txt:54 (add_subdirectory):
if (SDL2_FOUND)
--- src/input_common/sdl/sdl_impl.cpp.orig 2021-05-19 22:47:48 UTC
+++ src/input_common/sdl/sdl_impl.cpp
-@@ -796,8 +796,10 @@ SDLState::SDLState() {
- RegisterFactory<MotionDevice>("sdl", motion_factory);
+@@ -797,7 +797,9 @@ SDLState::SDLState() {
// Enable HIDAPI rumble. This prevents SDL from disabling motion on PS4 and PS5 controllers
-+#ifdef SDL_HINT_JOYSTICK_HIDAPI_PS5_RUMBLE
SDL_SetHint(SDL_HINT_JOYSTICK_HIDAPI_PS4_RUMBLE, "1");
++#ifdef SDL_HINT_JOYSTICK_HIDAPI_PS5_RUMBLE
SDL_SetHint(SDL_HINT_JOYSTICK_HIDAPI_PS5_RUMBLE, "1");
+#endif