aboutsummaryrefslogtreecommitdiff
path: root/emulators
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2008-05-20 18:45:53 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2008-05-20 18:45:53 +0000
commitffef66e77669b6d46f2d6bf1d214d488ee63b237 (patch)
tree5d6fdf86baa551a34e1c776de0397a9a2b786a0c /emulators
parentaca4ae777d85e29e3bd2fbc2a4a99048c9bc68e4 (diff)
downloadports-ffef66e77669b6d46f2d6bf1d214d488ee63b237.tar.gz
ports-ffef66e77669b6d46f2d6bf1d214d488ee63b237.zip
- New port: emulators/mupen64plus-glide
Graphic plugin for Mupen64Plus emulator
Notes
Notes: svn path=/head/; revision=213406
Diffstat (limited to 'emulators')
-rw-r--r--emulators/Makefile1
-rw-r--r--emulators/mupen64plus-glide/Makefile23
-rw-r--r--emulators/mupen64plus-glide/files/patch-glide64_Makefile57
3 files changed, 81 insertions, 0 deletions
diff --git a/emulators/Makefile b/emulators/Makefile
index e26a3e0f01dd..0b43c9068f45 100644
--- a/emulators/Makefile
+++ b/emulators/Makefile
@@ -109,6 +109,7 @@
SUBDIR += mupen64-tr64
SUBDIR += mupen64plus-base
SUBDIR += mupen64plus-dummyaudio
+ SUBDIR += mupen64plus-glide
SUBDIR += nonpareil
SUBDIR += o2em
SUBDIR += ods2reader
diff --git a/emulators/mupen64plus-glide/Makefile b/emulators/mupen64plus-glide/Makefile
new file mode 100644
index 000000000000..307734ffe570
--- /dev/null
+++ b/emulators/mupen64plus-glide/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: mupen64plus-glide
+# Date created: 2008-05-16
+# Whom: Jose Alonso Cardenas Marquez <acm@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PKGNAMESUFFIX= -glide
+
+COMMENT= Glide64 graphics plugin for Mupen64plus
+
+USE_SDL= sdl
+USE_GL= yes
+
+FIXFILES= #
+
+PLUGIN_NAME= glide64
+
+MASTERDIR= ${.CURDIR}/../mupen64plus-base
+
+OPTIONS= YASM "Use yasm assembler instead of nasm" on
+
+.include "${MASTERDIR}/Makefile"
diff --git a/emulators/mupen64plus-glide/files/patch-glide64_Makefile b/emulators/mupen64plus-glide/files/patch-glide64_Makefile
new file mode 100644
index 000000000000..e73d1e8526c7
--- /dev/null
+++ b/emulators/mupen64plus-glide/files/patch-glide64_Makefile
@@ -0,0 +1,57 @@
+--- glide64/Makefile 2008-03-29 14:41:03.000000000 -0500
++++ glide64/Makefile 2008-05-20 11:01:10.000000000 -0500
+@@ -4,7 +4,7 @@
+ include ../pre.mk
+
+ # set BITS
+-ifeq ("$(ARCH)","64BITS")
++ifeq ("$(ARCH_DETECTED)","64BITS")
+ BITS=64
+ MOPT=-m amd64
+ else
+@@ -13,15 +13,16 @@
+ endif
+
+ # local CFLAGS, LIBS, and LDFLAGS
+-CFLAGS = -O2 -Wall -g -DGCC -DUSE_GTK $(SDL_CFLAGS) $(GTK_FLAGS) -Iwrapper/ -ffast-math -funroll-loops
+-LDFLAGS = -shared -Wl,-Bsymbolic -lGL -lGLU -L/usr/X11R6/lib $(SDL_LIBS)
++CFLAGS += -DGCC -DUSE_GTK $(SDL_CFLAGS) $(GTK_FLAGS) -Iwrapper/ -ffast-math -funroll-loops
++LDFLAGS += -shared -Wl,-Bsymbolic -lGL -lGLU -L${LOCALBASE}/lib $(SDL_LIBS)
++LD = $(CXX)
+
+ # set special flags per-system
+ ifeq ($(CPU), X86)
+- ifeq ($(ARCH), 64BITS)
+- CFLAGS += -march=athlon64 -fPIC
++ ifeq ($(ARCH_DETECTED), 64BITS)
++ CFLAGS += -fPIC
+ else
+- CFLAGS += -march=i686 -mtune=pentium-m -mmmx -msse
++ CFLAGS +=
+ ifneq ($(PROFILE), 1)
+ ifneq ($(VPDEBUG), 1)
+ CFLAGS += -fomit-frame-pointer
+@@ -29,9 +30,9 @@
+ endif
+ endif
+ # tweak flags for 32-bit build on 64-bit system
+- ifeq ($(ARCH), 64BITS_32)
+- CFLAGS += -m32
+- LDFLAGS += -m32 -m elf_i386
++ ifeq ($(ARCH_DETECTED), 64BITS_32)
++ CFLAGS +=
++ LDFLAGS +=
+ endif
+ endif
+ ifeq ($(CPU), PPC)
+@@ -129,9 +130,7 @@
+ cursor.h: compiletex
+ ./compiletex cursor.tex cursor.h cursor
+
+-compiletex: compiletex.c
+- @rm -f compiletex compiletex.o
+- $(CC) -o compiletex.o -c $<
++compiletex: compiletex.o
+ $(LD) -o $@ compiletex.o
+
+ Tmem_nasm.o: Tmem_nasm.asm