aboutsummaryrefslogtreecommitdiff
path: root/finance/electrum
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2022-04-08 09:40:35 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2022-04-08 09:48:30 +0000
commitafff45326f3e40d7f44d28d6449a752f87c0e398 (patch)
tree5424d5e238b7174dba42d32d30e11a47a64507fc /finance/electrum
parentdf056fd2e3ef215b4c4d0a93e62d18f6f3b3cba0 (diff)
downloadports-afff45326f3e40d7f44d28d6449a752f87c0e398.tar.gz
ports-afff45326f3e40d7f44d28d6449a752f87c0e398.zip
finance/electrum: Support BitBox02 hardware wallet
Support BitBox02 hardware wallet from Shift Crypto, https://shiftcrypto.ch/. Add devd rule for device to sample configuration. Sponsored by: Shift Crypto
Diffstat (limited to 'finance/electrum')
-rw-r--r--finance/electrum/Makefile7
-rw-r--r--finance/electrum/files/hardware_wallet.conf.sample10
2 files changed, 13 insertions, 4 deletions
diff --git a/finance/electrum/Makefile b/finance/electrum/Makefile
index 82cb404b8d63..ce7be2ad0a6d 100644
--- a/finance/electrum/Makefile
+++ b/finance/electrum/Makefile
@@ -2,6 +2,7 @@
PORTNAME= electrum
PORTVERSION= 4.2.1
+PORTREVISION= 1
CATEGORIES= finance python
MASTER_SITES= https://download.electrum.org/${PORTVERSION}/ \
http://download.electrum.org/${PORTVERSION}/
@@ -50,10 +51,8 @@ HARDWARE_DESC= Enable Bitcoin hardware wallet support
GUI_USES= desktop-file-utils pyqt:5
GUI_USE= PYQT=pyqt5,sip
-# Consider portinting, hw wallets:
-# safet>=0.1.5
-# bitbox02>=6.0.0
-HARDWARE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}btchip-python>=0.1.32:security/py-btchip-python@${PY_FLAVOR} \
+HARDWARE_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bitbox02>=0.13.0:security/py-bitbox02@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}btchip-python>=0.1.32:security/py-btchip-python@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ckcc-protocol>=0.7.7:security/py-ckcc-protocol@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}hidapi>=0:comms/py-hidapi@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}keepkey>=6.3.1:security/py-keepkey@${PY_FLAVOR} \
diff --git a/finance/electrum/files/hardware_wallet.conf.sample b/finance/electrum/files/hardware_wallet.conf.sample
index ebb002e855af..ac8b7e77bf86 100644
--- a/finance/electrum/files/hardware_wallet.conf.sample
+++ b/finance/electrum/files/hardware_wallet.conf.sample
@@ -19,3 +19,13 @@
# match "type" "ATTACH";
# action "/bin/chmod g=rw /dev/$cdev";
#};
+
+## shiftcrypto.ch BitBox02
+#notify 301 {
+# match "system" "USB";
+# match "subsystem" "DEVICE";
+# match "vendor" "0x03eb";
+# match "product" "0x2403";
+# match "type" "ATTACH";
+# action "/bin/chmod g=rw /dev/$cdev";
+#};