aboutsummaryrefslogtreecommitdiff
path: root/finance/electrum
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-04-27 21:04:12 +0000
committerJohn Marino <marino@FreeBSD.org>2015-04-27 21:04:12 +0000
commiteb25564403d7385242b3d270dd5d76c4f66e9dcd (patch)
tree432cff6d3e5395b52d544e58df856d0f226ba122 /finance/electrum
parent61e130efc3a3b27945e296927936d5b3a2c5c1ef (diff)
downloadports-eb25564403d7385242b3d270dd5d76c4f66e9dcd.tar.gz
ports-eb25564403d7385242b3d270dd5d76c4f66e9dcd.zip
finance/electrum: Unbreak on DragonFly (staging)
Since the setup.py patch would never get sent upstream anyway, I modified the patch to install the desktop icons on every platform that ports supports unconditionally rather than check the OSNAME against a list. Issue was introduced on last commit Approved by: blanket (restore DF functionality)
Notes
Notes: svn path=/head/; revision=384877
Diffstat (limited to 'finance/electrum')
-rw-r--r--finance/electrum/files/patch-setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/finance/electrum/files/patch-setup.py b/finance/electrum/files/patch-setup.py
index dfd091a8f090..35e4e15d8e73 100644
--- a/finance/electrum/files/patch-setup.py
+++ b/finance/electrum/files/patch-setup.py
@@ -1,10 +1,12 @@
--- setup.py.orig 2015-03-14 13:27:54 UTC
+++ setup.py
-@@ -18,7 +18,7 @@ if sys.version_info[:3] < (2, 7, 0):
+@@ -17,8 +17,8 @@ if sys.version_info[:3] < (2, 7, 0):
+
data_files = []
- if platform.system() == 'Linux' or platform.system() == 'FreeBSD':
+-if platform.system() == 'Linux' or platform.system() == 'FreeBSD':
- usr_share = os.path.join(sys.prefix, "share")
++if True:
+ usr_share = '%%PREFIX%%/share'
data_files += [
(os.path.join(usr_share, 'applications/'), ['electrum.desktop']),