aboutsummaryrefslogtreecommitdiff
path: root/finance/emma
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-11-07 15:36:55 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-11-07 15:36:55 +0000
commitd08a486ae2bcf71839e606057766530805fdd506 (patch)
treefca9b426ae709bed8e6fe6196cc9ee164f7fcd74 /finance/emma
parent9f921bcc665517d5622569fea45a8b334206ae87 (diff)
downloadports-d08a486ae2bcf71839e606057766530805fdd506.tar.gz
ports-d08a486ae2bcf71839e606057766530805fdd506.zip
Add EMMA - a personal finance manager for GNOME.
Notes
Notes: svn path=/head/; revision=34879
Diffstat (limited to 'finance/emma')
-rw-r--r--finance/emma/Makefile41
-rw-r--r--finance/emma/distinfo1
-rw-r--r--finance/emma/files/patch-aa10
-rw-r--r--finance/emma/files/patch-ab10
-rw-r--r--finance/emma/files/patch-ac11
-rw-r--r--finance/emma/files/patch-ad10
-rw-r--r--finance/emma/files/patch-ae19
-rw-r--r--finance/emma/files/patch-af11
-rw-r--r--finance/emma/files/patch-ag19
-rw-r--r--finance/emma/files/patch-ah41
-rw-r--r--finance/emma/files/patch-ai11
-rw-r--r--finance/emma/files/patch-aj20
-rw-r--r--finance/emma/files/patch-ak20
-rw-r--r--finance/emma/files/patch-al11
-rw-r--r--finance/emma/pkg-comment1
-rw-r--r--finance/emma/pkg-descr22
-rw-r--r--finance/emma/pkg-plist55
17 files changed, 313 insertions, 0 deletions
diff --git a/finance/emma/Makefile b/finance/emma/Makefile
new file mode 100644
index 000000000000..a74968ec8543
--- /dev/null
+++ b/finance/emma/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: emma
+# Date created: 7 November 2000
+# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= emma
+PORTVERSION= 0.8.1
+CATEGORIES= misc gnome python
+MASTER_SITES= http://rainbow.mimuw.edu.pl/~la181249/emma/packages/
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.1/-1/}
+
+MAINTAINER= sobomax@FreeBSD.org
+
+BUILD_DEPENDS= automake:${PORTSDIR}/devel/automake
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/DateTime/DateTime.py:${PORTSDIR}/devel/py-mxDateTime
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:S/.1//}
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+USE_GNOME= yes
+USE_LIBTOOL= yes
+USE_PYTHON= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+pre-patch:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
+pre-configure:
+.for file in install-sh missing mkinstalldirs
+ ${LN} -sf ${LOCALBASE}/share/automake/${file} ${WRKSRC}/${file}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/finance/emma/distinfo b/finance/emma/distinfo
new file mode 100644
index 000000000000..3e9a4b6804c8
--- /dev/null
+++ b/finance/emma/distinfo
@@ -0,0 +1 @@
+MD5 (emma-0.8-1.tar.gz) = 7dc37a41b9fb2cfc69a3c1a3ac22f102
diff --git a/finance/emma/files/patch-aa b/finance/emma/files/patch-aa
new file mode 100644
index 000000000000..de34a1c5b9fc
--- /dev/null
+++ b/finance/emma/files/patch-aa
@@ -0,0 +1,10 @@
+--- ./src/date_entry.c 2000/11/07 11:19:50 1.1
++++ ./src/date_entry.c 2000/11/07 11:19:59
+@@ -3,7 +3,6 @@
+ #include <gnome.h>
+ #include "gnome-ucombo.h"
+
+-#include <langinfo.h>
+ #include <time.h>
+
+ #include "misc.h"
diff --git a/finance/emma/files/patch-ab b/finance/emma/files/patch-ab
new file mode 100644
index 000000000000..8479d52331bf
--- /dev/null
+++ b/finance/emma/files/patch-ab
@@ -0,0 +1,10 @@
+--- ./src/interface.c 2000/11/07 11:20:32 1.1
++++ ./src/interface.c 2000/11/07 11:20:40
+@@ -3,7 +3,6 @@
+
+ #include <gnome.h>
+
+-#include <langinfo.h>
+ #include <stdio.h>
+
+ #include <ctype.h>
diff --git a/finance/emma/files/patch-ac b/finance/emma/files/patch-ac
new file mode 100644
index 000000000000..e7660afe27d4
--- /dev/null
+++ b/finance/emma/files/patch-ac
@@ -0,0 +1,11 @@
+--- ./src/limit_dlg.c 2000/11/07 11:23:56 1.1
++++ ./src/limit_dlg.c 2000/11/07 11:24:08
+@@ -2,8 +2,6 @@
+
+ #include <gnome.h>
+
+-#include <langinfo.h>
+-
+ #include "acc_entry.h"
+ #include "date_entry.h"
+ #include "py_module.h"
diff --git a/finance/emma/files/patch-ad b/finance/emma/files/patch-ad
new file mode 100644
index 000000000000..e6923f45a7e6
--- /dev/null
+++ b/finance/emma/files/patch-ad
@@ -0,0 +1,10 @@
+--- ./src/misc.c 2000/11/07 11:24:41 1.1
++++ ./src/misc.c 2000/11/07 11:24:49
+@@ -2,7 +2,6 @@
+
+ #include <ctype.h>
+ #include <time.h>
+-#include <langinfo.h>
+
+ #include "data.h"
+
diff --git a/finance/emma/files/patch-ae b/finance/emma/files/patch-ae
new file mode 100644
index 000000000000..0c366dc127ff
--- /dev/null
+++ b/finance/emma/files/patch-ae
@@ -0,0 +1,19 @@
+--- ./src/prefs.c 2000/11/07 11:25:16 1.1
++++ ./src/prefs.c 2000/11/07 12:11:29
+@@ -3,7 +3,6 @@
+ #include <gnome.h>
+
+ #include <ctype.h>
+-#include <langinfo.h>
+
+ #include "interface.h"
+ #include "actions.h"
+@@ -116,7 +115,7 @@
+ gchar *path;
+ gchar *format;
+
+- path = g_strdup_printf("/emma/Misc/DateFormat=%s", nl_langinfo(D_FMT));
++ path = g_strdup_printf("/emma/Misc/DateFormat=%s", "%D");
+ format = gnome_config_get_string(path);
+
+ strncpy(misc_date_fmt, format, MISC_DATE_FMT_SIZE-1);
diff --git a/finance/emma/files/patch-af b/finance/emma/files/patch-af
new file mode 100644
index 000000000000..ea0d8c90adb2
--- /dev/null
+++ b/finance/emma/files/patch-af
@@ -0,0 +1,11 @@
+--- ./src/prefs_dlg.c 2000/11/07 12:12:14 1.1
++++ ./src/prefs_dlg.c 2000/11/07 12:12:23
+@@ -2,8 +2,6 @@
+
+ #include <gnome.h>
+
+-#include <langinfo.h>
+-
+ #include "limit_dlg.h"
+ #include "py_module.h"
+ #include "misc.h"
diff --git a/finance/emma/files/patch-ag b/finance/emma/files/patch-ag
new file mode 100644
index 000000000000..08210f036a82
--- /dev/null
+++ b/finance/emma/files/patch-ag
@@ -0,0 +1,19 @@
+--- src/py_module.c.orig Wed Nov 1 10:10:18 2000
++++ src/py_module.c Tue Nov 7 15:14:32 2000
+@@ -1,7 +1,6 @@
+ #include <config.h>
+
+ #include <ctype.h>
+-#include <langinfo.h>
+ #include <stdio.h>
+ #include <time.h>
+ #include <unistd.h>
+@@ -100,6 +99,8 @@
+ strcpy(tmp, g_get_home_dir());
+ strcat(tmp, "/.emma.py");
+ py_module_include_file(tmp, FALSE);
++
++ py_module_include_file(PREFIX "/share/gnome/emma/emma.py", FALSE);
+
+ py_module_include_file("/usr/share/emma.py", FALSE);
+ py_module_include_file("/usr/local/share/emma.py", FALSE);
diff --git a/finance/emma/files/patch-ah b/finance/emma/files/patch-ah
new file mode 100644
index 000000000000..f063d227450b
--- /dev/null
+++ b/finance/emma/files/patch-ah
@@ -0,0 +1,41 @@
+--- src/report_druid.c.orig Thu Nov 2 15:20:59 2000
++++ src/report_druid.c Tue Nov 7 15:02:22 2000
+@@ -1,6 +1,5 @@
+ #include <config.h>
+
+-#include <langinfo.h>
+ #include <math.h>
+
+ #include "date_entry.h"
+@@ -12,6 +11,10 @@
+
+ #include "report_druid.h"
+
++char *daynames[]={"Mon", "Tue", "Wed", "Thu", "Fri", "Sat", "Sun"};
++char *monthnames[]={"Jan", "Feb", "Mar", "Apr", "May", "Jun", "Jul", \
++ "Aug", "Sep", "Oct", "Nov", "Dec"};
++
+ /*
+ 0123456789012345678901234567890123456789012345678901234567890123456789012345678
+ */
+@@ -693,9 +696,9 @@
+ rgd = g_new(ReportGroupData, 1);
+
+ if (i == 6)
+- strcpy(rgd->label, nl_langinfo(ABDAY_1));
++ strcpy(rgd->label, daynames[6]);
+ else
+- strcpy(rgd->label, nl_langinfo(ABDAY_2 + i));
++ strcpy(rgd->label, daynames[i]);
+
+ snprintf(rgd->expr, PY_EXPRESSION_MAX_SIZE, "Weekday() == %d", i+1);
+
+@@ -711,7 +714,7 @@
+ ReportGroupData *rgd;
+ rgd = g_new(ReportGroupData, 1);
+
+- strcpy(rgd->label, nl_langinfo(ABMON_1+i));
++ strcpy(rgd->label, monthnames[i]);
+
+ snprintf(rgd->expr, PY_EXPRESSION_MAX_SIZE, "Month() == %d", i+1);
+
diff --git a/finance/emma/files/patch-ai b/finance/emma/files/patch-ai
new file mode 100644
index 000000000000..56b27d0b56d5
--- /dev/null
+++ b/finance/emma/files/patch-ai
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Tue Nov 7 15:25:26 2000
++++ src/Makefile.in Tue Nov 7 15:19:32 2000
+@@ -140,7 +140,7 @@
+
+
+ DEFS = @DEFS@ -I. -I$(srcdir) -I..
+-CPPFLAGS = @CPPFLAGS@
++CPPFLAGS = @CPPFLAGS@ -DPREFIX=\"@prefix@\"
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+ emma_OBJECTS = acc_entry.o account_dlg.o actions.o data.o date_entry.o \
diff --git a/finance/emma/files/patch-aj b/finance/emma/files/patch-aj
new file mode 100644
index 000000000000..803404888a30
--- /dev/null
+++ b/finance/emma/files/patch-aj
@@ -0,0 +1,20 @@
+--- data/standard.py 2000/11/07 14:27:11 1.1
++++ data/standard.py 2000/11/07 14:27:48
+@@ -48,7 +48,7 @@
+ "Example : CurDay()");
+
+ A = NormalisedTime()
+-FirstDayOfMonth = time.mktime(A[0], A[1], 1, A[3], A[4], A[5], A[6], A[7], A[8]);
++FirstDayOfMonth = time.mktime((A[0], A[1], 1, A[3], A[4], A[5], A[6], A[7], A[8]));
+
+ def CurMonth():
+ return emma.date() >= FirstDayOfMonth
+@@ -59,7 +59,7 @@
+ "Example : CurMonth()");
+
+ A = NormalisedTime()
+-FirstDayOfYear = time.mktime(A[0], 1, 1, A[3], A[4], A[5], A[6], A[7], A[8]);
++FirstDayOfYear = time.mktime((A[0], 1, 1, A[3], A[4], A[5], A[6], A[7], A[8]));
+
+ def CurYear():
+ return emma.date() >= FirstDayOfYear
diff --git a/finance/emma/files/patch-ak b/finance/emma/files/patch-ak
new file mode 100644
index 000000000000..194b1a11757e
--- /dev/null
+++ b/finance/emma/files/patch-ak
@@ -0,0 +1,20 @@
+--- data/date.py 2000/11/07 14:34:00 1.1
++++ data/date.py 2000/11/07 14:36:28
+@@ -57,7 +57,7 @@
+ return emma.date() >= this.ticks() and emma.date() < next.ticks()
+
+ emma.register_func("MonthExt",\
+- "Args: numMonths, offset\n\n",\
++ "Args: numMonths, offset\n\n"\
+ "Returns True if the transaction happened\n"\
+ "in the next <numMonths> months offset by\n"\
+ "<offset> weeks.\n\n"\
+@@ -72,7 +72,7 @@
+ return emma.date() >= this.ticks() and emma.date() < next.ticks()
+
+ emma.register_func("YearExt",\
+- "Args: numYears, offset\n\n",\
++ "Args: numYears, offset\n\n"\
+ "Returns True if the transaction happened in\n"\
+ "the next <numYears> year offset by <offset>\n"\
+ "years.\n\n"\
diff --git a/finance/emma/files/patch-al b/finance/emma/files/patch-al
new file mode 100644
index 000000000000..c6dc477ba2e8
--- /dev/null
+++ b/finance/emma/files/patch-al
@@ -0,0 +1,11 @@
+--- data/Makefile.in 2000/11/07 14:57:10 1.1
++++ data/Makefile.in 2000/11/07 14:57:34
+@@ -125,7 +125,7 @@
+ EXTRA_DIST = emma.py
+
+
+-pkgdata_DATA = $(LIMIT_EXTENSION) $(REPORT_FILTERS)
++pkgdata_DATA = $(LIMIT_EXTENSIONS) $(REPORT_FILTERS)
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ CONFIG_HEADER = ../config.h
+ CONFIG_CLEAN_FILES =
diff --git a/finance/emma/pkg-comment b/finance/emma/pkg-comment
new file mode 100644
index 000000000000..da3da484c47d
--- /dev/null
+++ b/finance/emma/pkg-comment
@@ -0,0 +1 @@
+A personal finance manager for Gnome
diff --git a/finance/emma/pkg-descr b/finance/emma/pkg-descr
new file mode 100644
index 000000000000..b3121d8b3ef5
--- /dev/null
+++ b/finance/emma/pkg-descr
@@ -0,0 +1,22 @@
+Emma is an Easy Money Management program for Gnome / Gtk+ similar to
+X-accountant, Quicken and MsMoney (these are registered trademarks of their
+respective owners).
+
+Emma allows you to keep track of your incomes and expenses. You can easily
+analyse where all your money came from or why your wallet is empty. Using
+embedded python interface you can extend Emma functions to make it even more
+useful.
+
+Features
+--------
+ o Hierarchical accounts
+ o Double-entry accounting
+ o Scheduled transactions
+ o Sorting of transactions
+ o Easy analysis of accounts through python interface
+ o Graphical charts to make analysis more fun
+ o Extendable through python interface
+ o Special dialog to edit python expressions
+ o Consistent look&feel of Gnome/Gtk+
+
+WWW: http://rainbow.mimuw.edu.pl/~la181249/emma/home.php3
diff --git a/finance/emma/pkg-plist b/finance/emma/pkg-plist
new file mode 100644
index 000000000000..f727fcc52927
--- /dev/null
+++ b/finance/emma/pkg-plist
@@ -0,0 +1,55 @@
+bin/emma
+share/gnome/apps/Applications/emma.desktop
+share/gnome/emma/date.py
+share/gnome/emma/emma.py
+share/gnome/emma/report_gnuplot.py
+share/gnome/emma/report_grace.py
+share/gnome/emma/standard.py
+share/gnome/help/emma/C/accounts.html
+share/gnome/help/emma/C/book1.html
+share/gnome/help/emma/C/c21.html
+share/gnome/help/emma/C/c26.html
+share/gnome/help/emma/C/c61.html
+share/gnome/help/emma/C/docbook.css
+share/gnome/help/emma/C/files.html
+share/gnome/help/emma/C/images/acc_axis_dlg.gif
+share/gnome/help/emma/C/images/accountdlg.gif
+share/gnome/help/emma/C/images/filedlg.gif
+share/gnome/help/emma/C/images/grp_axis_dlg.gif
+share/gnome/help/emma/C/images/newfile.gif
+share/gnome/help/emma/C/images/transactiondlg.gif
+share/gnome/help/emma/C/limits.html
+share/gnome/help/emma/C/ln14.html
+share/gnome/help/emma/C/reports.html
+share/gnome/help/emma/C/scheduled-transactions.html
+share/gnome/help/emma/C/topic.dat
+share/gnome/help/emma/C/transactions.html
+share/gnome/help/emma/C/x44.html
+share/gnome/help/emma/ja/accounts.html
+share/gnome/help/emma/ja/book1.html
+share/gnome/help/emma/ja/c21.html
+share/gnome/help/emma/ja/c26.html
+share/gnome/help/emma/ja/c58.html
+share/gnome/help/emma/ja/docbook.css
+share/gnome/help/emma/ja/files.html
+share/gnome/help/emma/ja/images/accountdlg.gif
+share/gnome/help/emma/ja/images/filedlg.gif
+share/gnome/help/emma/ja/images/newfile.gif
+share/gnome/help/emma/ja/images/transactiondlg.gif
+share/gnome/help/emma/ja/limits.html
+share/gnome/help/emma/ja/ln14.html
+share/gnome/help/emma/ja/scheduled-transactions.html
+share/gnome/help/emma/ja/topic.dat
+share/gnome/help/emma/ja/transactions.html
+share/gnome/help/emma/ja/x44.html
+share/locale/de/LC_MESSAGES/emma.mo
+share/locale/fr/LC_MESSAGES/emma.mo
+share/locale/ja/LC_MESSAGES/emma.mo
+share/locale/pl/LC_MESSAGES/emma.mo
+share/locale/sv/LC_MESSAGES/emma.mo
+@dirrm share/gnome/help/emma/ja/images
+@dirrm share/gnome/help/emma/ja
+@dirrm share/gnome/help/emma/C/images
+@dirrm share/gnome/help/emma/C
+@dirrm share/gnome/help/emma
+@dirrm share/gnome/emma