aboutsummaryrefslogtreecommitdiff
path: root/finance/ledger/Makefile
diff options
context:
space:
mode:
authorDaniel Harris <dannyboy@FreeBSD.org>2005-07-03 16:37:59 +0000
committerDaniel Harris <dannyboy@FreeBSD.org>2005-07-03 16:37:59 +0000
commita683b2c98d5081a050ccccf0d43641899e88d611 (patch)
tree35a94ddb04a6e42abb86d6e16deccc8ad379f207 /finance/ledger/Makefile
parent043e45ad085b50ecdd2aa92cb2105f8283c1c454 (diff)
downloadports-a683b2c98d5081a050ccccf0d43641899e88d611.tar.gz
ports-a683b2c98d5081a050ccccf0d43641899e88d611.zip
'Ledger' is a command-line accounting program, which uses a simple text file
as a ledger, yet provides powerful facilities for working with commodities, accounts, transactions, etc. It will read Gnucash data files directly. PR: 82685 Submitted by: Woody Carey <woodycarey@hotmail.com>
Notes
Notes: svn path=/head/; revision=138420
Diffstat (limited to 'finance/ledger/Makefile')
-rw-r--r--finance/ledger/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/finance/ledger/Makefile b/finance/ledger/Makefile
new file mode 100644
index 000000000000..2e38620bdbb6
--- /dev/null
+++ b/finance/ledger/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: ledger
+# Date created: June 25th, 2005
+# Whom: wcarey
+#
+# $FreeBSD$
+#
+
+PORTNAME= ledger
+PORTVERSION= 2.3
+CATEGORIES= finance
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED} \
+ http://www.badplandude.com/~wcarey/ledger/
+MASTER_SITE_SUBDIR=ledger
+
+MAINTAINER= woodycarey@hotmail.com
+COMMENT= John Wiegley's command line accounting program
+
+LIB_DEPENDS= gmp:${PORTSDIR}/math/libgmp4 \
+ pcre:${PORTSDIR}/devel/pcre \
+ xmltok:${PORTSDIR}/www/libwww \
+ xmlparse:${PORTSDIR}/www/libwww
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= CPPFLAGS="-I${PREFIX}/include" LDFLAGS="-L${PREFIX}/lib"
+
+NO_INSTALL_MANPAGES= yes
+INFO= ledger
+
+# we need to write our own do-install, as the configure script produces
+# a Makefile which respects $prefix, not ${PREFIX} during the install
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/ledger.info ${PREFIX}/info/
+ ${INSTALL_PROGRAM} ${WRKSRC}/ledger ${PREFIX}/bin/
+ ${INSTALL_DATA} ${WRKSRC}/libledger.a ${PREFIX}/lib/
+ ${MKDIR} ${PREFIX}/include/ledger
+ ${INSTALL_DATA} ${WRKSRC}/*.h ${PREFIX}/include/ledger/
+ ${MKDIR} ${EXAMPLESDIR}
+ ${MKDIR} ${EXAMPLESDIR}/scripts
+ ${INSTALL_SCRIPT} ${WRKSRC}/scripts/* ${EXAMPLESDIR}/scripts/
+ ${INSTALL_DATA} ${WRKSRC}/sample.dat ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/setup.py ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ledger.el ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ledger.vim ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ledger.texi ${EXAMPLESDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/main.py ${EXAMPLESDIR}
+
+post-install:
+ ${CAT} pkg-message
+
+.include <bsd.port.mk>