aboutsummaryrefslogtreecommitdiff
path: root/finance/libofx/Makefile
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-02-17 21:31:17 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-02-17 21:31:17 +0000
commitfd33828961e4fe1ea0da53baaba9836fff73ed1f (patch)
tree07398d77f36b5dd459f2cca27edc760b3c42d4a4 /finance/libofx/Makefile
parent76569348dfb3793517ab9307581b9c39a12eab4d (diff)
downloadports-fd33828961e4fe1ea0da53baaba9836fff73ed1f.tar.gz
ports-fd33828961e4fe1ea0da53baaba9836fff73ed1f.zip
- Update to 0.9.2
- Pass maintainership to submitter - Mark MAKE_JOBS_SAFE - Add LICENSE (GPLv2) - Remove MD5 checksum PR: ports/154783 Submitted by: Jason E. Hale <bsdkaffee@gmail.com>
Notes
Notes: svn path=/head/; revision=269290
Diffstat (limited to 'finance/libofx/Makefile')
-rw-r--r--finance/libofx/Makefile20
1 files changed, 16 insertions, 4 deletions
diff --git a/finance/libofx/Makefile b/finance/libofx/Makefile
index e7f4534a0326..36a6ac98d971 100644
--- a/finance/libofx/Makefile
+++ b/finance/libofx/Makefile
@@ -6,12 +6,11 @@
#
PORTNAME= libofx
-PORTVERSION= 0.9.1
-PORTREVISION= 4
+PORTVERSION= 0.9.2
CATEGORIES= finance
MASTER_SITES= SF
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= bsdkaffee@gmail.com
COMMENT= OpenSource implementation of the OFX (Open Financial eXchange)
LIB_DEPENDS= curl.6:${PORTSDIR}/ftp/curl \
@@ -24,19 +23,32 @@ USE_AUTOTOOLS= aclocal autoheader automake autoconf libtool
ACLOCAL_ARGS= -I m4
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-doxygen --disable-dot --disable-gengetopt \
- --with-opensp-includes=${LOCALBASE}/include/OpenSP
+ --with-opensp-includes=${LOCALBASE}/include/OpenSP \
+ --with-opensp-libs=${LOCALBASE}/lib
+MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+PORTDOCS= *
+
+OPTIONS= APIDOC "Install full API documentation" off
+
+.include <bsd.port.options.mk>
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for file in AUTHORS ChangeLog INSTALL NEWS README totest.txt
${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
+.if defined(WITH_APIDOC)
@(cd ${WRKSRC}/doc; ${COPYTREE_SHARE} html ${DOCSDIR})
.endif
+.endif
.include <bsd.port.mk>