aboutsummaryrefslogtreecommitdiff
path: root/finance/odoo
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-05-07 06:12:24 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-05-07 06:12:24 +0000
commita20fb3da2f52b9310c5328443a91ba3966104fb1 (patch)
tree781bb948b501a020ad501d186569cfc278d952a5 /finance/odoo
parentc2c985c0c7a80ad42f08f06e2a23078f08809c58 (diff)
Fix PKGNAME collision, dependencies and python version requirement
Notes
Notes: svn path=/head/; revision=534245
Diffstat (limited to 'finance/odoo')
-rw-r--r--finance/odoo/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/finance/odoo/Makefile b/finance/odoo/Makefile
index e5bc33d3f99a..cb27eb8dd825 100644
--- a/finance/odoo/Makefile
+++ b/finance/odoo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= odoo
PORTVERSION= 13.0
CATEGORIES= finance www
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= acm@FreeBSD.org
COMMENT= Suite of web based open source business apps
@@ -34,7 +35,7 @@ RUN_DEPENDS= wkhtmltopdf>0:converters/wkhtmltopdf \
${PYTHON_PKGNAMEPREFIX}pytz>=0:devel/py-pytz@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}usb>=0:devel/py-usb@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}vatnumber>=0:finance/py-vatnumber@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR} \
+ ${PY_PILLOW} \
${PYTHON_PKGNAMEPREFIX}pydot>=0:graphics/py-pydot@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ldap>=0:net/py-ldap@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}zeep>=0:net/py-zeep@${PY_FLAVOR} \
@@ -62,7 +63,7 @@ RUN_DEPENDS= wkhtmltopdf>0:converters/wkhtmltopdf \
${PYTHON_PKGNAMEPREFIX}ofxparse>=0.20:finance/py-ofxparse@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}ebaysdk>=2.1.3:finance/py-ebaysdk@${PY_FLAVOR}
-USES= python pgsql shebangfix
+USES= python:3.5+ pgsql shebangfix
USE_PYTHON= distutils
USE_OPENLDAP= yes