aboutsummaryrefslogtreecommitdiff
path: root/finance/p5-Finance-Currency-Convert-XE/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2004-12-15 06:39:24 +0000
committerAnton Berezin <tobez@FreeBSD.org>2004-12-15 06:39:24 +0000
commit65e33f1c052efb58ebf8874c9107351e10e0cc27 (patch)
treeb5914f62b7fc9caf9646b18b4fca6b3b38266433 /finance/p5-Finance-Currency-Convert-XE/Makefile
parent487941771b7330f14c8ae4e8460c2811b2422c34 (diff)
downloadports-65e33f1c052efb58ebf8874c9107351e10e0cc27.tar.gz
ports-65e33f1c052efb58ebf8874c9107351e10e0cc27.zip
Add p5-Finance-Currency-Convert-XE, a currency conversion module that
uses XE.com.
Notes
Notes: svn path=/head/; revision=124071
Diffstat (limited to 'finance/p5-Finance-Currency-Convert-XE/Makefile')
-rw-r--r--finance/p5-Finance-Currency-Convert-XE/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/finance/p5-Finance-Currency-Convert-XE/Makefile b/finance/p5-Finance-Currency-Convert-XE/Makefile
new file mode 100644
index 000000000000..be388141bc6b
--- /dev/null
+++ b/finance/p5-Finance-Currency-Convert-XE/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: finance/p5-Finance-Currency-Convert-XE
+# Date created: 10 December 2004
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Finance-Currency-Convert-XE
+PORTVERSION= 0.06
+CATEGORIES= finance perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Finance
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Finance::Currency::Convert::XE - Currency conversion module
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/${PERL_ARCH}/HTML/TokeParser.pm:${PORTSDIR}/www/p5-HTML-Parser \
+ ${SITE_PERL}/WWW/Mechanize.pm:${PORTSDIR}/www/p5-WWW-Mechanize
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Finance::Currency::Convert::XE.3
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ ${PERL} -pi \
+ -e 's/5.006/5.004/;' \
+ -e '$$_="" if /use warnings/;' \
+ ${WRKSRC}/lib/Finance/Currency/Convert/XE.pm
+
+.include <bsd.port.post.mk>