aboutsummaryrefslogtreecommitdiff
path: root/finance/py-python-binance
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2023-04-09 18:55:35 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2023-04-09 18:55:57 +0000
commit0315c33dd32c59cca059b4f234632dcd35f4e3bf (patch)
treeaa691b1e0715dfbeca79ff74a47b3b12eb270014 /finance/py-python-binance
parentb3dbca0e80ef09328e4b34cee95e6f6f7ef34a6b (diff)
downloadports-0315c33dd32c59cca059b4f234632dcd35f4e3bf.tar.gz
ports-0315c33dd32c59cca059b4f234632dcd35f4e3bf.zip
finance/py-python-binance: New port: Binance REST API python implementation
Diffstat (limited to 'finance/py-python-binance')
-rw-r--r--finance/py-python-binance/Makefile27
-rw-r--r--finance/py-python-binance/distinfo3
-rw-r--r--finance/py-python-binance/pkg-descr4
3 files changed, 34 insertions, 0 deletions
diff --git a/finance/py-python-binance/Makefile b/finance/py-python-binance/Makefile
new file mode 100644
index 000000000000..612f9b39df70
--- /dev/null
+++ b/finance/py-python-binance/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= python-binance
+DISTVERSION= 1.0.17
+CATEGORIES= finance python
+MASTER_SITES= PYPI
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Binance REST API python implementation
+WWW= https://python-binance.readthedocs.io/en/latest/
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}aiohttp>=3.8:www/py-aiohttp@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dateparser>0:devel/py-dateparser@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycryptodome>0:security/py-pycryptodome@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}ujson>0:devel/py-ujson@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}websockets>0:devel/py-websockets@${PY_FLAVOR}
+
+USES= python:3.5+
+USE_PYTHON= distutils autoplist
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/finance/py-python-binance/distinfo b/finance/py-python-binance/distinfo
new file mode 100644
index 000000000000..a5f7c55ab387
--- /dev/null
+++ b/finance/py-python-binance/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1681065857
+SHA256 (python-binance-1.0.17.tar.gz) = 364a0ff0d2892867d6851d90e8567c54a194fc62783f20da766a5c7655f57746
+SIZE (python-binance-1.0.17.tar.gz) = 68466
diff --git a/finance/py-python-binance/pkg-descr b/finance/py-python-binance/pkg-descr
new file mode 100644
index 000000000000..a08fd3c9f213
--- /dev/null
+++ b/finance/py-python-binance/pkg-descr
@@ -0,0 +1,4 @@
+python-binance is an unofficial Python wrapper for the Binance exchange REST
+API v3. I am in no way affiliated with Binance, use at your own risk.
+
+It is suitable to automate interactions with Binance.