aboutsummaryrefslogtreecommitdiff
path: root/finance/trytond28_product
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-11-20 17:20:57 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-11-20 17:20:57 +0000
commit6c6b72523502135a007ede6386683dc7f8d12905 (patch)
tree7fd4486a5fe95dc1c0f49e540a7a050e82c16883 /finance/trytond28_product
parentc9c7d169004f833c98fb9417e8dced9263b64219 (diff)
downloadports-6c6b72523502135a007ede6386683dc7f8d12905.tar.gz
ports-6c6b72523502135a007ede6386683dc7f8d12905.zip
. svn copy tryton -> tryton28 ports;
. update tryton28 ports; [1] . connect tryton28 ports to build; . register conflicts at tryton ports. PR: ports/181691 [1] Submitted by: Matthias Petermann <matthias@petermann-it.de> [1] Approved by: Matthias Petermann <matthias@petermann-it.de>
Notes
Notes: svn path=/head/; revision=334432
Diffstat (limited to 'finance/trytond28_product')
-rw-r--r--finance/trytond28_product/Makefile24
-rw-r--r--finance/trytond28_product/distinfo2
-rw-r--r--finance/trytond28_product/pkg-descr4
-rw-r--r--finance/trytond28_product/pkg-plist60
4 files changed, 90 insertions, 0 deletions
diff --git a/finance/trytond28_product/Makefile b/finance/trytond28_product/Makefile
new file mode 100644
index 000000000000..3f002571c806
--- /dev/null
+++ b/finance/trytond28_product/Makefile
@@ -0,0 +1,24 @@
+# Created by: Matthias Petermann <matthias@petermann-it.de>
+# $FreeBSD$
+
+PORTNAME= trytond28_product
+PORTVERSION= 2.8.0
+CATEGORIES= finance python
+MASTER_SITES= https://pypi.python.org/packages/source/t/trytond_product/ \
+ http://downloads.tryton.org/${PORTVERSION:R}/
+DISTNAME= trytond_product-${PORTVERSION}
+
+MAINTAINER= matthias@petermann-it.de
+COMMENT= Tryton Application Platform (Product Module)
+
+LICENSE= GPLv3
+
+RUN_DEPENDS= trytond28>=2.8.2:${PORTSDIR}/finance/trytond28
+
+CONFLICTS= trytond_product-2.[46].*
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=easy_install
+PYEASYINSTALL_EGG=${DISTNAME}-py${PYTHON_VER}${PYEASYINSTALL_OSARCH}.egg
+
+.include <bsd.port.mk>
diff --git a/finance/trytond28_product/distinfo b/finance/trytond28_product/distinfo
new file mode 100644
index 000000000000..9898fa5401af
--- /dev/null
+++ b/finance/trytond28_product/distinfo
@@ -0,0 +1,2 @@
+SHA256 (trytond_product-2.8.0.tar.gz) = 3cce365b382f18c01a13758445c7d15b4be2633cd6a09700b98c2c1bdf591f7c
+SIZE (trytond_product-2.8.0.tar.gz) = 44604
diff --git a/finance/trytond28_product/pkg-descr b/finance/trytond28_product/pkg-descr
new file mode 100644
index 000000000000..83a7f7cb3c15
--- /dev/null
+++ b/finance/trytond28_product/pkg-descr
@@ -0,0 +1,4 @@
+trytond_product is the product module for tryton, it define products,
+categories of product, units of measure, categories of units of measure.
+
+WWW: http://www.tryton.org/
diff --git a/finance/trytond28_product/pkg-plist b/finance/trytond28_product/pkg-plist
new file mode 100644
index 000000000000..08698efce778
--- /dev/null
+++ b/finance/trytond28_product/pkg-plist
@@ -0,0 +1,60 @@
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/PKG-INFO
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/SOURCES.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/dependency_links.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/entry_points.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/not-zip-safe
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/requires.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO/top_level.txt
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/category.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/category.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/category.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/category.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/icons/tryton-product.svg
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/locale/bg_BG.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/locale/ca_ES.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/locale/cs_CZ.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/locale/de_DE.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/locale/es_AR.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/locale/es_CO.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/locale/es_ES.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/locale/fr_FR.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/locale/nl_NL.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/locale/ru_RU.po
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/product.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/product.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/product.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/product.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/tests/__init__.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/tests/__init__.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/tests/__init__.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/tests/test_product.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/tests/test_product.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/tests/test_product.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/tryton.cfg
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/uom.py
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/uom.pyc
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/uom.pyo
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/uom.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/view/category_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/view/category_list.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/view/category_tree.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/view/product_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/view/product_tree.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/view/template_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/view/template_tree.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/view/uom_category_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/view/uom_category_tree.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/view/uom_form.xml
+%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/view/uom_tree.xml
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/view
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/tests
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/locale
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product/icons
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules/product
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond/modules
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/trytond
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%