aboutsummaryrefslogtreecommitdiff
path: root/finance
diff options
context:
space:
mode:
authorYen-Ming Lee <leeym@FreeBSD.org>2008-08-31 03:44:30 +0000
committerYen-Ming Lee <leeym@FreeBSD.org>2008-08-31 03:44:30 +0000
commit2c65a867fb053b42a2ec3980300b7ada74d97f34 (patch)
tree42cd7658296524ea0f625bd668d8166838f84ce2 /finance
parent1ed1b09b07c1d08b18541fad9335342162d0590a (diff)
downloadports-2c65a867fb053b42a2ec3980300b7ada74d97f34.tar.gz
ports-2c65a867fb053b42a2ec3980300b7ada74d97f34.zip
- simplify dependency
- bump PORTREVISION
Notes
Notes: svn path=/head/; revision=219500
Diffstat (limited to 'finance')
-rw-r--r--finance/p5-Finance-QuoteHist/Makefile21
1 files changed, 13 insertions, 8 deletions
diff --git a/finance/p5-Finance-QuoteHist/Makefile b/finance/p5-Finance-QuoteHist/Makefile
index b34d2d1153c3..765069721b29 100644
--- a/finance/p5-Finance-QuoteHist/Makefile
+++ b/finance/p5-Finance-QuoteHist/Makefile
@@ -7,6 +7,7 @@
PORTNAME= Finance-QuoteHist
PORTVERSION= 1.11
+PORTREVISION= 1
CATEGORIES= finance perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -14,13 +15,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl module for fetching historical stock quotes
-RUN_DEPENDS= ${SITE_PERL}/Date/Manip.pm:${PORTSDIR}/devel/p5-Date-Manip \
- ${SITE_PERL}/HTTP/Request.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/${PERL_ARCH}/Text/CSV_XS.pm:${PORTSDIR}/textproc/p5-Text-CSV_XS \
- p5-HTML-TableExtract>=2.07:${PORTSDIR}/www/p5-HTML-TableExtract
-BUILD_DEPENDS= ${RUN_DEPENDS}
-BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple \
- ${SITE_PERL}/${PERL_ARCH}/File/Spec.pm:${PORTSDIR}/devel/p5-PathTools
+RUN_DEPENDS= p5-Date-Manip>=0:${PORTSDIR}/devel/p5-Date-Manip \
+ p5-HTML-TableExtract>=2.07:${PORTSDIR}/www/p5-HTML-TableExtract \
+ p5-Text-CSV_XS>=0:${PORTSDIR}/textproc/p5-Text-CSV_XS \
+ p5-URI>=0:${PORTSDIR}/net/p5-URI \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
PERL_CONFIGURE= yes
@@ -33,4 +32,10 @@ MAN3= Finance::QuoteHist.3 \
Finance::QuoteHist::Google.3 \
Finance::QuoteHist::BusinessWeek.3 \
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500703
+RUN_DEPENDS+= p5-MIME-Base64>=0:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.include <bsd.port.post.mk>